Browsing nokia e65 buggy

Bug #164454 reported by Anders Østerholt
10
Affects Status Importance Assigned to Milestone
OBEX FTP Client for GNOME-VFS
Fix Released
Undecided
Unassigned
gnome-vfs-obexftp (Ubuntu)
Fix Released
Low
Unassigned

Bug Description

Binary package hint: gnome-vfs-obexftp

When browsing the phone it sometimes manages to go through c: data and a few more. At some point the opening of a new directory stops working and directories are displayed as blank files.

Disconnecting and reconnecting the bluetooth connection in the phones bluetooth menu seems to fix it for a while.

Seems to be browsing that is broken, while file transfer works fine.

Revision history for this message
impact (impact-atlas) wrote :

Same problem, but with a Nokia E50. First, it displays both the phone memory (C:) and the phone memory card (E:) fine. Suddenly during browsing, Nautilus complains that it can't display a folder and the folder icon changes into a file icon. After pressing refresh/reload in Nautilus, the icon of the folder usually vanishes completely and Nautilus throws up two error messages - both saying that it cannot display the folder.

If I wait a short while (a minute or two) it starts working again - I don't have to turn BT off - just wait.

Changed in gnome-vfs-obexftp:
status: New → Confirmed
importance: Undecided → Low
Revision history for this message
Leszek Koltunski (leszek-3miasto) wrote :

Try the package with Nautilus workaround compiled in:

https://bugs.launchpad.net/gnome-vfs-obexftp/+bug/140478

Revision history for this message
impact (impact-atlas) wrote :

Thanks for the suggestion. Unfortunately the package is not compatible with my x86_64 bit system, I am unable to install it.

Revision history for this message
fazulas (fizolas) wrote :

Same problem here with Debian lenny updated today (amd64), using a Nokia E51. Obexftp in the command line seems to work fine, but gnome-vfs-obexftp 0.4-1 (using Nautilus) behaves mostly in the same way as described in the first post of this thread. The problems seem to begin when browsing backwards (i.e. traversing down a directory), but there are some other random odd behaviours too: sometimes the initial window won't show both the phone memory (C:) and the card memory (E:), but just one of them.

Revision history for this message
fazulas (fizolas) wrote :

Recompiling the package with the Nautilus workaround enabled works for me, thanks! I'm attaching my .deb file in case it is useful for someone.

Revision history for this message
Thomas Hotz (thotz-deactivatedaccount) wrote :

Your Ubuntu version is EOL. Does this still happen under supported Ubuntu versions? Thank you!

Changed in gnome-vfs-obexftp (Ubuntu):
status: Confirmed → Incomplete
Changed in gnome-vfs-obexftp:
status: New → Incomplete
status: Incomplete → New
Revision history for this message
fazulas (fizolas) wrote :

Hi,

I have just checked browsing Nokia 6131, Nokia E52 and Nokia E63 over Bluetooth using Debian Squeeze and Ubuntu 11.10 and everything works fine for me now.

Thanks!

Changed in gnome-vfs-obexftp (Ubuntu):
status: Incomplete → Fix Released
Changed in gnome-vfs-obexftp:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers