OBEX FTP Client for GNOME-VFS

Support OBEX FTP over USB

Reported by James Henstridge on 2007-06-11
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OBEX FTP Client for GNOME-VFS
Wishlist
Unassigned
Open Obex
New
Unknown
gnome-vfs-obexftp (Debian)
Fix Released
Unknown

Bug Description

Some people seem to use OBEX FTP over USB. If it isn't difficult, it'd be nice to support it.

Things that need to be addressed include:

 * how do you discover USB devices that can do this?
 * how do you establish a connection to such devices?

Changed in gnome-vfs-obexftp:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
James Henstridge (jamesh) wrote :

Had another go at using OBEX over USB with my phone -- it looks like it was a simple permissions error stopping it from working previously, so I do have hardware that can test this.

It looks like the openobex interface for setting up USB connections is quite primitive though:

 * The API only gives you a list of the discovered connections, then lets you pick one to connect to.
 * For my phone, I get three possible OBEX endpoints discovered (all of which appear to act the same).
 * It doesn't seem to provide any way of mapping back from the discovered interface to the USB device.

So this makes it tricky to do useful things like asking HAL to notify us as interesting USB devices come and go, since we can't then use that data to establish a connection.

Changed in gnome-vfs-obexftp:
status: Unknown → Unconfirmed
Changed in openobex:
status: Unknown → New
Changed in gnome-vfs-obexftp (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.