Personal file sharing preferences dialog does not offer to install needed packages

Reported by José Luis Ricón on 2010-03-10
462
This bug affects 100 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Medium
John Lea
gnome-user-share
New
Undecided
Unassigned
gnome-user-share (Ubuntu)
Medium
Unassigned
Nominated for Lucid by Darius Kulikauskas

Bug Description

Binary package hint: nautilus

What happens -> I open the Personal file sharing preferences dialog via system-preferences or via nautilus, and Im told that the network sharing feature can not be enabled because the required packages are not on your pc.
I, as a tech user, went to synaptic, found the package, looked for its recommends and got the functionality.
A normal user wont be able to do so, and so a button to install those packages is needed for usabilty's sake.

----------------------------------------------

Desired resolution:

- Change the "Sharing Options" text in them Nautilus right click folder menu to "Local network share"
- Change the 'Share' tab title text in the Nautilus 'Properties' window to "Local network share"

José Luis Ricón (artirj) wrote :
Chris Coulson (chrisccoulson) wrote :

Thank you for your bug report. This was on my radar already when i changed gnome-user-share to make it cope without having apache, but I just haven't gotten round to it yet.

affects: nautilus (Ubuntu) → gnome-user-share (Ubuntu)
Changed in gnome-user-share (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → Low
status: New → Triaged
Mike Rushton (leftyfb) wrote :

@Chris Coulson

You know I filed #525172 almost 3 weeks ago right? Not sure why this bug gets noticed now and the original marked as a duplicate.

Chris Coulson (chrisccoulson) wrote :

That's just the way it happens sometimes, I'm not sure why that's a problem for you. And there's no need to post what is basically the same comment to both bugs.

I set the other bug as duplicated and not this one because Chris has commented on this one.
This not really a problem as at the end the result 'll be the same.

... and the package needed to install is what?

I'm old time linux user, but new to ubuntu/debian style distros. I did a cursory search of synaptic for personal file sharing, and came up with nothing.

For the record, installing apache2 fixed this.

... and also for the record, once installed, everything works as expect *and* there's nice UI options for sharing from the file manager (nautilus). Great!

Detlef Lechner (detlef-lechner) wrote :

It is bad program usabilty to provide a menu option by default and tell users that "This feature cannot be enabled because the required packages are not installed on your system."
Rather, the Ubuntu maintainers should make sure that Ubuntu provides the required packages by default.

Detlef Lechner (detlef-lechner) wrote :

s/provides/installs/

I do not think that it is a good idea to require to install the 2 large packages apache2.2-bin and lib-apche2-mod-dnssd just to make Share Files over the Network possible.

On Sat, Apr 10, 2010 at 2:07 PM, Detlef Lechner <email address hidden> wrote:
> I do not think that it is a good idea to require to install the 2 large
> packages apache2.2-bin and lib-apche2-mod-dnssd just to make Share Files
> over the Network possible.

Detlef,

could you avoid mixing problem on the same bug; furthermore,
apache2.2-bin is not a big package:
== apache2.2-bin ==
Installed-Size: 3764
Size: 1399724
== libapache2-mod-dnssd ==
Installed-Size: 100
Size: 14692
== apache2.2-common ==
Installed-Size: 2104
Size: 285202

So that's not a big deal.

--
Baptiste Mille-Mathias
Les gens heureux ne sont pas pressés

hasan adil (hasank2) wrote :

I just came across this issue and it really is very frustrating. A preference should not be available if the feature isn't even installed.

If you go to software center and search "Personal File sharing", it will you everything is installed which is even worse since then the end user is really confused. Win, Mac also do file sharing and its far less of a headache.

Jack Leigh (leighman) wrote :

Also encountering the problem. It telling you the packages are not installed is completely useless. It should tell you what to install or offer to do so.

Chris Coulson (chrisccoulson) wrote :

This is already on my list of things to do. There's no need to add a papercut task for this bug

Changed in hundredpapercuts:
status: New → Invalid

Baptiste Mille-Mathias: I did not mix up things. I wrote here because I am affected by the same error that José Luis Ricón reported.
This error persists up to now (2010-05-18).
Consider the other remark which I made as an supplement.

Jordan Farrell (wolfrage) wrote :

    I have some questions for the developer of gnome-share. So are we not going to be using Samba in the future to share files? If so will the method using Apache to share files still be able to share with windows systems? Is the method using Apache as advanced as the Samba project or are we recreating the wheel here?
    I ask because my attempt to share files between two Ubuntu machines failed so I took the route that I posted here: http://ubuntuforums.org/showthread.php?t=1502265
    My method does provide the added benefit of being able to exchange with windoz systems and even virtual windoz systems.

I have installed all necessary dependencies in the above posts. But still not able to share. The network location shows but nothing is in it although i have assigned permissions to the folders I want to share.

Alan Weeks (aweeks1) wrote :

I had spent hours trying to re-establish my network to XP after upgrading 8.04 to 10.04, but with increasing frustration.

Luckily I found "macpablosramblings" who explains the prob & the fix.

Even now, the network is only working partially ---XP HOme to Ubuntu only.

As a Ubuntu user, not a techie, I am not at all clear regarding networking L-L 10.04.

Perhaps a real pro could write a "how to..." in simple, step-by-step format??

Kangarooo Jānis (kangarooo) wrote :

still exists in 10.10
also in 10.10 i have to install bluez and gnome-bluetooth to make even bluetooth start.

Kangarooo Jānis (kangarooo) wrote :

still getting that messege.
Also i found http://macpablodesigns.wordpress.com/2010/05/01/enable-personal-file-sharing-in-ubuntu-10-04/
so i installed apache2 & libapache2-mod-dnssd didnt help. even after restart.

Hu Kai (kay-hu) wrote :

  I've already installed apache2 & libapache2-mod-dnssd in 10.10, and there is no Personal File Sharing under System-Preferences, seems the workaround for 10.04 doesn't work in 10.10.

Anyone resolved this problem?

> I've already installed apache2 & libapache2-mod-dnssd in 10.10, and
> there is no Personal File Sharing under System-Preferences, seems the
> workaround for 10.04 doesn't work in 10.10.
>
> Anyone resolved this problem?
>

AFAIK, gnome-user-share is not installed in 10.10 by default. You can
install it from universe.

But your problem is *not* what this bug is about.

This bug is about the program not offering to install the packages it
needs to perform its primary function.

Chih-Hsyuan Ho (chih) wrote :

In order to be able to receive files through Bluetooth, this package (Personal File Sharing) is required. It is seemingly installed in 10.04 (and probably all releases before it), no idea why it is not the case with 10.10. It simply does not make any sense!

fabioamd87 (fabioamd87) wrote :

sharing through network is working? I've the option disabled...

Martin Pitt (pitti) on 2011-02-15
Changed in gnome-user-share (Ubuntu):
assignee: Chris Coulson (chrisccoulson) → nobody
Josh Leverette (coder543) wrote :

this is still a bug in Natty

Eric Appleman (erappleman) wrote :

Confirm on Oneiric too.

John Lea (johnlea) on 2011-06-20
description: updated
tags: added: udo
Changed in hundredpapercuts:
assignee: nobody → John Lea (johnlea)
importance: Undecided → High
status: Invalid → Fix Committed
Changed in ayatana-design:
assignee: nobody → John Lea (johnlea)
Changed in hundredpapercuts:
status: Fix Committed → New
importance: High → Undecided
Changed in ayatana-design:
importance: Undecided → High
status: New → Fix Committed
Changed in hundredpapercuts:
assignee: John Lea (johnlea) → nobody
John Lea (johnlea) on 2011-06-30
Changed in ayatana-design:
status: Fix Committed → Fix Released
tags: added: desktop-oneiric-ux
jay (jayheimang) wrote :

It appears this issue is resolved. But then why did I just upgrade to 11.04 and am unable to "Share Files over the Network" because "... the required packages are not installed ... ". And there's no option to install them.

Isn't that what this thread was discussing?
If not, my apologies and - Where should I be looking?

Didier Roche (didrocks) wrote :

Setting as invalid, the menu doesn't seem there in Oneiric.
@Eric: can you confirm you still see it in oneiric with a default install?

Changed in gnome-user-share (Ubuntu):
status: Triaged → Invalid
Omar (omar-w-kh) wrote :

I have this problem in 11.04.

To me this is still a problem in 11.10 beta2. As in #27 for 11.04.

John Lea (johnlea) wrote :

Reproduced issue with Oneiric, so re-set as Confirmed

Changed in gnome-user-share (Ubuntu):
status: Invalid → Confirmed
John Lea (johnlea) on 2011-10-18
tags: added: udp
Changed in ayatana-design:
status: Fix Released → Fix Committed
John Lea (johnlea) on 2011-10-19
Changed in ayatana-design:
status: Fix Committed → Triaged
John Lea (johnlea) on 2011-11-03
Changed in unity:
assignee: nobody → Ted Gould (ted)
importance: Undecided → Medium
Changed in ayatana-design:
status: Triaged → Fix Committed
Chris Wilson (notgary) wrote :

Thanks a lot for reporting this, however since the average user is more likely to be using Ubuntu One to share files and folders, rather than Nautilus' built-in features, this unfortunately does not count as a paper cut.

Changed in hundredpapercuts:
status: New → Invalid
Sebastien Bacher (seb128) wrote :

the issue described in the title is not an unity one, if you have unity issues which have to do with that bug better to open a new ticket

Changed in unity:
status: New → Invalid
Changed in gnome-user-share:
status: New → Invalid
Changed in unity (Ubuntu):
status: New → Invalid
Enkouyami (furyhamster) wrote :

Just because its not a unity issue does not invalidate it as being a gnome-user-share issue.

no longer affects: ayatana-design
no longer affects: unity (Ubuntu)
affects: unity → null
John Lea (johnlea) wrote :

mpt; this issue still affects ayatana-design, re-adding to bug

affects: null → ayatana-design
Changed in ayatana-design:
status: Invalid → Triaged
assignee: Ted Gould (ted) → John Lea (johnlea)
Rubén (cont3mpo) wrote :

The "Sharing Options" in Nautilus just install Samba, please add Apache2 to that installation. Is really annoying not know what package install.

el_gallo_azul (el-gallo-azul) wrote :

I installed Ubuntu 12.04 yesterday, because I tried Samba on Ubuntu 11.10 two days ago and everything went bad and my machine became unusable. I am very wary of (trying to use) Samba. I only want to share files between Linux machines.

Yes I am trying to work out how to fix the problem of not being able to use Personal File Sharing because 'This feature cannot be enabled because the required packages are not installed on your system'.

So this is a repetition of #27 above. The message itself is quite sweet, but without providing any clue of how to identify which packages are not installed, its usefulness is reduced.

I've just been through each item on the first page of Google results for 'ubuntu 12.04 personal file sharing this feature cannot be enabled because the required packages are not installed on your system', but the 2 most thorough answers require Samba. A couple of others refer to Apache, but I can't work out what package/s to install. Here's a quick list of what I've found.

apache2
apache2.2-bin
apache2.2-common
libapache2-mod-dnssd
NFS

John Lea (johnlea) on 2012-08-08
Changed in gnome-user-share (Ubuntu):
status: Confirmed → Triaged
Changed in ayatana-design:
status: Triaged → Fix Committed
Amr Ibrahim (amribrahim1987) wrote :

I'm also experiencing this immature feature in 12.04.

John Lea (johnlea) on 2012-10-04
Changed in gnome-user-share (Ubuntu):
importance: Low → Medium
John Lea (johnlea) on 2012-10-04
no longer affects: hundredpapercuts
no longer affects: gnome-user-share
MNLipp (mnl) wrote :

I just came around this problem. It still is a problem in 12.04.

And I still do not understand why I have to install apache2 if I only want to receive some files via bluetooth from my smart phone. I'm on a campus network with my laptopm sometimes and it really frightens me to have an http server running.

zzecool (zzecool) wrote :

And the problem still exist in 12.10 .....

Same features should work out of the box and this is one of them , it is obvious that Ubuntu doing it wrong here.

Sharing is so mixed and complicated in ubuntu

we have "shares-admin" from the terminal
we have personal sharing - gnome-user-share that have the mentioned problem-bug with the apache ( ffs )
and we have the nautilus way : right click properties ---> sharing

Of course the user is so confused that doesn't understand what is happening ...

Can someone explain why the personal sharing need apache when the shares-admin doesn't ?

This is a rather old bug, but I have been tasked to look into this for 13.10. This bug has mixed in a couple of issues over time. Here is what I believe is the current state and what this bug should really be about.

- The bug title references only Personal File Sharing Preferences, but description also references Nautilus as well. I think this bug should only be used to track the issue in Personal File Sharing Preferences.

- The "Desired resolution" posted by Design (John Lea) in the bug description is for Nautilus, but now Nautilus will prompt the user to install needed services when trying to use file sharing. What is in Nautilus now is quite nice, so I'll follow up with John on this.

 - Back to Personal File Sharing Preferences. Currently (13.10), it still only gives the message that required packages are missing and gives no clue as to what packages are needed or even better, offer to install the needed packages. The needed package is apache2 (and dependencies) because Bluez uses WebDAV to transfer files and WebDAV is provided by apache2.

I'm not sure who is responsible for gnome-user-share in Ubuntu, so I'll try poking around to see what can be done about Personal File Sharing Preferences.

John Lea (johnlea) on 2013-08-14
description: updated
John Lea (johnlea) on 2013-08-20
description: updated
description: updated
Amr Ibrahim (amribrahim1987) wrote :

any updates on this for trusty?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions