changing font size in gnome-terminal changes terminal dimensions

Bug #960084 reported by RobinMHolt on 2012-03-20
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Compiz
Low
Unassigned
Compiz Core
Low
Unassigned
GNOME Terminal
New
Undecided
Unassigned
compiz (Ubuntu)
Low
Unassigned

Bug Description

Open a gnome-terminal

Fill the window with output (ie: cat /etc/passwd)

Use Ctrl '-' and Ctrl '+' to change the font size larger and smaller.

Watch the window manager change the window width and height.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.6.0-0ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
Date: Tue Mar 20 05:40:12 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

RobinMHolt (holt) wrote :
Omer Akram (om26er) on 2012-03-20
Changed in unity (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Changed in compiz-core:
status: New → Confirmed
Changed in unity:
status: New → Confirmed
affects: unity (Ubuntu) → compiz (Ubuntu)
Changed in unity:
importance: Undecided → Low
Changed in compiz-core:
importance: Undecided → Low
Thomas Thurman (marnanel) wrote :

I haven't investigated, but I assume you have; why do you think this is a window manager problem?

RobinMHolt (holt) wrote :

If the window has the dimensions of 80 columns by 25 rows, I change the font size down and up a couple steps ending back at the original size and now my window has dimensions of 68x22, which component is likely to be the source of the problem. I assumed window manager, but I do not know how things are structured and where responsibility lies. If it belongs to a different component, please reassign.

Thomas Thurman (marnanel) wrote :

Probably not the WM, but I suppose it's not impossible; I'll try to look into it this evening and report back.

Thomas Thurman (marnanel) wrote :

Not a WM problem. gnome-terminal does this deliberately through terminal_window_set_size_force_grid().

Changed in compiz-core:
status: Confirmed → Invalid
Changed in unity:
status: Confirmed → Invalid
Changed in compiz (Ubuntu):
status: Confirmed → Invalid
RobinMHolt (holt) wrote :

I know _NOTHING_ about window manager calls, but why is this only affecting compiz/unity. On the same box, I can start a gnome-terminal under icewm and increase or decrease font size all day long without an issue. Are you saying that gnome-terminal is calling terminal_window_set_size_force_grid() with wrong parameters or something and is just so happens that icewm interprets that correctly?

RobinMHolt (holt) wrote :

After testing with XFCE and ICEWM, I am convinced that this problem is unlikely to be gnome-terminal and almost certainly the window manager. I looked at the mapped files via /proc/<pid>/smaps for all three flavors of window managers and the only differences were related to font and sounds/notifications. Please don't condemn this bug report to death by assigning to the GNOME Terminal non-existant group.

Thomas Thurman (marnanel) wrote :

I assure you, I don't want to let this bug vanish. I didn't realise when I reassigned it that it behaves differently under IceWM. I'll do some more testing tonight if I can (sorry, time is squeezed at the moment because I'm rehearsing for a concert next week). I'll let you know what I find and reassign as appropriate.

Thomas Thurman (marnanel) wrote :

I've just tested this under IceWM and I can confirm that changing the font size in gnome-terminal still resizes the window. Reporter, are you still getting this behaviour?

RobinMHolt (holt) wrote :

Yes, but I believe there is a misunderstanding. I am not saying there is a problem with the window getting larger on the screen, I am saying that changing font size changes the number of rows and columns of characters in the newly resized windows. If I start with an 80x25 sized window, then decrease and increase the font size a couple times, the new window will have fewer rows and columns. Do not focus on the number of pixels, but rather number of rows and columns. That information is no longer very easy to determine because the window size is no longer displayed when resizing (useful information I wish had been retained).

RobinMHolt (holt) wrote :

I have tried this on every possible login session I can find and the only one that fails is the default Ubuntu
session. If I log in using the Ubuntu 2D session, it works there. This absolutely can not be a gnome-terminal
bug.

wastrel (wastrel) wrote :

The dimensions of the terminal in characters should be preserved, the size of the window in pixels should increase or decrease proportional to the font size as font size is changed. This worked perfectly in gnome2, it is spastic in 12.10 unity.

Thanks for the attention to the problem.

wastrel (wastrel) wrote :

I'm seeing this problem when using tabs in the gnome terminal window as well, the window resizes itself to preserve the terminal height in rows while accomodating the tab UI in the X window. When you close tabs the tab UI disappears and the window resizes again. This behavior sometimes works & sometimes leaves the terminal with more or fewer rows than it had originally.

wastrel (wastrel) on 2012-10-24
summary: - changing font size in gnome-terminal changes window dimensions.
+ changing font size in gnome-terminal changes terminal dimensions
wastrel (wastrel) wrote :

Just tested in XFCE, gnome-terminal resizes correctly there.

Changed in unity:
status: Invalid → Confirmed
wastrel (wastrel) wrote :

Attempting to clarify again.

To reproduce the problem:

1.)
$ echo $LINES $COLUMNS
24 80
$

2.) increase font size
<ctrl><shift>+
<ctrl><shift>+

3.)
$ echo $LINES $COLUMNS
20 62
$

4.) decrease font size
<ctrl>-
<ctrl>-

5.)
$ echo $LINES $COLUMNS
27 92
$

The terminal size in lines and columns should remain the same, while the x window changes size to accommodate.

Changed in compiz-core:
status: Invalid → Confirmed
affects: unity → compiz
Changed in compiz (Ubuntu):
status: Invalid → Confirmed
Changed in compiz:
milestone: none → 0.9.9.0
status: Confirmed → Triaged
Changed in compiz-core:
status: Confirmed → Triaged
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
Changed in compiz:
milestone: 0.9.9.0 → 0.9.9.2
Changed in compiz:
milestone: 0.9.9.2 → 0.9.10.0
wastrel (wastrel) wrote :

I'm happy to report this is fixed in 13.04. Thank you!

MC Return (mc-return) wrote :

I can unfortunately still reproduce that problem, exactly like described...
Unfortunately I cannot set back the status to triaged, someone else should do that, please.

Changed in compiz (Ubuntu):
status: Triaged → Fix Committed
status: Fix Committed → Fix Released
Changed in compiz-core:
status: Triaged → Fix Released
Changed in compiz:
status: Triaged → Fix Released
RobinMHolt (holt) wrote :

Thankfully, I stopped using Unity because of this bug. A year later and it is still being essentially ignored.

deivid (deivid-rodriguez) wrote :

I'm experiencing this bug too...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers