Expanded panel menus don't fade out cleanly on close

Bug #1744001 reported by Daniel van Vugt on 2018-01-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME Shell
Fix Released
Low
gnome-shell (Ubuntu)
Low
Daniel van Vugt
Nominated for Bionic by Marco Trevisan (Treviño)

Bug Description

[ Impact ]

Expanded panel menus don't fade out cleanly on close.

[ Test case ]

1. Open the panel menu and expand any one of the submenus.
2. Click on the desktop to close the panel menu.

Expected: Menu fades out cleanly like when it wasn't expanded.
Was: Expanded part of the menu does not fade out cleanly.

[ Regression potential ]

Shell items might be no properly be refreshed realtime or redrawn

Related branches

Changed in gnome-shell:
importance: Unknown → Medium
status: Unknown → Confirmed
Daniel van Vugt (vanvugt) wrote :

This is tagged for 'performance' because by chance the fix proposed upstream also significantly reduces CPU usage :)

tags: added: performance
Jeremy Bicha (jbicha) on 2018-04-23
Changed in gnome-shell (Ubuntu):
status: In Progress → Fix Committed
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.28.1-0ubuntu2

---------------
gnome-shell (3.28.1-0ubuntu2) bionic; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * js-ui-Choose-some-actors-to-cache-on-the-GPU.patch:
    - Improve rendering of shell elements moving rendering to GPU
      (LP: #1744001)

  [ Jeremy Bicha ]
  * Cherry-pick polkitAgent-Guard-against-repeated-close-calls.patch:
    - Fix PolicyKit authorization prompt after cancelling once (LP: #1765353)

 -- Marco Trevisan (Treviño) <email address hidden> Mon, 23 Apr 2018 15:29:28 -0500

Changed in gnome-shell (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-shell:
importance: Medium → Low
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.