GNOME Shell crashes randomly on Ubuntu GNOME 17.04 ["(EE) failed to read Wayland events: Broken pipe"]

Bug #1695720 reported by Eduardo Medina on 2017-06-04
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Fix Released
Critical

Bug Description

https://bugzilla.gnome.org/show_bug.cgi?id=781799
https://bugzilla.redhat.com/show_bug.cgi?id=1451914

Hi, I'm experiencing the bug showed in the two links put above on Ubuntu GNOME 17.04. I just want to ask if the Ubuntu team or Ubuntu GNOME team will apply the patch for this bug on Ubuntu GNOME 17.04 (and the whole Ubuntu stack, obviously).

The bug it's very difficult to reproduce, and I see that on Ubuntu GNOME is harder than on Manjaro GNOME. Nonetheless, I hope that you will consider to apply the patch when it's available, because the bug is really annoying.

If there is some way to collect the info of the bug when it happens, I want to know it, because apport-gtk doesn't appear when it happens.

tags: added: gnome-shell
tags: added: gjs gnome-17.04
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
tags: added: zesty
tags: removed: gnome-17.04
summary: - GNOME Shell crashes randomly on Ubuntu GNOME 17.04
+ GNOME Shell crashes randomly on Ubuntu GNOME 17.04 ["(EE) failed to read
+ Wayland events: Broken pipe"]
Eduardo Medina (no-more-hopes) wrote :

Reading Wayland events even on Xorg?

Eduardo Medina (no-more-hopes) wrote :

It seems that the patch will arrive soon. https://bugzilla.gnome.org/show_bug.cgi?id=781799#c57

Changed in gnome-shell:
importance: Unknown → Critical
status: Unknown → Confirmed
Eduardo Medina (no-more-hopes) wrote :

It seems that the patch is now available. https://bugzilla.gnome.org/show_bug.cgi?id=781799#c90

Eduardo Medina (no-more-hopes) wrote :

It seems the bug is not fully patched yet.

Eduardo Medina (no-more-hopes) wrote :

It seems the last backtrace is from another bug.

Changed in gnome-shell:
status: Confirmed → Fix Released
no longer affects: gnome-shell (Ubuntu)
no longer affects: gjs
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.