A Unity launcher for Android would be beneficial

Bug #1223822 reported by Jeb E. on 2013-09-11
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GNOME Shell
New
Undecided
Unassigned
Mir
Invalid
Undecided
Unassigned
Ubuntu Phone Commons
New
Undecided
Unassigned
Ubuntu Touch session manager
New
Undecided
Unassigned
Ubuntu touch distro priorities
Undecided
Unassigned
unity-mir
Undecided
Unassigned

Bug Description

With all the talk of Ubuntu for Android and Ubuntu Phone OS, most average Android users and developers aren't going to willingly flash their phones to an unstable OS or want to plug their phones into a keyboard, mouse, and monitor or even have the equipment necessary to do either.

There are tens to hundreds of launchers already readily available in the Google Play Store for download. A quick, simple, easy process that doesn't require root privileges or complicated methods to installation. It is just a shame as to why Ubuntu Unity, the version used in Ubuntu Phone OS, made to be simple, easy to use, and easy to access once installed isn't available in the Play Store.

Bringing Unity to Android officially will definitely make the Play Store a huge marketing mechanism for Canonical and the Ubuntu Community as a whole, bringing more users into the equation for more feedback and ultimately a more solid, robust, stable, fast, and fluid Unity 8 for the future, cross-device and cross-platform while at the same time providing an up-to-date, updateable, upgradable launcher set for Android that will never go out of style.

Please bring Unity to Android.

Jeb E. (jebeld17) on 2013-09-11
summary: - Not available on Android
+ A Unity launcher for Android would be beneficial
Andrea Azzarone (azzar1) on 2013-09-11
Changed in unity:
importance: Undecided → Wishlist
no longer affects: mir
no longer affects: unity-mir
no longer affects: libunity-webapps

Thank you for taking the time to make Ubuntu better. Since what you submitted is not really a bug, or a problem, but rather an idea to improve Ubuntu, you are invited to post your idea in Ubuntu Brainstorm at http://brainstorm.ubuntu.com/ where it can be discussed, voted on by the community, and reviewed by developers. Thanks for taking the time to share your opinion!

Changed in unity:
status: New → Invalid
Jeb E. (jebeld17) wrote :

Brainstorm seems to be essentially dead, plus there is too much online legislation created by the mods there that only allow a few specific ideas to be seen and voted upon by the general public... Not very nice.

Jeb E. (jebeld17) wrote :

With Android still on the prowl and Ubuntu for Phones still lagging behind in almost every respect, creating an Android launcher of the Ubuntu Phone interface found in the Google Play Store would be a great (indirect) marketing strategy for Canonical and Ubuntu to get their name out there. Think of the millions of Android devices out there, in use at this very same moment...

Changed in unity:
status: Invalid → Confirmed
Jeb E. (jebeld17) on 2015-01-09
Changed in unity:
status: Confirmed → New
Andrea Azzarone (azzar1) on 2015-01-27
no longer affects: unity
Daniel van Vugt (vanvugt) wrote :

Invalid for Mir. Any solution probably would not require any work in Mir.

Changed in mir:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers