gnome-power-manager is not starting automatically

Bug #81574 reported by Licio Fonseca on 2007-01-26
62
Affects Status Importance Assigned to Milestone
gnome-power
Invalid
Undecided
Unassigned
gnome-power-manager (Ubuntu)
High
Oliver Grawert

Bug Description

The gnome-power-manager running sometimes, when it isn't running the option to hibernate isn't enable.
When screensaver is running the gnome-power-manager is disable, for enable it again is necessary to click in the power button and cancel.

Licio Fonseca (licio) wrote :
Licio Fonseca (licio) wrote :

we can see that after click in the powerbutton and cancell, it shows g-p-m again.

David Gerber (zapek) wrote :

Same here. It exits randomly. There's no error message, no crash, it just exits and the last printed output is not always the same.

Reproduceable with --no-daemon and --verbose on the command line, but there's nothing useful to be gathered from the output.

This happens since the last update, that is: version 2.17.90-0ubuntu2.

Example of last lines before it exits:
[battery_kind_cache_debug_print] gpm-power.c:560 (01:41:10): capacity 0 voltage 12557

or

[battery_status_changed_primary] gpm-manager.c:954 (01:42:36): Laptop battery is not discharging

Jonh Wendell (wendell) on 2007-01-30
Changed in gnome-power-manager:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Changed in gnome-power:
status: Unconfirmed → Rejected
Changed in gnome-power-manager:
assignee: nobody → desktop-bugs
Jonh Wendell (wendell) wrote :

Actually, the problem is:

It's missing a desktop file for g-p-m at /etc/xdg/autostart

So, it's not being started at login time. That's the problem.

Jonh Wendell (wendell) wrote :

Maybe this was introduced by the fix of bug 81304

Jonh Wendell (wendell) on 2007-02-02
Changed in gnome-power-manager:
importance: Medium → High
Oliver Grawert (ogra) wrote :

 gnome-power-manager (2.17.90-0ubuntu5) feisty; urgency=low
 .
   * fix autostart .desktop installation

Changed in gnome-power-manager:
assignee: desktop-bugs → ogra
status: Confirmed → Fix Released

on feisty, this happening to me with kernel 2.6.20-5-generic.
with kernel 2.6.20-6-generic, buttons show just fine

Bradley M. Kuhn (bkuhn-ebb) wrote :

I have some hopefully useful information about this bug. I have discovered that I can introduce the bug reliably by taking the following actions:

   /etc/init.d/dbus restart

Then, I note that gnome-power-manager is not running. Next, I click the logout button, and don't see the hibernate nor suspend buttons present on the popup.

When I click cancel and then click the logout button again, I see that gnome-power-manager has restarted and I have the options again.

Brian Murray (brian-murray) wrote :

Bradley - Does gnome-power-manager stop running for you on Feisty? If so do you have any more information about the conditions that cause it to not run?

Bradley M. Kuhn (bkuhn-ebb) wrote :

Brian, yes, this happens on feisty. I am not sure of additional conditions. I do run an odd window-manager (sawfish). However, gnome-session runs as normal, and gnome-power-manager is always running *except* when I restart dbus by hand while still logged in. As I mentioned in my initial report, clicking on the logout button from the panel twice (once to just cancel, then again) restarts the gnome-power-manager.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments