Battery status application indicator displays wrong status

Bug #701941 reported by Ingo Gerth on 2011-01-12
36
This bug affects 5 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
gnome-power
New
Medium
gnome-power-manager (Ubuntu)
Low
Unassigned

Bug Description

On my netbook the battery icon is already colored warningly red when my battery still has about 2 hours remaining! It might be that only a low percentage of power is left, but in absolute terms of time it does not make sense to display 2 hours as a dramatic situation.
---
Architecture: i386
DistroRelease: Ubuntu 10.10
GnomeSessionIdleInhibited: No
GnomeSessionInhibitors: None
GnomeSessionSuspendInhibited: No
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta i386 (20100901.1)
MachineType: ASUSTeK Computer Inc. X55SV
NonfreeKernelModules: nvidia
Package: gnome-power-manager 2.32.0-0ubuntu1
PackageArchitecture: i386
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.35-24-generic root=UUID=7faee8b8-03a6-451b-a351-68632225b747 ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-24.42-generic 2.6.35.8
Tags: maverick ubuntu-une
Uname: Linux 2.6.35-24-generic i686
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev plugdev sambashare tape video
dmi.bios.date: 01/14/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 207
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: X55SV
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr207:bd01/14/2008:svnASUSTeKComputerInc.:pnX55SV:pvr1.0:rvnASUSTeKComputerInc.:rnX55SV:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: X55SV
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.

---
Architecture: i386
DistroRelease: Ubuntu 10.10
GnomeSessionIdleInhibited: No
GnomeSessionInhibitors: None
GnomeSessionSuspendInhibited: No
InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Release i386 (20101007)
MachineType: ASUSTeK Computer INC. 1015PE
NonfreeKernelModules: wl
Package: gnome-power-manager 2.32.0-0ubuntu1
PackageArchitecture: i386
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-24-generic root=UUID=e3f13f7a-6b83-4be7-ba34-0982ccfad435 ro quiet splash
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.35-24.42-generic 2.6.35.8
Tags: ubuntu-une maverick
Uname: Linux 2.6.35-24-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 07/12/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0603
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1015PE
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0603:bd07/12/2010:svnASUSTeKComputerINC.:pn1015PE:pvrx.x:rvnASUSTeKComputerINC.:rn1015PE:rvrx.xx:cvnASUSTeKComputerINC.:ct10:cvrx.x:
dmi.product.name: 1015PE
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.

Paul Sladen (sladen) wrote :

The specification states that the icon should turn bed based on time (<30 minutes) and not on percentage:

  https://wiki.ubuntu.com/BatteryStatusMenu#Icons

if percentage is being used, then it could be down to bug #629258 ("Battery life estimation never comes around"). You can tell if this is the case by clicking on the battery icon and seeing if it states "estimating".

Ingo Gerth (igerth) wrote :

The time remaining is rather well estimated, I can not complain about that. Without having made any changes, however, the described bug definitely occurs when there is still a lot more time remaining than just half an hour. Maybe the specification is not implemented correctly? See the screenshot attached.

Thanks a lot for reporting this, however as this is not a small usability flaw found in all default installations of Ubuntu, and is instead system-specific (it doesn't appear on my laptop), this is not eligible for the paper cuts project. I have however made the upstream developers aware of the situation.

Changed in hundredpapercuts:
status: New → Invalid
Jack Leigh (leighman) wrote :

I think this is a valid papercut. It is only hardware specific in the sense that some laptop batteries last longer than others. It also particularly affects netbooks which Unity seems to want to target. Mine gives me a red battery indicater with a couple of hours remaining too and I often click to find out I in fact have plenty of time left.
.`. a usability bug that regularly affects a large number of users.

Changed in hundredpapercuts:
status: Invalid → Confirmed
Jack Leigh (leighman) wrote :

Having said that, what version of Ubuntu are you using?
I personally have only seen this in Lucid.

Changed in gnome-power:
importance: Unknown → Medium
status: Unknown → New
Ingo Gerth (igerth) wrote :

Thanks for sending the bug upstream Chris.

Leighman, did you also try it out on Maverick? I am using 10.10 and the bug occurs here for me.

I'm on Maverick.

On 13 Jan 2011 00:38, "leighman" <email address hidden> wrote:

Having said that, what version of Ubuntu are you using?
I personally have only seen this in Lucid.

--
You received this bug notification because you are a member of
Papercutters, which is subscribe...
Status in Gnome Powermanager:
 Unknown

Status in One Hundred Paper Cuts:

Confirmed
Status in “gnome-power-manager” package in Ubuntu:

New

Bug description:
On my netbook the battery icon is already colored warningly red when
my ...

Vish (vish) wrote :

Chris is right, this is not a papercut , ie. not a design flaw, a paper cut should be a small usability issue, in the default Ubuntu install, that affects many people and is quick and easy to fix. .
This is a bug which just needs fixing.
For further information about papercuts criteria, please read https://wiki.ubuntu.com/PaperCut.
Don't worry though, this bug has been marked as "Invalid" only in the papercuts project.

@Ingo Gerth : Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 701941
This will help us to find and resolve the problem. Thanks in advance!
When reporting bugs in the future please use apport, using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in hundredpapercuts:
status: Confirmed → Invalid
Changed in gnome-power-manager (Ubuntu):
importance: Undecided → Low
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Ingo Gerth (igerth) wrote :

The previous information conerncs my *laptop*, where this bug seems to be the other way around. If the rationale really states that the battery should be colored red when less than thirty minutes is remaining, than it surely is not implemented this way. On the attached screenshot you can see that 25 minutes is left and the battery is *not* red.

The following information will come from my *netbook*, which concerns the behavior described before.

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Gary M (garym) wrote :

Marking as confirmed, based

Changed in gnome-power-manager (Ubuntu):
status: Incomplete → New
Gary M (garym) wrote :

(Please ignore my previous comment. I didn't set this to Confirmed as it wasn't clear to me that the reported lucid and maverick problems were the same issue. But the requested information was provided by Ingo, so it's no longer Incomplete.)

Gary M (garym) wrote :

(Confirmed for maverick, based on duplicate bug #695053.)

tags: added: maverick
Changed in gnome-power-manager (Ubuntu):
status: New → Confirmed
Gary M (garym) on 2011-03-14
tags: added: natty
Gary M (garym) wrote :

On an Asus EEEPC 1001HA netbook (same mainboard & batteries as 1005HA), the indicator turns red when discharging reaches 30%. Perhaps the right number is being checked in the wrong place?

To post a comment you must log in.