12.10 Bluetooth Battery Indicator Interferes with Bluetooth Mouse Moves

Bug #1098959 reported by Ubfan on 2013-01-12
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gnome-power
New
Undecided
Unassigned
indicator-power (Ubuntu)
Undecided
Unassigned

Bug Description

 A fully updated (Jan 11, 2013) Ubuntu 12.10 allows the bluetooth mouse to "connect" but fails to move the cursor. The bluetooth battery indicator is created and works.

 If bluetooth is turned on just before mouse connection is attempted (before the battery indicator shows the mouse battery), sometimes there is mouse cursor movement for a fraction of a second. One time, a mouse onnection succeeded, and at that time, the battery indicator for the mouse no longer reported the current battery state (switching batteries of different charges no longer accurately indicated the battery charge).
hcidump reports the mouse moves, but the cursor does nothing, nor do clicks.

  ** The mouse does work if the battery indicator is killed soon after boot before bluetooth is turned on.**

  Taking a wild guess, the bluetooth battery indicator handler is not re-queueing the mouse moves it sees while looking for the battery info. Additionally, the mouse handler, when it rarely gets a position before the battery handler is not re-queuing the battery messages.

 Equipment:
 HP V3000, with Nvidia 6150 running driver version 304.51, root on 8G usb.
 Bus 002 Device 002: ID 03f0:171d Hewlett-Packard Bluetooth 2.0 Interface
[Broadcom BCM2045], Generic Bluetooth mouse
 Broadcom 4311 wireless running the b43 driver with the firmware supplied
from package firmware-b43-installer.
 xorg.conf file was originally absent, but copying one from my 12.04
installation made no difference.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: indicator-power 12.10.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-21.32-generic 3.5.7.1
Uname: Linux 3.5.0-21-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.6.1-0ubuntu9
Architecture: i386
Date: Sat Jan 12 12:03:51 2013
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: indicator-power
UpgradeStatus: No upgrade log present (probably fresh install)

Ubfan (ubfan1) wrote :
Ubfan (ubfan1) wrote :

I have found a more reliable way to turn the mouse on:
Shutdown a running system with bluetooth turned off.
Reboot, and kill upowerd before enabling bluetooth, then turn on bluetooth and insert mouse batteries -- the mouse will work.
Maybe the package with the problem is not the indicator package, but the upower package, or even the bluez package if it is supplying an API which is faulty.

Ubfan (ubfan1) wrote :

Running system is a 4G USB, booted with bluetooth off, no battery indicator displayed, killed the upowerd process, then turned bluetooth on, then turned on the mouse, which immediately worked, resulting in the following dmesg messages:
[ 1542.188059] usb 2-4: new full-speed USB device number 4 using ohci_hcd
[ 1542.418559] usb 2-4: New USB device found, idVendor=03f0, idProduct=171d
[ 1542.418574] usb 2-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 1542.418582] usb 2-4: Product: HP Integrated Module
[ 1542.418589] usb 2-4: Manufacturer: Broadcom Corp
[ 1542.515610] Bluetooth: HIDP (Human Interface Emulation) ver 1.2
[ 1544.470504] hid-generic 0005:0A5C:0001.0003: unknown main item tag 0x0
[ 1544.480876] input: Bluetooth Mouse as /devices/pci0000:00/0000:00:0b.0/usb2/2-4/2-4:1.0/bluetooth/hci0/hci0:11/input11
[ 1544.481419] hid-generic 0005:0A5C:0001.0003: input,hidraw2: BLUETOOTH HID v0.1e Keyboard [Bluetooth Mouse] on 00:16:41:D4:B1:1F

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-power (Ubuntu):
status: New → Confirmed

If you cycle the mouse on/off, do you eventually see a upowerd crash?

Everything else you described is the same as what I'm seeing in this bug here:
https://bugs.launchpad.net/ubuntu/+source/upower/+bug/1079110

Ubfan (ubfan1) wrote :
Download full text (12.3 KiB)

Cycling mouse and/or bluetooth never crashes the upowerd for me. I do get some null pointer stack dump from the bluetoothd at some point. Closest complaint was :
quanta4g kernel: [ 211.852064] power_supply hid-00:60:D1:00:C3:15-battery: driver failed to report `capacity' property: 4294967291

Here's the null pointer log:
Jan 19 14:25:50 quanta4g kernel: [ 213.560251] ------------[ cut here ]------------
Jan 19 14:25:50 quanta4g kernel: [ 213.560261] WARNING: at /build/buildd/linux-3.5.0/lib/kobject.c:196 kobject_add_internal+0x1ea/0x200()
Jan 19 14:25:50 quanta4g kernel: [ 213.560264] Hardware name: Presario V3000 (RD462PA#AB0)
Jan 19 14:25:50 quanta4g kernel: [ 213.560269] kobject_add_internal failed for hci0:11 with -EEXIST, don't try to register things with the same name in the same directory.
Jan 19 14:25:50 quanta4g kernel: [ 213.560272] Modules linked in: hidp bnep rfcomm parport_pc ppdev vesafb lp parport snd_hda_codec_conexant arc4 nvidia(PO) hp_wmi sparse_keymap kvm_amd kvm snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq snd_timer snd_seq_device psmouse serio_raw r852 sm_common nand r592 nand_ids mtd nand_bch bch memstick joydev nand_ecc snd btusb k8temp soundcore bluetooth snd_page_alloc b43 mac80211 nv_tco cfg80211 i2c_nforce2 bcma ssb_hcd wmi video mac_hid ext2 hid_generic usbhid hid firewire_ohci sdhci_pci uas usb_storage sdhci firewire_core crc_itu_t pata_amd forcedeth sata_nv ssb
Jan 19 14:25:50 quanta4g kernel: [ 213.560377] Pid: 5, comm: kworker/u:0 Tainted: P W O 3.5.0-21-generic #32-Ubuntu
Jan 19 14:25:50 quanta4g kernel: [ 213.560380] Call Trace:
Jan 19 14:25:50 quanta4g kernel: [ 213.560391] [<c1044802>] warn_slowpath_common+0x72/0xa0
Jan 19 14:25:50 quanta4g kernel: [ 213.560400] [<c12c9dba>] ? kobject_add_internal+0x1ea/0x200
Jan 19 14:25:50 quanta4g kernel: [ 213.560409] [<c12c9dba>] ? kobject_add_internal+0x1ea/0x200
Jan 19 14:25:50 quanta4g kernel: [ 213.560419] [<c10448d3>] warn_slowpath_fmt+0x33/0x40
Jan 19 14:25:50 quanta4g kernel: [ 213.560428] [<c12c9dba>] kobject_add_internal+0x1ea/0x200
Jan 19 14:25:50 quanta4g kernel: [ 213.560438] [<c113e293>] ? kmem_cache_alloc_trace+0x103/0x110
Jan 19 14:25:50 quanta4g kernel: [ 213.560448] [<c12ca075>] kobject_add+0x35/0x80
Jan 19 14:25:50 quanta4g kernel: [ 213.560457] [<c13aad36>] device_add+0xe6/0x620
Jan 19 14:25:50 quanta4g kernel: [ 213.560469] [<c12d5543>] ? kvasprintf+0x43/0x60
Jan 19 14:25:50 quanta4g kernel: [ 213.560479] [<c12ca022>] ? kobject_set_name_vargs+0x42/0x60
Jan 19 14:25:50 quanta4g kernel: [ 213.560503] [<f9ec53a3>] hci_conn_add_sysfs+0x43/0x80 [bluetooth]
Jan 19 14:25:50 quanta4g kernel: [ 213.560527] [<f9eb9695>] hci_conn_complete_evt.isra.47+0xb5/0x360 [bluetooth]
Jan 19 14:25:50 quanta4g kernel: [ 213.560575] [<f9ebb370>] hci_event_packet+0x8f0/0x2170 [bluetooth]
Jan 19 14:25:50 quanta4g kernel: [ 213.560644] [<f9d80cae>] ? __ieee80211_recalc_idle+0x13e/0x290 [mac80211]
Jan 19 14:25:50 quanta4g kernel: [ 213.560674] [<c101003c>] ? __switch_to+0xbc/0x260
Jan 19 14:25:50 quanta4g kernel: [ 213.560683] [<c107d53a>] ? idle_balance+0x10a/0x150
Jan 19 14...

Rafael Bijos Faidiga (ubun0u) wrote :

On my computer, the mouse works after about 8 minutes that it is connected.
my dmesg

[ 7902.662724] hid-generic 0005:0A5C:0001.0006: unknown main item tag 0x0
[ 7902.674186] input: Bluetooth Mouse as /devices/pci0000:00/0000:00:1d.2/usb4/4-1/4-1:1.0/bluetooth/hci0/hci0:41/input7
[ 7902.674467] hid-generic 0005:0A5C:0001.0006: input,hidraw2: BLUETOOTH HID v0.1e Keyboard [Bluetooth Mouse] on 00:10:60:A8:5E:72
[ 8180.408049] power_supply hid-00:16:90:00:06:6C-battery: driver failed to report `capacity' property: 4294967291
[ 8185.408076] power_supply hid-00:16:90:00:06:6C-battery: driver failed to report `capacity' property: 4294967291
[ 8190.408037] power_supply hid-00:16:90:00:06:6C-battery: driver failed to report `capacity' property: 4294967291
[ 8197.000056] power_supply hid-00:16:90:00:06:6C-battery: driver failed to report `capacity' property: 4294967291
[ 8202.000072] power_supply hid-00:16:90:00:06:6C-battery: driver failed to report `capacity' property: 4294967291
[ 8207.000085] power_supply hid-00:16:90:00:06:6C-battery: driver failed to report `capacity' property: 4294967291
[ 8212.004026] power_supply hid-00:16:90:00:06:6C-battery: driver failed to report `capacity' property: 4294967291
[ 8217.004026] power_supply hid-00:16:90:00:06:6C-battery: driver failed to report `capacity' property: 4294967291
[ 8252.012057] power_supply hid-00:16:90:00:06:6C-battery: driver failed to report `capacity' property: 4294967291
[ 8287.028041] power_supply hid-00:16:90:00:06:6C-battery: driver failed to report `capacity' property: 4294967291
[ 8322.000137] power_supply hid-00:16:90:00:06:6C-battery: driver failed to report `capacity' property: 4294967291
[ 8352.029419] Bluetooth: hci0 link tx timeout
[ 8352.029431] Bluetooth: hci0 killing stalled connection 00:16:90:00:06:6C
[ 8352.114281] power_supply hid-00:16:90:00:06:6C-battery: driver failed to report `capacity' property: 4294967291
[ 8357.112027] power_supply hid-00:16:90:00:06:6C-battery: driver failed to report `capacity' property: 4294967291
[ 8362.112042] power_supply hid-00:16:90:00:06:6C-battery: driver failed to report `capacity' property: 4294967291
[ 8374.726527] hid-generic 0005:0A5C:0001.0007: unknown main item tag 0x0
[ 8374.759369] input: Bluetooth Mouse as /devices/pci0000:00/0000:00:1d.2/usb4/4-1/4-1:1.0/bluetooth/hci0/hci0:41/input8
[ 8374.763486] hid-generic 0005:0A5C:0001.0007: input,hidraw2: BLUETOOTH HID v0.1e Keyboard [Bluetooth Mouse] on 00:10:60:A8:5E:72

8374-7902=472
472/60=7,86 minutes
or it works (almolst always) after sudo restart bluetooth (twice)

MichaelE (michael-eitelwein) wrote :
Download full text (5.1 KiB)

After update to 13.04, my apple wireless keyboard (bluetooth) stops working after a few minutes. It may be related to the same issue, as I have the same error message in the kernel log:

[ 171.061649] Bluetooth: HIDP (Human Interface Emulation) ver 1.2
[ 171.061663] Bluetooth: HIDP socket layer initialized
[ 171.469709] apple 0005:05AC:023A.0004: unknown main item tag 0x0
[ 171.501005] input: Apple Wireless Keyboard as /devices/pci0000:00/0000:00:12.2/usb1/1-4/1-4.2/1-4.2:1.0/bluetooth/hci0/hci0:12/input16
[ 171.501226] apple 0005:05AC:023A.0004: input,hidraw3: BLUETOOTH HID v0.50 Keyboard [Apple Wireless Keyboard] on 00:02:72:3f:ca:24
[ 174.435365] usb 1-4.4: USB disconnect, device number 7
[ 305.485226] power_supply hid-e8:06:88:41:78:de-battery: driver failed to report `capacity' property: -5
[ 305.485254] power_supply hid-e8:06:88:41:78:de-battery: driver failed to report `capacity' property: -5
[ 314.034459] apple 0005:05AC:023A.0005: unknown main item tag 0x0
[ 314.064000] input: Apple Wireless Keyboard as /devices/pci0000:00/0000:00:12.2/usb1/1-4/1-4.2/1-4.2:1.0/bluetooth/hci0/hci0:12/input17
[ 314.064367] apple 0005:05AC:023A.0005: input,hidraw2: BLUETOOTH HID v0.50 Keyboard [Apple Wireless Keyboard] on 00:02:72:3f:ca:24
[ 314.132615] do_trap: 42 callbacks suppressed
[ 314.132626] traps: upowerd[2325] trap int3 ip:7fe4f3c772c5 sp:7fff10e4f590 error:0
[ 728.013999] init: mountall main process (370) terminated with status 1
[ 728.014400] init: upstart-file-bridge main process (380) terminated with status 1
[ 728.014449] init: upstart-file-bridge main process ended, respawning
[ 728.014710] init: upstart-udev-bridge main process (483) terminated with status 1
[ 728.014756] init: upstart-udev-bridge main process ended, respawning
[ 728.015117] init: upstart-socket-bridge main process (778) terminated with status 1
[ 728.015166] init: upstart-socket-bridge main process ended, respawning
[ 728.049264] init: plymouth-stop pre-start process (5004) terminated with status 1
[ 728.831905] init: upstart-udev-bridge main process (5007) terminated with status 1
[ 728.831975] init: upstart-udev-bridge main process ended, respawning
[ 728.832303] init: upstart-socket-bridge main process (5009) terminated with status 1
[ 728.832352] init: upstart-socket-bridge main process ended, respawning
[ 728.832625] init: upstart-file-bridge main process (5011) terminated with status 1
[ 728.832670] init: upstart-file-bridge main process ended, respawning
[ 988.148438] power_supply hid-e8:06:88:41:78:de-battery: driver failed to report `capacity' property: -5
[ 988.148466] power_supply hid-e8:06:88:41:78:de-battery: driver failed to report `capacity' property: -5
[ 992.243098] apple 0005:05AC:023A.0006: unknown main item tag 0x0
[ 992.272772] input: Apple Wireless Keyboard as /devices/pci0000:00/0000:00:12.2/usb1/1-4/1-4.2/1-4.2:1.0/bluetooth/hci0/hci0:12/input18
[ 992.273023] apple 0005:05AC:023A.0006: input,hidraw2: BLUETOOTH HID v0.50 Keyboard [Apple Wireless Keyboard] on 00:02:72:3f:ca:24
[ 992.330047] traps: upowerd[3874] trap int3 ip:7f58431ae2c5 sp:7fff53378150 error:0
[ 992.890086] power_supply hid-e8:06:88:41:78:de-batte...

Read more...

Ubfan (ubfan1) wrote :

A frech install of 12.04.2 also displays the mouse problem with the mouse battery indicator. The mouse might move a few pixels when first turned on, but then stops and never moves again.

Brendan (schismoid) wrote :

I'm seeing this issue as well, on 13.04. Bluetooth mouse works for a while, then stops working when the "battery: driver failed to report `capacity' property: -5" error happens, but then eventually starts working again...until the error occurs again.

[ 6228.748184] input: Evoluent VerticalMouse 4 as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.8/2-1.8.1/2-1.8.1.3/2-1.8.1.3:1.0/bluetooth/hci0/hci0:13/input28
[ 6228.748445] hid-generic 0005:1A7C:0191.0012: input,hidraw2: BLUETOOTH HID v1.29 Mouse [Evoluent VerticalMouse 4] on 28:cf:e9:1c:ea:12
[ 6233.870497] power_supply hid-dc:2c:26:c3:79:7c-battery: driver failed to report `capacity' property: -5
[ 6238.868994] power_supply hid-dc:2c:26:c3:79:7c-battery: driver failed to report `capacity' property: -5
[ 6268.544610] hid-generic 0005:1A7C:0191.0013: unknown main item tag 0x0
[ 6268.677837] input: Evoluent VerticalMouse 4 as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.8/2-1.8.1/2-1.8.1.3/2-1.8.1.3:1.0/bluetooth/hci0/hci0:12/input29
[ 6268.678407] hid-generic 0005:1A7C:0191.0013: input,hidraw2: BLUETOOTH HID v1.29 Mouse [Evoluent VerticalMouse 4] on 28:cf:e9:1c:ea:12
[ 6336.226244] power_supply hid-dc:2c:26:c3:79:7c-battery: driver failed to report `capacity' property: -5
[ 6341.224674] power_supply hid-dc:2c:26:c3:79:7c-battery: driver failed to report `capacity' property: -5
[ 6341.233227] hid-generic 0005:1A7C:0191.0014: unknown main item tag 0x0
[ 6341.554574] input: Evoluent VerticalMouse 4 as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.8/2-1.8.1/2-1.8.1.3/2-1.8.1.3:1.0/bluetooth/hci0/hci0:11/input30
[ 6341.554955] hid-generic 0005:1A7C:0191.0014: input,hidraw2: BLUETOOTH HID v1.29 Mouse [Evoluent VerticalMouse 4] on 28:cf:e9:1c:ea:12
[ 6652.342429] power_supply hid-dc:2c:26:c3:79:7c-battery: driver failed to report `capacity' property: -5
[ 6657.340849] power_supply hid-dc:2c:26:c3:79:7c-battery: driver failed to report `capacity' property: -5
[ 6657.357520] hid-generic 0005:1A7C:0191.0015: unknown main item tag 0x0
[ 6657.381081] input: Evoluent VerticalMouse 4 as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.8/2-1.8.1/2-1.8.1.3/2-1.8.1.3:1.0/bluetooth/hci0/hci0:13/input31
[ 6657.381570] hid-generic 0005:1A7C:0191.0015: input,hidraw2: BLUETOOTH HID v1.29 Mouse [Evoluent VerticalMouse 4] on 28:cf:e9:1c:ea:12

Ubfan (ubfan1) wrote :

Same problem seen on Ubuntu 14.04 64 bit on a Toshiba Satellite S855-5378 (different machine, same generic bt mouse) with built-in bluetooth. The bt mouse will connect, but status never shows "paired". The mouse works maybe 30 seconds while the bt mouse battery is discovered, then mouse stops working when the battery indicator finishes what it is doing.

Ubfan (ubfan1) wrote :

On the Toshiba Satellire S855-5378, running 14.04, when the laptop battery is removed, running on AC, the battery indicator does not show up in the title bar, the bt mouse will successfully connect with a warning (incorrect) of 0% mouse battery, and continues to run. Some additional details on the connection and mouse are below:
[ 2630.907716] Bluetooth: HIDP (Human Interface Emulation) ver 1.2
[ 2630.907738] Bluetooth: HIDP socket layer initialized
[ 2638.817535] hid-generic 0005:0A5C:0001.0004: unknown main item tag 0x0
[ 2638.817816] input: Bluetooth Mouse as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2:1.0/bluetooth/hci0/hci0:1/input14
[ 2638.818082] hid-generic 0005:0A5C:0001.0004: input,hidraw3: BLUETOOTH HID v0.1e Keyboard [Bluetooth Mouse] on 2c:d0:5a:21:21:2d

Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 10f1:1a43 Importek
Bus 001 Device 005: ID 0930:021d Toshiba Corp.

Ubfan (ubfan1) wrote :

On 14.04.1 fully patched to Oct 22, 2014, on the original HP V3000, the bluetooth mouse now works. The battery indicator however now shows as a red battery icon, the mouse battery at 0% (new batteries), and no laptop battery is shown at all, even when the laptop battery is present. Looks like the bluetooth problems with the battery indicator have been fixed, even though the battery indicator still has problems.

atimonin (atimonin) wrote :

My BT mouse worked OK (but with red batt indicator) until last update.
Now it connects, but cursor doesn't move.

When I switch mouse off and on I can see in syslog:

Dec 15 10:32:27 timonin kernel: [ 4594.054066] hid-generic 0005:0A5C:0001.0007: unknown main item tag 0x0
Dec 15 10:32:27 timonin kernel: [ 4594.060380] input: Bluetooth Mouse as /devices/pci0000:00/0000:00:13.0/usb4/4-1/4-1:1.0/bluetooth/hci0/hci0:22/input18
Dec 15 10:32:27 timonin kernel: [ 4594.061659] hid-generic 0005:0A5C:0001.0007: input,hidraw1: BLUETOOTH HID v0.1e Keyboard [Bluetooth Mouse] on 50:b7:c3:d2:c1:e3

Sometime mouse is working for a couple of seconds and then stops

Ubfan (ubfan1) wrote :

Trying to use the BT mouse on the Toshiba S855-5378 without the laptop battery resulted in periodic mouse freezes after several minutes of use, usually a second or so after a popup notification of "low BT mouse battery" (batteries were new). I have similar errors in syslog that altimonin posted.
Dec 16 10:49:28 tosi kernel: [ 1148.112333] hid-generic 0005:0A5C:0001.0007: unknown main item tag 0x0
Dec 16 10:49:28 tosi kernel: [ 1148.142646] input: Bluetooth Mouse as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2:1.0/bluetooth/hci0/hci0:4/input17
Dec 16 10:49:28 tosi kernel: [ 1148.143000] hid-generic 0005:0A5C:0001.0007: input,hidraw3: BLUETOOTH HID v0.1e Keyboard [Bluetooth Mouse] on 2c:d0:5a:21:21:2d
Dec 16 10:49:31 tosi kernel: [ 1151.594091] hid-generic 0005:0A5C:0001.0008: unknown main item tag 0x0
Dec 16 10:49:31 tosi kernel: [ 1151.600791] input: Bluetooth Mouse as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2:1.0/bluetooth/hci0/hci0:5/input18
Dec 16 10:49:31 tosi kernel: [ 1151.601070] hid-generic 0005:0A5C:0001.0008: input,hidraw3: BLUETOOTH HID v0.1e Keyboard [Bluetooth Mouse] on 2c:d0:5a:21:21:2d
Dec 16 10:49:41 tosi kernel: [ 1161.740049] hid-generic 0005:0A5C:0001.0009: unknown main item tag 0x0
Dec 16 10:49:41 tosi kernel: [ 1161.745329] input: Bluetooth Mouse as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2/1-1.2:1.0/bluetooth/hci0/hci0:6/input19
Dec 16 10:49:41 tosi kernel: [ 1161.745537] hid-generic 0005:0A5C:0001.0009: input,hidraw3: BLUETOOTH HID v0.1e Keyboard [Bluetooth Mouse] on 2c:d0:5a:21:21:2d
Dec 16 10:50:04 tosi wpa_supplicant[1255]: wlan0: CTRL-EVENT-SCAN-STARTED

atimonin (atimonin) wrote :

I have a problem with BT mouse: after a connectinon it (sometime) is working, but then doesn't.
Cursor is not moving....
Attached hcidump -XYt

atimonin (atimonin) wrote :

As I can see nobody can help here....

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers