gnome panel has no way to specify on which screen it should appear

Bug #192009 reported by sibidiba on 2008-02-15
114
This bug affects 15 people
Affects Status Importance Assigned to Milestone
GNOME Panel
Confirmed
Medium
gnome-control-center
Invalid
Wishlist
gnome-panel (Ubuntu)
Wishlist
Unassigned

Bug Description

If you have an external monitor, gnome always selects the first display device listed by xrandr, instead you should be able to specify one.
You have no way to have the panel appear always on the same screen.

Related branches

Jonathon Conte (thesicktwist) wrote :

I'm fairly certain that I've been bitten by this as well. I have a dual head radeon card. When enabling the secondary display, both the upper and lower panels switch from my primary monitor to the secondary monitor. I am running an up-to-date Hardy i386 development release as of 22 March 2008.

libxrandr2 2:1.2.2-1
gnome-panel 1:2.22.0-0ubuntu2
metacity 1:2.22.0-0ubuntu1
xserver-xorg-video-ati 1:6.8.0-1

Changed in gnome-panel:
importance: Undecided → Wishlist
Michael Nagel (nailor) on 2008-08-04
Changed in gnome-panel:
status: New → Confirmed
Pedro Villavicencio (pedro) wrote :

Thanks for the report, this needs to be forwarded upstream by someone interested on the feature, for forwarding instructions please have a look to https://wiki.ubuntu.com/Bugs/Upstream/GNOME ; leaving this as incomplete until that, thanks in advance.

Changed in gnome-panel:
assignee: nobody → desktop-bugs
status: Confirmed → Incomplete
Pedro Villavicencio (pedro) wrote :

Closing this bug report as no further information has been provided. Please feel free to reopen this bug if you can provide the information asked for. Thanks!.

Changed in gnome-panel:
status: Incomplete → Invalid
sibidiba (sibidiba) wrote :

This bug is still present. If you have multiple monitors, there is no way to specify which one should be the primary, i.e. the one with the taskbar.

Changed in gnome-panel:
status: Invalid → Confirmed
Pedro Villavicencio (pedro) wrote :

As said on my first comment, someone having a second monitor and interest on this feature should send it upstream, otherwise there's no point on leaving the bug here open, for instructions on how to do forward the bug upstream see my first comment too, thanks.

Lionel Dricot (ploum) on 2008-12-02
Changed in gnome-panel:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-panel:
status: Confirmed → Triaged
Changed in gnome-panel:
status: Unknown → New
Changed in gnome-control-center:
status: Unknown → New
James Westby (james-w) wrote :

Hi,

There is a patch in the upstream bug now that prefers LVDS outputs,
which should give a better experience for laptop users as their panel
will tend to stay on the laptop panel.

It's partly just a stopgap until you can select the primary output in the
capplet though.

Would that patch be suitable for Jaunty?

Thanks,

James

James Westby (james-w) wrote :

Hi,

Here's a debdiff for this bug. I've tested it and it appears to do what it
is supposed to for me.

Thanks,

James

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-panel - 1:2.26.0-0ubuntu5

---------------
gnome-panel (1:2.26.0-0ubuntu5) jaunty; urgency=low

  * Apply patch from Federico to prefer the LVDS output when placing the panel
    in a multi-screen environment. While there is still no way to configure this
    it should give a better experience for laptop users. (LP: #192009)
  * Apply patch from Federico to handle overlapping monitors better by just
    using the largest.
  * Add debhelper token to debian/gnome-panel.postrm, thanks lintian.

 -- James Westby <email address hidden> Tue, 31 Mar 2009 12:51:38 +0100

Changed in gnome-panel:
status: Triaged → Fix Released

While this patch may be an improvement for many users, this does not fix the original problem: the lack of being able to specify on which screen the panel should display.

On my setup the external display has a larger resolution (1920x1200) than the LVDS panel of the laptop (1600x900). Therefore I like to have the panel on the external monitor which has more screen real-estate available.

Changed in gnome-panel (Ubuntu):
status: Fix Released → Triaged

This patch breaks gnome-panel on NX:

The program 'gnome-panel' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadRequest (invalid request code or no such operation)'.
  (Details: serial 112 error_code 1 request_code 150 minor_code 8)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Maybe because nxagent don't support XRRGetScreenResources.

nickolai (nickolai) wrote :

This change makes the multi-screen experience strictly worse in at least one scenario, as follows.

In my case, I have an external VGA screen that's smaller than my LVDS screen, and physically placed above it. After running "xrandr --output VGA --auto --above LVDS", my desktop extends upward to include the VGA screen, but gnome-panel remains at the top of the LVDS screen (since it's larger), in the middle of my logical desktop. This seems odd, since windows that span both screens are now interrupted by a gnome-panel.

To make matters worse, when a new window is created and placed on the LVDS screen, the window is aligned to the top of the LVDS screen, as opposed to the bottom of the gnome-panel. As a result, the window's title bar is placed below the overlapping gnome-panel, making it difficult to move the window.

On Wed, 2009-04-01 at 16:11 +0000, nickolai wrote:
> This change makes the multi-screen experience strictly worse in at least
> one scenario, as follows.
>
> In my case, I have an external VGA screen that's smaller than my LVDS
> screen, and physically placed above it. After running "xrandr --output
> VGA --auto --above LVDS", my desktop extends upward to include the VGA
> screen, but gnome-panel remains at the top of the LVDS screen (since
> it's larger), in the middle of my logical desktop. This seems odd,
> since windows that span both screens are now interrupted by a gnome-
> panel.

I don't see that this would have changed with this patch would it?
Weren't both panels placed on the same screen before this change as
well?

> To make matters worse, when a new window is created and placed on the
> LVDS screen, the window is aligned to the top of the LVDS screen, as
> opposed to the bottom of the gnome-panel. As a result, the window's
> title bar is placed below the overlapping gnome-panel, making it
> difficult to move the window.

This part I see as well, but I'm trying to work out which component
is at fault to file a bug.

Thanks,

James

nickolai (nickolai) wrote :

> I don't see that this would have changed with this patch would it?
> Weren't both panels placed on the same screen before this change as
> well?

Prior to this change, my gnome-panel would move to the top of the combined desktop (top of the VGA screen), and there would be no instance of gnome-panel anywhere on the LVDS screen. This allowed me to have very tall windows that spanned multiple screens with little visual interruption.

James Westby (james-w) wrote :

On Wed, 2009-04-01 at 17:04 +0000, nickolai wrote:
> > I don't see that this would have changed with this patch would it?
> > Weren't both panels placed on the same screen before this change as
> > well?
>
> Prior to this change, my gnome-panel would move to the top of the
> combined desktop (top of the VGA screen), and there would be no instance
> of gnome-panel anywhere on the LVDS screen. This allowed me to have
> very tall windows that spanned multiple screens with little visual
> interruption.

Ah,

You only have a single panel. A second panel would have used to have
gone in the middle of the two screens.

Yes, your case would be worse with this patch. This patch is a trade-off
though, so there will be some.

With xrandr 1.3 it will be possible to make the behaviour configurable,
but that's not an option for Jaunty.

Thanks,

James

Dave Gilbert (ubuntu-treblig) wrote :

Hmm this change made all my panels swap monitors in my dual head setup. I have 2 monitors 1920x1080 external, 1280x800 laptop internal with the external logically above the internal one as far as X knows. I have 3 panels; top & bottom of external and bottom of internal.

After this change they swapped places - so I had the two on the internal and one on the external.

I've moved them back; as long as they stay put I'm not going to be too fussed about it - but I'm not sure changing behaviour where people have positioned panels is a good idea.

Dave

Damien Cassou (cassou) wrote :

The latest update made things really bad for me. My laptop screen is below my primary monitor. This setup worked very well until yesterday.

Please have a look at bug report #353712 and attached screeenshot.

James Westby (james-w) wrote :

Hi Damien,

Federico has a request for you in the upstream bug:

  "To diagnose this we need the output of "xrandr -q" and "xprop -root". I wonder
if the WM struts are wrong."

if you have a GNOME bugzilla login you can answer directly in

  http://bugzilla.gnome.org/show_bug.cgi?id=562944

if not then answer here and we can relay the information.

Thanks,

James

Sean Dague (sdague) wrote :

Adding a "me too" of this make gnome not work on most of my machines, given that they are accessed via NX. A revert of this patch would be appreciated.

vinicius.vbf (vinicius-vbf) wrote :

+1 on the NX issue. Please revert this patch ASAP and please test future patches on machines accessed through NX. Thanks.

Sebastien Bacher (seb128) wrote :

there is no need to keep adding such +1 comment, that's just spamming subscribers, and it's not up to you to command other people to do thing "asap" or test on nx, don't run an unstable distribution if you want a totally stable one

kyleabaker (kyleabaker) wrote :

Sebastien Bacher
I just have to +1 that.

It helps no one if you just +1 bugs. Just click the link that it affects you too. Frankly I'm getting tired of people commenting about old news. Just freaking stop.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-panel - 1:2.26.0-0ubuntu6

---------------
gnome-panel (1:2.26.0-0ubuntu6) jaunty; urgency=low

  * debian/patches/27_handle_overlapping_monitors.patch,
    debian/patches/28_prefer_lvds_monitor.patch:
    - don't use those changes for jaunty, they create several issues and it's
      late in the cycle to work on those (lp: #192009, #352716)

 -- Sebastien Bacher <email address hidden> Mon, 06 Apr 2009 11:49:42 +0200

Changed in gnome-panel (Ubuntu):
status: Triaged → Fix Released
vinicius.vbf (vinicius-vbf) wrote :

Sebastien Bacher, I wasn't commanding, I was asking.
I thought that the +1 comment helps to get a sample of how many users are being affected by the issue. I won't do that anymore.
The package was stable before this patch. I just suggested to add NX testing before releasing future versions. I'm trying to use Ubuntu as our primary dev. env. at my company and unfortunatelly we need to test our products on the next release (that should be very stable at this point).
Regards

Changed in gnome-control-center:
status: New → Invalid
Pieter Ennes (skion) wrote :

Using gnome-panel (1:2.26.0-0ubuntu6) my gnome-panels are still swapped when compared to intrepid, but reading the above comments makes me think that this version should behave the same again as it did with intrepid? Does anyone have a manual fix already? Adding --primary to the xrandr command does not seem to work for me.

$ xrandr --output LVDS --auto --left-of VGA --output VGA --primary --auto
$ xrandr --output LVDS --primary --auto --left-of VGA --output VGA --auto

both do the same, but when using --right-of in stead of --left-of strangely the panels _are_ put on the external screen!

$ xrandr --output LVDS --auto --right-of VGA --output VGA --auto

Seems like the leftmost screen is preferred for primary?

Damien Cassou (cassou) wrote :

Have you tried:

$ xrandr --output LVDS --auto --output VGA --auto --right-of LVDS

?

Pieter Ennes (skion) wrote :

Damien, no, but just tried it now and that command gives panels on the LVDS too. Also:

$ xrandr --output VGA --auto --right-of LVDS --output LVDS --auto

does the same. I've swapped my screens for now, so the big one is on the left.

Guillaume Desmottes (cassidy) wrote :

Re-opening the Ubuntu bug as the patch has been reverted in the 2.26.0-0ubuntu6 package.

Changed in gnome-panel (Ubuntu):
status: Fix Released → Confirmed
Changed in gnome-panel (Ubuntu):
status: Confirmed → Triaged

Is there any update on this bug?

My gnome panel moves from my laptop screen to the external monitor every time I connect it at work and it's profoundly annoying as I travel a lot and lose my gnome panel next time I'm on the road. Going into gconf-editor to kludge it back to the laptop screen is very, very unfriendly.

Alex Leone (acleone) wrote :

Try:
1. Right click on the panel, go to "Properties"
2. Uncheck "Expand"
3. Wait for the panel to shrink (or close the properties window)
4. Left click and drag the little handle on the side of the panel to the other screen
5. Open the properties window and check expand

The panel will reappear on the correct monitor if I enable/disable it. I haven't tried this on a laptop with an external monitor.

(Works for me on Ubuntu 9.10 beta, with an ati x1900xt running one vga and one dvi monitor)

On Karmic you can now position the panels with

$ gconftool --type int --set /apps/panel/toplevels/top_panel_screen0/monitor 1
$ gconftool --type int --set /apps/panel/toplevels/bottom_panel_screen0/monitor 1

On my system this moves the top and bottom panels from LVDS to external VGA.

Luc (luc-santeramo) wrote :

Michael command lines also work on intrepid.
Switch between 0 and 1 to choose your screen.

...6 days before Karmic official release, but thanks anyway !

donal (donalbuckley) wrote :

In my case, I use a laptop also with external VGA.
I just installed Karmic over Intrepid.

With Karmic the laptop comes up as primary but I want the Ext. VGA as primary when it is plugged in.
I've had to add a script to switch both off and reset the External as Primary after each restart (of which I have lot because of lots of various issues with karmic). The reset script only works about one third of the time, (causing blank screen the other two thirds).

With Intrepid the External was Primary when plugged in, (as I would expect most people using an external would require).
Configure Display has no option for setting this though what I would wish to revert to is a way to say "Use External Display As Primary When Present".

I got fed up with manual hacks gconf editor etc etc etc & installed cairo dock which stays put on my laptop screen irrespective of whether I have the external monitor connected. Just what I wanted and though eye-candy's not what it's about, it looks rather good too! You'll need to clear down your gnome panel and set it to hide in some way, but if you're here then you'll know your way round gnome panel well enough to sort something out methinks ;-)

Nigel Babu (nigelbabu) on 2010-06-13
tags: added: patch-accepted-upstream
Changed in gnome-panel:
status: New → Confirmed
Changed in gnome-panel:
importance: Unknown → Medium
Changed in gnome-control-center:
importance: Unknown → Wishlist
status: Invalid → Unknown
Sebastien Bacher (seb128) wrote :

setting the tag to needswork since the patch has been applied so if there is still an issue extra work is required

Changed in gnome-panel (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
tags: added: patch-needswork
removed: patch-accepted-upstream
Changed in gnome-control-center:
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.