Sound Preferences window is unuseable

Bug #411315 reported by Richard Cavell on 2009-08-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME media utilities
Confirmed
Medium
gnome-media (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

[Please fix my package choice].

I'm on Ubuntu Karmic alpha with all updates to date. I'm on a second-generation MacBook. My sound worked perfectly under Jaunty and Karmic until the recent Pulse Audio updates. Now many of my applications are hit and miss - youtube won't play sound but games under wine will play sound. But I'm not complaining about that in this bug report.

If I look at my processes under System Monitor, I have about 30 instances of "aplay", each of which is using 800, 804 or 808 kbytes of RAM and currently sleeping. I presume that these are sounds that were supposed to play but have failed to do so given the new audio architecture changes. I can kill them manually or using "pulseaudio -k".

I have selected "Sound" from my System->Preferences menu to see if I can fix it. It is misbehaving. The sound preferences window has no title and no "X" in the close button's area. The window is about 3 screens high and cannot be resized. If I select the tabs, the screen is only partially drawn - it's as though it wants to spend about a minute redrawing the screen but it never actually gets there.

I realize that the underlying problem is with Pulse Audio, but still Sound Preferences shouldn't behave like this. Screenshots should explain.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

affects: gnome-settings-daemon (Ubuntu) → gnome-media (Ubuntu)
Changed in gnome-media (Ubuntu):
importance: Undecided → Low
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
tags: added: usability
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=591746

Changed in gnome-media (Ubuntu):
status: New → Triaged
Changed in gnome-media:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-media:
status: Unknown → New
Changed in gnome-media:
status: New → Confirmed
Richard Cavell (richardcavell) wrote :

I'm not happy for this to be marked as a duplicate. My bug report is about the user interface, not the audio problems.

Gabe Gorelick (gabegorelick) wrote :

I agree, this is not a duplicate of bug 559442, since this has to do with the UI side of having a lot of applications using sound.

Changed in gnome-media:
status: Confirmed → Fix Released
Changed in gnome-media:
importance: Unknown → Medium
Changed in gnome-media:
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.