Can't toggle audio recording for devices in Volume Control applet to 'on' state

Bug #290543 reported by dcarpenter on 2008-10-29
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME media utilities
Fix Released
Medium
gnome-media (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-volume-manager

Toggling audio recording on for devices in the recording tab of the Volume Control applet is functioning incorrectly

[What I expected to happen]
When toggling a device to the 'on' state, I expected the setting to be saved after closing and reopening the Volume Control applet.

[What happened instead]
All devices that I toggled to 'on' were reverted back to the off state after closing and reopening the Volume Control applet.

I believe that this is a display error, as I am able to record from the microphone if I toggle it on in alsa-mixer even if it is displayed as toggled 'off' in the Volume Control applet

lsb_release -rd:
Description: Ubuntu 8.10
Release: 8.10

gnome-volume-manager:
  Installed: (none)
  Candidate: 2.24.0-0ubuntu1
  Version table:
     2.24.0-0ubuntu1 0
        500 http://us.archive.ubuntu.com intrepid/universe Packages

lspci:
00:00.0 Host bridge: Intel Corporation 82875P/E7210 Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation 82875P Processor to AGP Controller (rev 02)
00:03.0 PCI bridge: Intel Corporation 82875P/E7210 Processor to PCI to CSA Bridge (rev 02)
00:06.0 System peripheral: Intel Corporation 82875P/E7210 Processor to I/O Memory Interface (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc R360 NJ [Radeon 9800 XT]
01:00.1 Display controller: ATI Technologies Inc RV350 NJ [Radeon 9800 XT] (Secondary)
02:01.0 Ethernet controller: Intel Corporation 82547EI Gigabit Ethernet Controller
03:02.0 Multimedia video controller: Conexant Systems, Inc. CX23880/1/2/3 PCI Video and Audio Decoder (rev 05)
03:04.0 Multimedia audio controller: Creative Labs SB Audigy (rev 04)
03:04.1 Input device controller: Creative Labs SB Audigy Game Port (rev 04)
03:04.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port (rev 04)

Related branches

dcarpenter (dcarpenter85) wrote :
Sebastien Bacher (seb128) wrote :

thank you for your bug report, what do you toggle on exactly? do you speak about muting and unmuting the volume?

Changed in gnome-applets:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Bartek (tschew) wrote :

I can confirm the stated behaviour on my machine as well. I believe dcarpenter was referring to the "Toggle audio recording from capture" button [ the 50s style microphone in his screengrab ]. When you click the microphone the X is removed but upon closing and reloading gnome-volume-control the X reappears, suggesting that the input cannot be used for recording. However, it works.

dcarpenter (dcarpenter85) wrote :

Yes, Bartek is correct. I click the button and the X is removed, however upon reopening the X is back. And as he stated, the input CAN be used for recording, it is just unclear for the average user if the input is indeed enabled.

Changed in gnome-media:
status: Incomplete → Confirmed
dah bien-hwa (dahbien-hwa) wrote :

I see the same faulty behaviour in gnome-volume-control, meaning the "Toggle audio recording from Capture" always is off (the state with the white X on red ground on it) when opening the window.
I can't reproduce it right now, but it seemed like the state of that setting had some effect as to whether I could record something on my system or not, one or two hours ago today. But after also playing around a little with alsamixer, the microphone now always works, regardless of this setting.

Sebastien Bacher (seb128) wrote :
Changed in gnome-media:
status: Confirmed → Triaged
Changed in gnome-media:
status: Unknown → New
Changed in gnome-media:
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now

Changed in gnome-media:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-media - 2.25.5-0ubuntu1

---------------
gnome-media (2.25.5-0ubuntu1) jaunty; urgency=low

  * New upstream version:
    - Add desktop files and icons for gnome-volume-control
    - Add a new sound theme
    - Fix some of the resizing on startup in the volume control
    - Simplify the sound theme selection
    - Fix a few positioning problems in the volume applet
    - Add a mute toggle item in the volume applet (lp: #290543)
    - Make the volume slider instantaneous
    - Fix "no applications" message when there are applications
    - Fix the volume applet not showing up in some cases (lp: #314966)
    - Add a close button to the sound capplet
    - Hide sound events from the applications tab
    - Fix scrolling with the mouse wheel going in the wrong direction
      (lp: #317751)
  * debian/control.in:
    - build-depends on libxml2-dev
  * debian/patches/06_autoconf.patch:
    - new version update

 -- Sebastien Bacher <email address hidden> Tue, 20 Jan 2009 23:32:11 +0100

Changed in gnome-media:
status: Fix Committed → Fix Released
j.benes (j-benes) wrote :

Sorry to re-open this bug, but on Ubuntu Jaunty, gnome-media ver. 2.26-0ubuntu3 and the bad behavoiour of invalid state (as described above) still exists.

Adam Dorsey (adorsey) wrote :

Also confirming that this bug exists in Jaunty, using gnome-media 2.26.0-0ubuntu3.

Changed in gnome-media (Ubuntu):
status: Fix Released → Confirmed
Sebastien Bacher (seb128) wrote :

don't reopen closed bug but open a new bug if you have a similar issue on jaunty

Changed in gnome-media (Ubuntu):
status: Confirmed → Fix Released
Thorsten Staerk (dev-staerk) wrote :

This bug affects me as well. I cannot see from the above descriptions how it would be fixed. Which gnome-media package version do I need so it is fixed in Intrepid?

Changed in gnome-media:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.