$HOME/Desktop and $HOME/Documents are hardcoded

Bug #259051 reported by Khashayar Naderehvandi on 2008-08-18
8
Affects Status Importance Assigned to Milestone
GNOME New Main Menu
Fix Released
Medium
gnome-main-menu (Ubuntu)
Low
Julian Andres Klode
libslab (Ubuntu)
Undecided
Julian Andres Klode

Bug Description

It seems like some paths are hardcoded in gnome-main-menu, notably $HOME/Documents and $HOME/Desktop. Instead, $HOME/.config/user-dirs.dirs should be parsed in order to learn which folders are the appropriate ones with regards to the user's current locale. As things are now, when GMM is started $HOME/Documents is created (in addition to my $HOME/Dokument), and under the 'places' tab there's a Desktop button that points to a non-existent Desktop dir.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, the issue is known upstream, you can read about it on http://bugzilla.gnome.org/show_bug.cgi?id=486548

Changed in gnome-main-menu:
importance: Undecided → Low
status: New → Triaged
Changed in gnome-main-menu:
status: Unknown → New
Gert Kulyk (gkulyk) wrote :

For intrepid, this bug (as well as many others) should be fixed in a recent upload of the package to my ppa:

deb http://ppa.launchpad.net/gkulyk/ubuntu intrepid main
deb-src http://ppa.launchpad.net/gkulyk/ubuntu intrepid main

Please test it, if it is working for you, I'll attach the patch to the upstream-bug-report.

Thank you very much!

The package from your ppa solves the issues reported here, as well as a bunch of others. Please attach the patch to the upstream bug-report!

Gert, not much seems to be happening on the upstream bug. How about you trying to push the changes directly to Ubuntu (Jaunty) instead?

Maxxer (lorenzo-milesi) wrote :

gert, do you still keep your ppa updated?

Julian Andres Klode (juliank) wrote :

I am working on it and hope to get this into Lucid.

Changed in gnome-main-menu (Ubuntu):
assignee: nobody → Julian Andres Klode (juliank)
status: Triaged → In Progress
Julian Andres Klode (juliank) wrote :

Adding libslab, since some parts are there now and not in gnome-main-menu anymore. Furthermore,

I have pushed commits to my branches to fix this bug:
  git://git.debian.org/users/jak/gnome-main-menu.git
  git://git.debian.org/users/jak/libslab.git

and hope that someone pulls those branches into the gnome.org ones (I already sent an email to them). I'll probably upload a new package with those patches in a few days/weeks.

Changed in libslab (Ubuntu):
assignee: nobody → Julian Andres Klode (juliank)
status: New → In Progress
Julian Andres Klode (juliank) wrote :

Just committed the changes to the pkg-gnome repository on svn.debian.org, once the package is uploaded and synced, this bug will be closed automatically.

Changed in gnome-main-menu (Ubuntu):
status: In Progress → Fix Committed
Changed in libslab (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libslab - 2.27.91-3

---------------
libslab (2.27.91-3) unstable; urgency=low

  * use-xdg-user-directories.diff: Use XDG user directories instead of
    hardcoding $HOME/Desktop and $HOME/Documents (LP: #259051).

libslab (2.27.91-2) unstable; urgency=low

  * Merge patches from openSUSE / Novell
    - libslab-bnc187879-fix-crash.patch: Fixes a crash
      See https://bugzilla.novell.com/show_bug.cgi?id=187879
    - libslab-bnc536778-fix-libslab-split.patch: Fixes parts of gnome-main-menu
      which were empty because libslab looked in the wrong location.
      See https://bugzilla.novell.com/show_bug.cgi?id=536778
    - libslab-bnc537483-fix-redraw.patch:
      See https://bugzilla.novell.com/show_bug.cgi?id=537483
  * debian/rules: Disable dh_auto_test because it fails due to the upstream
    buildsystem thinking that files in .pc have to be translated.
  * debian/control: Set Standards-Version to 3.8.4.
  * debian/libslab0a.lintian-overrides: Add an override for the soname.
 -- Andrew Starr-Bochicchio <email address hidden> Mon, 15 Feb 2010 16:38:21 +0000

Changed in libslab (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-main-menu - 0.9.13-5

---------------
gnome-main-menu (0.9.13-5) unstable; urgency=low

  * nm-glib-0.8.diff: Only check for NM if we have iwlib (Closes: #569537).

gnome-main-menu (0.9.13-4) unstable; urgency=low

  * debian/rules: Use dh_autoreconf instead of manual autoreconf stuff.
  * debian/rules: Pass --with quilt to dh on clean.
  * fix-binutils-gold-build.diff: Fix build with gold (Closes: #554655).
  * use-xdg-user-directories.diff: Use XDG user directories instead of
    hardcoding $HOME/Desktop and $HOME/Documents (LP: #259051).
  * nm-glib-0.8.diff: Support new libnm-glib name in NM 0.8 (Closes: #569320).
 -- Julian Andres Klode <email address hidden> Mon, 22 Mar 2010 19:25:31 +0000

Changed in gnome-main-menu (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-main-menu:
importance: Unknown → Medium
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.