GNOME DVB Daemon breaks Totem translations

Bug #680519 reported by Piotr Drąg on 2010-11-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME DVB Daemon
Undecided
Sebastian Pölsterl
gnome-dvb-daemon (Fedora)
Won't Fix
Medium

Bug Description

GNOME DVB Daemon plugin breaks translations in Totem. We get untranslated labels and such (Playing instead of "Odtwarzanie"), and it's visible in Credits window (see attached screenshot), where it should be "Aviary.pl <email address hidden>, 2008, 2009, 2010" instead of "Lauchpad Contributors:".

Reported downstream: https://bugzilla.redhat.com/show_bug.cgi?id=647203

Related branches

Description of problem:

Totem uses translation from Launchpad instead of upstream one. It's strange, since tarball and SRPM includes correct, upstream translation.

Version-Release number of selected component (if applicable):
totem-2.30.2-1.fc13.x86_64

Actual results:

Launchpad translation used, "Lauchpad Contributors:" in credits window.

Expected results:

Upstream translation used, "Aviary.pl <email address hidden>, 2008, 2009, 2010" in credits window.

Additional info:

It can be observed also in Fedora 14.

Created attachment 455992
Example in Polish localization

I can't reproduce this either way with F14.

What's the output of "locale" on your machine, and which Totem plugins do you have installed/enabled (my first guess would be a bug in the gnome-dvb-daemon Totem plugin).

I have manually enabled only Thumbnail plugin, but gnome-dvb-daemon is indeed automatically started by totem. I've also noticed that those "Lauchpad Contributors" string comes from gnome-dvb-daemon translation.

[Piotrek@Piotrek-laptop ~]$ locale
LANG=pl_PL.utf8
LC_CTYPE="pl_PL.utf8"
LC_NUMERIC="pl_PL.utf8"
LC_TIME="pl_PL.utf8"
LC_COLLATE="pl_PL.utf8"
LC_MONETARY="pl_PL.utf8"
LC_MESSAGES="pl_PL.utf8"
LC_PAPER="pl_PL.utf8"
LC_NAME="pl_PL.utf8"
LC_ADDRESS="pl_PL.utf8"
LC_TELEPHONE="pl_PL.utf8"
LC_MEASUREMENT="pl_PL.utf8"
LC_IDENTIFICATION="pl_PL.utf8"
LC_ALL=

[Piotrek@Piotrek-laptop ~]$ rpm -qa|grep totem
totem-pl-parser-2.30.3-1.fc13.x86_64
totem-2.30.2-1.fc13.x86_64
totem-mozplugin-2.30.2-1.fc13.x86_64
totem-nautilus-2.30.2-1.fc13.x86_64

Reassigning to gnome-dvb-daemon, which is most likely the culprit.

Piotr Drąg (piotrdrag) wrote :

Reported upstream.

Sebastian Pölsterl (sebp) wrote :

Thanks for reporting this bug. Could you please check if the attached patch solves the issue?

Changed in gnome-dvb-daemon:
status: New → Confirmed
assignee: nobody → Sebastian Pölsterl (sebp)
Piotr Drąg (piotrdrag) wrote :

Yes, it does fix it.

Changed in gnome-dvb-daemon:
status: Confirmed → Fix Committed
Changed in gnome-dvb-daemon:
status: Fix Committed → Fix Released
Changed in gnome-dvb-daemon (Fedora):
importance: Unknown → Medium
status: Unknown → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.