Deleting or stopping print jobs does not work

Bug #934291 reported by Felix on 2012-02-17
94
This bug affects 17 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Unknown
High
cups-pk-helper (Debian)
New
Unknown
cups-pk-helper (Ubuntu)
Critical
Unassigned
Bionic
Critical
Till Kamppeter

Bug Description

Deleting or stopping print jobs through the "gnome-control-center -> printers" menu is not possible.
(Black rectangle for stopping can be pressed, nothing happens.)

Deleting with cups via webinterface does work. ( http://localhost:631/ )

Please let me know which information to provide.

Cheers

[Impact]

The most intuitive way for users to maintain printers and look after print jobs is the printing part of the GNOME Control Center. As this tool makes use of cups-pk-helper for authentication, a lot of its functionality is not working dur to the non-working in cups-pk-helper package.

This way a key functionality in Ubuntu Desktop is not working which may people turn away from Linux on the desktop.

[Test Case]

Do job operations (remove, move to other printer, ...) with print jobs using the printing tool of GNOME Control Center ("Devices" -> "Printers"). You will see that most or all of these operations do not work.

They will work after installing this update.

[Regression Potential]

cups-pk-helper is only used by some graphical user interfaces for printer operations, like the mentioned GNOME tool. It does not impact printing itself, CUPS command line operations, or the CUPS web admin interface.

Also the changes on cups-pk-helper are not done in its code or its way how it works but only in its configuration (using a system user).

This way the regression potential is low.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-control-center 1:3.2.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-16.28-generic 3.0.17
Uname: Linux 3.0.0-16-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Fri Feb 17 16:47:32 2012
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
SourcePackage: gnome-control-center
UpgradeStatus: Upgraded to oneiric on 2011-12-17 (61 days ago)
usr_lib_gnome-control-center:
 deja-dup 22.0~bzr1290.37~oneiric1
 gnome-bluetooth 3.2.0-0ubuntu2
 indicator-datetime 0.3.1-0ubuntu1.1

Felix (apoapo) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, what desktop environment do you use? Can you make a screenshot of the dialog?

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Felix (apoapo) wrote :

I am using gnome-shell. This bug is present since i am using GS. (About 5 months now)

I stopped my network connection to make the job pending for some time to get my screens.
After having ressed the "stop" button, the button is grayed out but the job is not deleted. After re-activating my wireless, my network printer started printing immediately.

As i said, the cups webinterface is able to delete jobs.

Cheers

Felix (apoapo) wrote :
Sebastien Bacher (seb128) wrote :

do you have cups-pk-helper installed?

Changed in gnome-control-center (Ubuntu):
status: Incomplete → New
Felix (apoapo) wrote :

That package was not installed. However, installing it (and restarting the laptop to be sure..) didn't solve the issue.

Sebastien Bacher (seb128) wrote :

ok, then it seems it's an upstream bug, there is a reason we don't use their print ui by default ;-) should probably be reported to bugzilla by somebody using gnome-shell and having the issue

Sebastien Bacher (seb128) wrote :

Seems similar to https://bugzilla.gnome.org/show_bug.cgi?id=669679, you might want to subscribe to that bug, comment on it

Changed in gnome-control-center (Ubuntu):
status: New → Triaged
Changed in gnome-control-center:
importance: Unknown → High
status: Unknown → New
Michael Pacey (michael-wd21) wrote :

This is insane! The only way to cancel a print job in Ubuntu is to open a terminal and use the cancel command!

I applied for a job at Canonical and was unsuccessful. I promise if you'd employed me I would NOT have allowed this to happen!

Michael Pacey (michael-wd21) wrote :

Also, I'm going to have to use mpage to do two pages per side because of the crazy way gnome printing works. What's going on? Mark Shuttleworth, you went into space, did you come back?

Sebastien Bacher (seb128) wrote :

@Michael: what desktop do you use? "Ubuntu" (or its default desktop: unity) uses system-config-printer still instead of the GNOME Ui and the interface we are using doesn't have that issue...

To maintain a respectful atmosphere, please follow the code of conduct - http://www.ubuntu.com/project/about-ubuntu/conduct . Bug reports are handled by humans, the majority of whom are volunteers, so please bear this in mind.

Changed in gnome-control-center:
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

is that still an issue in raring?

Changed in gnome-control-center (Ubuntu):
status: Triaged → Incomplete
Chris Hermansen (c-hermansen) wrote :

Sebastien, I am running 13,04 and confirm that the System Settings > Printers as invoked from Gnome Shell is

- unable to cancel my jobs
- unable to display others' jobs that are hung / clogging up the printer queue
- absent of some useful features like the enabled checkbox

I can make screen shots if that is useful

Christopher (soft-kristal) wrote :

Still an issue in Ubuntu Gnome 14.04, but I was able to cancel the job in cups (http://localhost:631).

Domenico (domenico-somma) wrote :

I have the same problem. Here a work-around: https://bugzilla.gnome.org/show_bug.cgi?id=669679#c10

aurelijusr (aurelijus-rozenas) wrote :

Same in Ubuntu Gnome 14.10 (Gnome Shell 3.14). Works with workaround suggested by Domenico.

I've been investigating this issue recently and can confirm that, while this is not an issue in my Fedora machine with the very same version of cups, cups-pk-helper and gnome-control-center installed, it is still present in Ubuntu, due to what I believe it might be a bug in the way CUPS is being packaged by debian (thus Ubuntu would have inherited the bug). Thus it's probably a bug in Debian as well.

Long story short, while Fedora configures "root" to be part of CUPS system administration group, Debian/Ubuntu does not do that and instead defines "lpadmin" as the only member of that group. Now, because gnome-control-center actually relies in cups-pk-helper to cancel jobs, CUPS won't allow doing that in ubuntu because neither the owner of the job (cups-pk-helper runs as root, not as the username originating the cancel request from g-c-c) nor an user belonging to SystemGroup is requesting such an operation. As a result, the operation is not cancelled.

You can see a more detailed explanation here: https://bugzilla.gnome.org/show_bug.cgi?id=669679#c23

I fixed this locally by changing the debian/rules so that I pass "--with-system-groups='lpadmin root'" to dh_auto_configure, instead of simply passing 'lpadmin' and that works for me. I think it's worth reporting this to debian, but it's unclear to me how to do so, so I thought I would report it here for now, in case someone could lend a hand with it.

Thoughts?

PS: A temporary fix for users facing this problem, better than setting JobsPrivateValues to 'none', would be to simply edit /etc/cups/cups-files.conf and manually add 'root' to SystemGroup

Sebastien Bacher (seb128) wrote :

Till, could you have a look, the previous comment points to debian/ubuntu packaging issues

Changed in cups (Ubuntu):
assignee: nobody → Till Kamppeter (till-kamppeter)
importance: Undecided → High

I hope this old and quite serious bug will get some attention soon.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cups (Ubuntu):
status: New → Confirmed

The but is still present.
The workaround by @mariospr fixes it though.

Dirk Schmidtke (dirkschmidtke) wrote :

What a pity! Bug is still present in UbuntuGnome 16.10 with Gnome Shell 3.20.

Moritz Baumann (mo42) wrote :

This is a simple packaging/configuration issue, the bug has been assigned for 18 months and it still isn't fixed? Come on, guys!

shemgp (shemgp) wrote :

Here's a patch to add root to the system-groups in the rules file in the debian directory.

The attachment "add root to system-groups in rules" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
tags: added: rls-z-incoming
Changed in cups (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Confirmed
Robie Basak (racb) wrote :

Mario, thank you for the detailed analysis. This is really helpful.

I wonder though if the right fix would be to have cups-pk-helper run as lpadmin, rather than root? I'm not familiar with the details though, so I don't know if that would work or is possible. If the goal in having lpadmin is to reduce things that must be root, then perhaps this is the right answer though?

This probably does need sending up to Debian and getting their opinion. In particular I don't want to inadvertently compromise security by just making something run as root.

Till, do you have any opinion?

Robie Basak (racb) wrote :

Unsubscribing ~ubuntu-sponsors for now, as I don't think this is ready for an upload to Ubuntu without either Till's opinion or an opinion from Debian or a fix in Debian. Please resubscribe ~ubuntu-sponsors if you disagree or an upload is otherwise ready to go in.

Robie Basak (racb) wrote :

> by just making something run as root

Well it's rather than inverse of course.

If cups-pk-helper is only to allow doing things like creating, modifying, removing queues, managing jobs, changing config options in cupsd.conf and NOT for changing options in cups-files.conf, then it will work perfectly also if running as lpadmin. lpadmin is exactly for these things.

So my suggestion is to run cups-pk-helper as lpadmin and not as root.

shemgp (shemgp) wrote :

Here's another debdiff to make cups-pk-helper run as lpadmin.

shemgp, did you test this patch?

There is no user "lpadmin". With "run as lpadmin" I mean run as a user which is in the lpadmin group.

So the better solution would be to build CUPS with root in the system group or let root be member of the lpadmin group.

OdyX, WDYT about applying the patch of comment #24 to the Debian/Ubuntu package of CUPS? It adds root to CUPS' system group and this way cups-pk-helper (runs as root) can authenticate queue and job manipulations from GUIs.

If there are any objections from the Debian side, what about letting only Ubuntu builds include root in the system group?

shemgp (shemgp) wrote :

Now, yes. I thought it was working but I was using a gnome-shell extension that used the command 'cancel' to cancel a job and not cups-pk-helper. Anyway, still digging into it. Sorry for the non-working patch.

shemgp (shemgp) wrote :

Here's another debdiff. I tested this on my machine and was able to delete jobs from the queue. I just had to add the annotation which I got an idea from from the colord package.

Thanks for the quick fix.

shemgp (shemgp) wrote :

Here's a more complete fix. Added the annotation for all actions and made setting the daemon user an option in the configure.ac.

Didier Raboud (odyx) wrote :

Re:
> OdyX, WDYT about applying the patch of comment #24 to the Debian/Ubuntu package of CUPS? It adds root to CUPS' system group and this way cups-pk-helper (runs as root) can authenticate queue and job manipulations from GUIs.

I think it should not be solved in CUPS, but in cups-pk-helper, as the incoming patches apparently do.

Meiden (revolcon69) wrote :

Can't believe that this bug is still present after 5 years....

Felix (apoapo) wrote :

Welcome 2 Linux. Enduser is worthless!

So then why does no one apply the patch of comment #36? OdyX (printing maintainer for Debian) and me, we are OK with this solution.

Changed in cups (Ubuntu):
status: Confirmed → Invalid
Changed in cups-pk-helper (Ubuntu):
status: New → Triaged
importance: Undecided → High

Added cups-pk-helper task and re-subscribed ubuntu-sponsors.

Changed in gnome-control-center (Ubuntu):
status: Incomplete → Invalid

I have applied the patch of comment #36 to cups-pk-helper now (nothing uploaded, only local testing) and for me it does not work.

On the command line I have disabled a print queue and send a job to it, by disabling the job stays in the queue so that one has time to do the actual test.

Now I have started gnome-control-center and opened the section "Devices"/"Printers". The queue I have stopped is shown as such and it is also shown that it has one job. I clicked the "1 job" button to open the job viewer. There are pause and kill buttons in the job line and a "Clear all" button at the top. Neither with the kill button nor with the "Clear all" button I can remove the jobe. I also cannot re-enable the queue via the "Restart" in the print queue list.

"Restart" button for the queue returns to work when I re-install the original cups-pk-helper without the patch.

If I add "root" as member of the "lpadmin" group in /etc/group, all is working perfecty: Kill button of the job list entry, "Clear all" at the top of job list, and "Restart" in the print queue entry.

OdyX, WDYT? Should we add root as member of the lpadmin group?

shemgp, your latest patch is still not working for me, see comment #42.

Unsubscribing ubuntu-sponsors, as cups-pk-helper patch does not solve the problem.

Changed in cups-pk-helper (Ubuntu):
status: Triaged → Incomplete
Changed in cups (Ubuntu):
status: Invalid → Incomplete
shemgp (shemgp) wrote :

Hello,

Are you using Artful? I've tested it again in Ubuntu 17.10 and the UI doesn't get updated immediately but it does pause, resume, and cancel jobs just fine: https://youtu.be/Z5IuAAtKlnI.

Could you test using this PPA: https://launchpad.net/~shemgp/+archive/ubuntu/other-apps?

I'll test it in Xenial tomorrow in the office if it works there (https://launchpad.net/~shemgp/+archive/ubuntu/xenial).

I use Artful and I have added your PPA now. I have also removed "root" as member of the "lpadmin" group in /etc/group, to have only your fix active.

What did you change in your PPA compared to your patch from comment #36?

shemgp, unfortunately, your newest patch still does not solve the problem for me.

Didier Raboud (odyx) wrote :

It's fine to have root as member of the lpadmin group. BUT… it's not fine to have cups-pk-helper run as root and allow unauthorized users (in CUPS' eyes) cancel other user's jobs.

This should be fixed in cups-pk-helper through making it interact with CUPS using the requesting user's user. This would ensure that CUPS's authorizations are respected.

I don't want to see a situation where "any GNOME user" accesses "cups-pk-helper which runs as root" and can then "manipulate CUPS as if it were a member of lpadmin".

shemgp (shemgp) wrote :

Yup, as I see it using cups-pk-helper gives two layers of auth, one for cupsd and another for policy-kit. Using cups-pk-helper as lpadmin or root would override cupsd permissions as it'll be running with all privileges, but there's still the policy-kit permissions.

Right now, I've tested it, with my patch, printer jobs can't be seen between users in gnome-control panel (I think it has nothing to do with my patch though). Jobs still can be seen in the "Additional Printer Settings", but when I try to delete the job, there, of an admin user from a non-admin user it asks me for the password of the admin user. Deleting the other way around works though (admin deleting non-admin jobs).

Also, there's a gnome-extension named "Printers" which uses cupsd commands to delete jobs, etc. In that extension as admin, I can see non-admin jobs, and can delete them. On a non-admin account, I can't see admin jobs.

Also, for Till Kamppeter (till-kamppeter), the diff between my ppa and the latest debdiff is:
3,4c3,10
< +++ cups-pk-helper-0.2.6/debian/changelog 2017-07-12 14:25:18.000000000 +0800
< @@ -1,3 +1,15 @@
---
> +++ cups-pk-helper-0.2.6/debian/changelog 2017-12-14 11:00:48.000000000 +0800
> @@ -1,3 +1,21 @@
> +cups-pk-helper (0.2.6-1ubuntu3~artful1) artful; urgency=medium
> +
> + * Recompile for artful
> +
> + -- Shem Pasamba <email address hidden> Thu, 14 Dec 2017 11:00:48 +0800
> +
However, here's still the latest debdiff.

shemgp, thank you also for this attempt but it is also not working for me.

Does the PPA work?

Sent from Mailspring (https://link.getmailspring.com/link/local-2575ba08-3601@shemgp-x230t/0?redirect=https%3A%2F%2Fgetmailspring.com%2F&recipient=934291%40bugs.launchpad.net), the best free email app for work

On Dec 21 2017, at 12:05 am, Till Kamppeter <email address hidden> wrote:
> shemgp, thank you also for this attempt but it is also not working for
> me.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/934291
>
> Title:
> Deleting or stopping print jobs does not work
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-control-center/+bug/934291/+subscriptions

I have tried the PPA some days ago (Dec 15) and it did not work. Is there a new version on the PPA?

shemgp (shemgp) wrote :

Thanks for testing. It really does not work on a freshly installed Artful, because the mechanism was only allowing root and not lpadmin to run. I changed that and tested it on a freshly installed Artful, and it worked, so here's another debdiff. I also updated my PPA. Please do test.

It is working now. Thank you very much.

Can someone upload this version of cups-pk-helper to Bionic? Thanks.

Patch to apply is the one of comment #53.

Changed in cups (Ubuntu):
status: Incomplete → Invalid
Changed in cups-pk-helper (Ubuntu):
status: Incomplete → In Progress

Sorry for dropping the ball on this one, for some reason I completely missed all notifications and I only happened to find this bug today almost by chance :-)

Anyway, if you don't mind me asking... I understand that my workaround of passing --with-system-groups='lpadmin root' to configure when building CUPS would no longer be needed with the patches for cups-pk-helper 0.2.6-1ubuntu2 and 0.2.6-1ubuntu3?

If so, one more question: would this be proposed to Debian? I can't see them in https://packages.debian.org/sid/cups-pk-helper, but comments in this thread seem to suggest the intention is to have them there as well.

Many thanks in any case

Changed in gnome-control-center:
status: Incomplete → Unknown
Ken VanDine (ken-vandine) wrote :

@odyx do you think the patch in comment #53 is suitable for debian? I'd like to avoid a delta with debian if possible, so i'll defer sponsoring this until we have some agreement on the fix.

Didier Raboud (odyx) wrote :

@ken-vandine: I'd not name the system user 'lpadmin' but rather 'cups-pk-helper', which is more precise, especially as its creation/deletion is handled by the cups-pk-helper maintainer scripts.

Other than that, it looks like a good solution.

That said, only the cups-pk-helper maintainer in Debian (Guido Günther, see https://tracker.debian.org/pkg/cups-pk-helper) can have a definitive opinion there.

Promoted this bug to "Critical". Its solution is essentially important for all functions of the GNOME printer tool to work.

Changed in cups-pk-helper (Ubuntu):
importance: High → Critical
no longer affects: cups (Ubuntu)
no longer affects: gnome-control-center (Ubuntu)

Here is the debdiff for Cosmic, the same as the one of comment #53 but with system user cups-pk-helper.

And here is the debdiff for the SRU for Bionic, it should only differ by the version number.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups-pk-helper - 0.2.6-1ubuntu2

---------------
cups-pk-helper (0.2.6-1ubuntu2) cosmic; urgency=medium

  [ Shem Pasamba ]
  * debian/patches/Use_cups-pk-helper_in_org.opensuse.CupsPkHelper.Mechanism.conf.patch
    - Use cups-pk-helper in org.opensuse.CupsPkHelper.Mechanis.conf
      instead of root
  * debian/patches/run_as_cups-pk-helper.patch
    - Make the cups-pk-helper run as cups-pk-helper passing cups-pk-helper as
      user too. (LP: #934291)
  * debian/cups-pk-helper.postinst:
    - Add cups-pk-helper group and user.
  * debian/cups-pk-helper.postrm:
    - Remove cups-pk-helper user and group.
  * Added --with-daemon-user

  [ Till Kamppeter ]
  * Use cups-pk-helper as system user.

 -- Till Kamppeter <email address hidden> Fri, 4 May 2018 17:37:58 +0200

Changed in cups-pk-helper (Ubuntu):
status: In Progress → Fix Released
Changed in cups-pk-helper (Ubuntu Bionic):
status: New → Triaged
importance: Undecided → Critical
Changed in cups-pk-helper (Ubuntu Bionic):
milestone: none → ubuntu-18.04.1
assignee: nobody → Ken VanDine (ken-vandine)

Note that bug 1290533 is NOT caused by this fix, it already has occurred before.

description: updated
Changed in cups-pk-helper (Ubuntu Bionic):
assignee: Ken VanDine (ken-vandine) → Till Kamppeter (till-kamppeter)

Hello Felix, or anyone else affected,

Accepted cups-pk-helper into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cups-pk-helper/0.2.6-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in cups-pk-helper (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-bionic
Download full text (4.1 KiB)

I left gnome.

A servant of the Most High God,

Ron McIlvaine

On Fri, Jun 1, 2018, 5:05 AM Timo Aaltonen <email address hidden> wrote:

> Hello Felix, or anyone else affected,
>
> Accepted cups-pk-helper into bionic-proposed. The package will build now
> and be available at https://launchpad.net/ubuntu/+source/cups-pk-
> helper/0.2.6-1ubuntu1.1
> <https://launchpad.net/ubuntu/+source/cups-pk-helper/0.2.6-1ubuntu1.1> in
> a few hours, and then in the -proposed
> repository.
>
> Please help us by testing this new package. See
> https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
> to enable and use -proposed.Your feedback will aid us getting this
> update out to other Ubuntu users.
>
> If this package fixes the bug for you, please add a comment to this bug,
> mentioning the version of the package you tested and change the tag from
> verification-needed-bionic to verification-done-bionic. If it does not
> fix the bug for you, please add a comment stating that, and change the
> tag to verification-failed-bionic. In either case, without details of
> your testing we will not be able to proceed.
>
> Further information regarding the verification process can be found at
> https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in
> advance!
>
> ** Changed in: cups-pk-helper (Ubuntu Bionic)
> Status: Triaged => Fix Committed
>
> ** Tags added: verification-needed verification-needed-bionic
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/934291
>
> Title:
> Deleting or stopping print jobs does not work
>
> Status in gnome-control-center:
> Unknown
> Status in cups-pk-helper package in Ubuntu:
> Fix Released
> Status in cups-pk-helper source package in Bionic:
> Fix Committed
>
> Bug description:
> Deleting or stopping print jobs through the "gnome-control-center ->
> printers" menu is not possible.
> (Black rectangle for stopping can be pressed, nothing happens.)
>
> Deleting with cups via webinterface does work. ( http://localhost:631/
> )
>
> Please let me know which information to provide.
>
> Cheers
>
>
> [Impact]
>
> The most intuitive way for users to maintain printers and look after
> print jobs is the printing part of the GNOME Control Center. As this
> tool makes use of cups-pk-helper for authentication, a lot of its
> functionality is not working dur to the non-working in cups-pk-helper
> package.
>
> This way a key functionality in Ubuntu Desktop is not working which
> may people turn away from Linux on the desktop.
>
> [Test Case]
>
> Do job operations (remove, move to other printer, ...) with print jobs
> using the printing tool of GNOME Control Center ("Devices" ->
> "Printers"). You will see that most or all of these operations do not
> work.
>
> They will work after installing this update.
>
> [Regression Potential]
>
> cups-pk-helper is only used by some graphical user interfaces for
> printer operations, like the mentioned GNOME tool. It does not impact
> printing itself, CUPS command line operations, or the CUPS web admin
> interface.
>
> Also the changes o...

Read more...

shemgp (shemgp) wrote :

Version 0.2.6-1ubuntu1.1 from proposed doesn't seem to be able to delete print jobs. In my current build though (0.2.6-1ubuntu4~artful1) it works. Tested on Ubuntu 18.04. Haven't had time to look at it lately. Maybe I'll look at it again once my printer gets fixed.

I am also not able to get it working with the new package, both with the binary package downloaded and with the package built from source by myself.
Something additional seems to be broken.

Proposed package definitely does not work in Bionic and Cosmic. Using exactly the patch of comment #53 works though.
Investigating what went wrong with the user name change.

tags: added: verification-failed verification-failed-bionic
removed: verification-needed verification-needed-bionic
Changed in cups-pk-helper (Ubuntu Bionic):
status: Fix Committed → In Progress
Changed in cups-pk-helper (Ubuntu):
status: Fix Released → In Progress

Here is the corrected fix. The new user cups-pk-helper must be in the lpadmin group, not in its own new group.
debdiff for Cosmic is attached.

Changed in cups-pk-helper (Ubuntu):
status: In Progress → Fix Committed

And here is the correction for the SRU for Bionic.

Ken VanDine (ken-vandine) wrote :

I've sponsored the fix to both cosmic and bionic-proposed

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups-pk-helper - 0.2.6-1ubuntu3

---------------
cups-pk-helper (0.2.6-1ubuntu3) cosmic; urgency=medium

  * debian/cups-pk-helper.postinst: Do not add cups-pk-helper group, make
    cups-pk-helper user member of lpadmin group instead (LP: #934291).

 -- Till Kamppeter <email address hidden> Wed, 6 Jun 2018 15:20:58 +0200

Changed in cups-pk-helper (Ubuntu):
status: Fix Committed → Fix Released
Felix (apoapo) wrote :

Crazy! Can not believe it really happened!

"Bug #934291 reported by Felix on 2012-02-17"

Thank you very much!

Hello Felix, or anyone else affected,

Accepted cups-pk-helper into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cups-pk-helper/0.2.6-1ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in cups-pk-helper (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
removed: verification-failed verification-failed-bionic
Esokrates (esokrarkose) wrote :

I have forwarded the info to the Debian maintainers Guido Günther, see
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=698504

He would like to see the patch upstreamed ...

@Till, @shemgp could you please propose your patch to upstream?

Furthermore, could you please arrange with the Debian maintainer in order to have handle this across Debian and Ubuntu?

Changed in cups-pk-helper (Debian):
status: Unknown → New

I have tested the package from -proposed now and it solves the problem. Everything is working as intended. Marking the fix verified ...

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic

I would like to briefly intrude to say "thanks to everyone" for this.

On Thu, Jun 14, 2018 at 12:46 PM, Till Kamppeter <email address hidden>
wrote:

> I have tested the package from -proposed now and it solves the problem.
> Everything is working as intended. Marking the fix verified ...
>
> ** Tags removed: verification-needed verification-needed-bionic
> ** Tags added: verification-done verification-done-bionic
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/934291
>
> Title:
> Deleting or stopping print jobs does not work
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-control-center/+bug/934291/+subscriptions
>

--
Chris Hermansen · clhermansen "at" gmail "dot" com

C'est ma façon de parler.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cups-pk-helper - 0.2.6-1ubuntu1.2

---------------
cups-pk-helper (0.2.6-1ubuntu1.2) bionic-proposed; urgency=medium

  * debian/cups-pk-helper.postinst: Do not add cups-pk-helper group, make
    cups-pk-helper user member of lpadmin group instead (LP: #934291).

 -- Till Kamppeter <email address hidden> Wed, 6 Jun 2018 16:23:58 +0200

Changed in cups-pk-helper (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for cups-pk-helper has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.