Alternative keyboard layouts missing in Keyboard Preferences in Oneiric & Precise

Reported by Chascon on 2011-10-25
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center
New
Undecided
Unassigned

Bug Description

Symptom
I can't add alternative keyboard layouts.

Steps to reproduce
Go to Keyboard Layout
Press the + button
Nothing at all appears. That is no selections to choose from.

Realize the + button is faded, despite that the other buttons (- and others) light up.

Expected results
Alternative keyboard layouts should appear to choose from, ie., Dvorak, Colemak, etc.

Release
Description: Ubuntu 11.10
Release: 11.10

uname -r
3.0.0-12-generic

Chascon (chascone) wrote :

After several updates I've noticed that this bug report had not gotten any attention, because it seems that it only affects me. So I wanted to bring attention to the fast that this isn't so.

Before reporting this bug, I found a __current__ thread about missing layouts in the Ubuntu forum.

http://ubuntuforums.org/showthread.php?t=1714436&highlight=keyboard+layouts+missing

I followed the advice and fiddled with both keyboards-rg and xkb-data to not avail.

In addition there are others with layout issues.
http://ubuntuforums.org/showthread.php?t=1822904&highlight=keyboard+layouts+missing

Chascon (chascone) wrote :

To be clear the procedure outlined in https://help.ubuntu.com/11.04/ubuntu-help/keyboard-layouts.html does not work. A workaround, although temporary was to issue

sudo dpkg-reconfigure keyboard-configuration

That allowed me to select the standard US keyboard layout, with the the help of wikipedia (http://en.wikipedia.org/wiki/IBM_PC_keyboard to identify the exact physical keyboard I have). The new layout showed up in the Unity applet, to the exclusion of my previous selections, but did not do so once within the keyboard preferences pane, where only my previously selected ones showed up.

The newer US layout eventually disappeared sometime after changing the options within the keyboard preferences pane (to one of my earlier layout choices).

It seems that the keyboard preferences pane breaks after the upgrade, and if it hasn't been reported it's probably because most people are monolingual and/or use solely one layout, and haven't bothered re-configuring layouts. Thus, they haven't found the pane to be broken because they haven had the need to reconfigure.

I not sure if the following procedure would fare any better.

cat /usr/share/i18n/SUPPORTED | grep "en\|ru" > /var/lib/locales/supported.d/local
dpkg-reconfigure locales
update-locale LANG=en_US.UTF-8

http://ubuntuguide.org/wiki/Ubuntu:Edgy/TipsAndTricks#How_to_set_the_Compose_key_to_type_special_characters

Chascon (chascone) wrote :

I've upgraded to Precise and the issue continues. This is what I've done since then without results that stick.

Thinking that the problem is linked to the fact that I uninstalled other-than-English language support with BleachBit, I did the following. reinstalled language-selector-gnome reinstalled language-pack-en-base

I went back to now called Keyboard Layout and the + button is still faded.

I even went so far as to add Spanish locale to see if I could add another layout, but this didn't make a difference. I can't add any layouts to the ones I already have installed (US alternative, US International, English Mac, and the International alt/Gr version).

I tried the following: dpkg-reconfigure locales update-locale LANG=en_US.UTF-8

Although it did seem to update my locale settings, when I went back to the now called Keyboard Layout, the + button was still faded.

I haven't tried dpkg-reconfigure localeconfig because this is not installed and apparently xkeyboard-config is an eol.

xkb-data looks promissing from the read in software-center: "This package contains configuration data used by the X Keyboard Extension (XKB), which allows selection of keyboard layouts when using a graphical interface."

A quick wajig reinstall xkb-data proved my hopes wrong.

It seems the only thing that temporarily allowed me to install more layouts was sudo dpkg-reconfigure keyboard-configuration. I selected the colemak layout to see if took. I ran it but by the time I rebooted, the change didn't stick. Plugging in an external keyboard also makes colemak in the applet disappear.

The strange thing about using dpkg-reconfigure keyboard-configuration is that the app menu applet shows the change but System Settings --> Keyboard Layout doesn't. It always shows the eternal US alternative, US International, English Mac, and the International alt/Gr layouts. And I can never add a layout through this pane.

I just reinstalled iso-codes, and for a few minutes I saw that the keyboard Unity "applet" showed colemak I had installed previously with. I relogged back in and it was gone but colemak shows in cat /etc/default/keyboard but not in Xorg. A quick alt+cntl F1 show me that it did take, only in console.

"XKBMODEL="pc104" XKBLAYOUT="us" XKBVARIANT="colemak" XKBOPTIONS="terminate:ctrl_alt_bksp"

Somehow I don't think sudo dpkg-reconfigure keyboard-configuration was meant to (only?) change the console layout.

I'm just reading /etc/default/keyboard and it says the following.

If you change any of the following variables and X is configured to use this file, then the changes will become visible to X only if udev is restarted. You may need to reboot the system.

I can assume that X is listening, at least until I reboot, when changes are thrown away. So, I assume there is a conflict between more than one file or sets of files as to which layouts take predominance.

Any ideas anyone? This one has me stumped.

Chascon (chascone) wrote :

Since I'm running a macbook pro 1,1, I wonder if it relates to https://bugs.launchpad.net/ubuntu/+source/xkeyboard-config/+bug/327963, although I don't get an error message or https://bugs.launchpad.net/ubuntu/+source/gnome-applets/+bug/629503 but in that bug the user can add, they just don stick.

summary: Alternative keyboard layouts missing in Keyboard Preferences in Oneiric
+ & Precise
Chascon (chascone) wrote :

Running through dpkg-reconfigure keyboard-configuration __without__ my external keyboard, if anyone is thinking that it's interfering, and then quickly rebooting resulted in it not sticking.

Chascon (chascone) wrote :

So I see two problems, and I assume they're related.

1) layout changes via dpkg-reconfigure keyboard-configuration do not stick, and
2) I can't add layouts via System Settings/Keyboard Layout.

Chascon (chascone) on 2012-04-18
description: updated
Chascon (chascone) on 2012-04-19
no longer affects: console-setup (Ubuntu)
no longer affects: xkeyboard-config
Chascon (chascone) wrote :

Ok, I've realized a few things and this has cleared some of this mess.

1) The Keyboard Layout has a default limit of 4 layouts. Anything more and the + (add) button dims, eliminating the ability to add another layout. This should be written up as a separate bug.

2) Changing the layout in unity's "applet" does not change it in X. /etc/default/keyboard shows the following, even if layouts are repositioned in Keyboard Layout in System Settings.

XKBMODEL="pc104"
XKBLAYOUT="us"
XKBVARIANT="intl"
XKBOPTIONS="terminate:ctrl_alt_bksp"

3) lightdm takes to the change, at least if it's done via Keyboard Layout.

4) X doesn't take to the change even if it's done via Keyboard Layout.

Clearly there is a conflict between /etc/default/keyboard and Keyboard Layout. I would assume a workaround to be to run the following:

1. sudo dpkg-reconfigure keyboard-configuration
2. and then to edit /etc/default/keyboard to coincide with the input into the previous routine (pkg-reconfigure keyboard-configuration)

See http://krisreeves.com/things-that-should-be-easy/permanently-change-keyboard-layout-on-ubuntu-server-11-10/

I should really stop writing here, as the basic premise of not being able to implement more layouts seems invalid (and thus I'll change this bug's status to invalid), although I might report 1) this limitation of 4 layouts as a bug.

2) There are also the issues of any layout chosen from dpkg-reconfigure keyboard-configuration not sticking, /etc/default/keyboard not keeping sync with dpkg-reconfigure keyboard-configuration.

3) The issue of not being able to change a layout within a session from the Unity "applet", /etc/default/keyboard not keeping sync with applet.

4) And the issue of /etc/default/keyboard not keeping in sync with selections taken in Keyboard Layout, which explains why desktop sessions (X) revert to previous settings.

/etc/default/keyboard seems to want to do it's own thing, regardless of what other utilities want.

Chascon (chascone) wrote :

Apparently gnome-keyboard-properties should bring up Keyboard Layout from System Settings, but I get command not found. Hmm.

Chascon (chascone) wrote :

I'm surprised my bug report wasn' t confirmed, despite there now being a few similar bugs, one for a French layout and some others that are thought to be duplicates. I think this reported preceded those, but who's keeping track.

Anyway (for those that might come across this), I found a fix, my fix and it takes care of bug https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/986322 too.

1. Open the gnome preference "keyboard layout" pane
2. Move the layout order, if you have more than one
3. Delete all layouts except the default one (mine was a US layout)

The previous two steps have been suggested as fixes on their own (on the Ubuntu forums?). They did not work for me. I tried them together consecutively and this again did not work for me. Thus my next step.

4. Press, "Reset to Defaults"
5. Layout changes effectuated from both the layout pane and indicator now result in a change in layout.

Chascon (chascone) wrote :

6. Of course, add layouts back before attempting to change to them.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers