Ctrl-w does not close control center windows

Bug #863549 reported by Māris Fogels on 2011-09-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
Low
gnome-control-center (Ubuntu)
Low
Unassigned

Bug Description

None of the settings windows opened from the System Settings dialog respond to the Ctrl-w shortcut for closing windows.

Steps to reproduce:

 1. Open the System Settings dialog via the indicator menu
 2. Open a window for any individual setting (Sound, Keyboard, Power,....)
 3. Type Ctrl-w

What happens: Nothing
What should happen: The settings window should close

Ctrl-w is a common keyboard shortcut for closing windows in Linux. So are Ctrl-q and Escape. The settings windows do not respond to any one of these.

This only affects individual settings windows like Sound, Power, and so forth. The main System Settings window does respond to Ctrl-q and closes in response to it.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-control-center 1:3.2.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Fri Sep 30 14:17:20 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110915.1)
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, user)
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)
usr_lib_gnome-control-center:
 deja-dup 20.0-0ubuntu3
 gnome-bluetooth 3.2.0-0ubuntu1
 indicator-datetime 0.2.95-0ubuntu1

Māris Fogels (mars) wrote :
Māris Fogels (mars) wrote :

Is there a Human Interface Guideline document for GNOME that I could reference in the report? Surely this is a violation.

Māris Fogels (mars) on 2011-09-30
description: updated
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Pedro Villavicencio (pedro) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:
https://bugzilla.gnome.org/show_bug.cgi?id=660814

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-control-center:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-control-center:
importance: Unknown → Low
status: Unknown → New
Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream in http://git.gnome.org/browse/gnome-control-center/commit/?id=ec739861f0f7b82bb0a70da74d79c3daf356f71a

" shell: Make Ctrl+W close panels

    Ctrl+W will close the current panel, and go back to the
    overview."

Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Committed
Changed in gnome-control-center:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.2.2-2ubuntu2

---------------
gnome-control-center (1:3.2.2-2ubuntu2) precise; urgency=low

  * debian/libgnome-control-center1.symbols: restore the symbols tracking,
    since we build external capplets we better check they don't break
  * debian/rules: don't build shlibs for a library which stopped being
    distributed in GNOME3
  * debian/patches/94_git_adding_shortcuts.patch:
    - let add custom shortcuts in any categorie
  * debian/patches/95_git_ctrlw_shortcut.patch:
    - ctrl-W close capplets and go back to the overwiew (lp: #863549)
 -- Sebastien Bacher <email address hidden> Mon, 23 Jan 2012 15:11:19 +0100

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.