The play button is active when "No sound" is selected in gnome-sound-properties

Bug #32861 reported by Sylvain Defresne on 2006-02-25
6
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
Medium
control-center (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

When the "No sound" options is selected for an event, the play button is still active, but an error message is displayed when clicked. The button should be disabled when this option is selected, as no sound can be played.

The attached patch change the play button to be insensible (that is grayed out) when the "No sound" option is selected.

It does not remove the error dialog box, but I could do it if needed (as the "clicked" signal could no longer be sent by the button with "No sound" selected).

Changed in gnome-control-center:
assignee: nobody → desktop-bugs
Jonathon Conte (thesicktwist) wrote :

Confirmed here on Dapper testing (flight 6 + updates). Would be great if this made it in before the final release.

Changed in gnome-control-center:
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

Reassigning to control-center, "gnome-control-center" is not a correct source package

Vassilis Pandis (pandisv) wrote :

Still an issue on Edgy. Forwarded upstream: http://bugzilla.gnome.org/show_bug.cgi?id=353828

Changed in control-center:
status: Unconfirmed → Unknown
Changed in control-center:
status: Unknown → Confirmed
Changed in control-center:
importance: Medium → Low
Changed in control-center:
status: Confirmed → Fix Released
Vassilis Pandis (pandisv) wrote :

Upstream have committed a variation of this patch.

Changed in control-center:
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :

That upload fixes the bug:

 control-center (1:2.17.90-0ubuntu1) feisty; urgency=low
 .
   * New upstream version:
     common:
     - Removed non-critical g_return_if_fail
     - Added support for saving and applying the gtk-color-scheme key
     - Replaced non-standard categories with X-GNOME...
     - Check for xf86misc lib in addition to header files
     about-me:
     - Fixed compilation on Solaris
     - Made translatable strings more generic
     a11y:
     - Renamed to "Keyboard Accesiblity" in .desktop file
     background:
     - Fixed several compile warnings
     default applications:
     - Moved capplet from System to Personal category
     keyboard:
     - Don't crash if default group is not set in GConf
     keybindings:
     - Moved scrolled window calls to their correct place
     - Fixed leaks
     - Corrected .desktop category entry
     mouse:
     - Fixed memory leaks
     sound:
     - Added NULL-check
     - Fixed spacing and build the whole dialog from Glade
     - Show the sound properties view after adding it to the dialog
     - Fixed label alignments bug caused by Glade-3 #396433
     - Set play button insensitive when no sound is selected
       (Ubuntu: #32861)
     theme switcher:
     - Fixed build with gcc 2
     - Removed separate color scheme saving UI
     - Added support for gtk-color-scheme key in metatheme info
     - Added a revert button to the color schemes tab
     typing break:
     - Set default icon and application name
     windows:
     - Fixed leak
     shell:
     settings daemon:
     - Added missing NULL-check
     - Removed variable that was never initialized
     - Quit application when window is closed (Ubuntu: #78152)
     - Set program name to gnome-control-center
   * debian/patches/25_window_manager_settings.patch:
     - updated
   * debian/patches/90_from_svn_fix_no_schemas_sound_properties_crasher.patch:
     - dropped, fixed with the new version
   * debian/patches/91_from_svn_list_misc_category.patch:
     - dropped, fixed with the new version

Changed in control-center:
status: Fix Committed → Fix Released
Changed in gnome-control-center:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.