Online Accounts: GNOME Control Center

gnome-control-center crashed with SIGSEGV in finish_with_cleanup()

Reported by Nicholas Skaggs on 2013-02-11
214
This bug affects 36 people
Affects Status Importance Assigned to Milestone
Online Accounts: GNOME Control Center
High
David King
gnome-control-center-signon (Ubuntu)
Medium
Tommy Bengtsson
Raring
Undecided
Unassigned

Bug Description

This crash is reminiscent of this bug and is completely reproducible.

https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/805473

Open empathy.
Select accounts
In the online accounts popup, select a new account type.
Click the all setting button at the top left of the window
Crash occurs

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: gnome-control-center 1:3.6.3-0ubuntu12
ProcVersionSignature: Ubuntu 3.8.0-5.10-generic 3.8.0-rc6
Uname: Linux 3.8.0-5-generic x86_64
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Mon Feb 11 18:10:52 2013
ExecutablePath: /usr/bin/gnome-control-center
InstallationDate: Installed on 2012-07-13 (213 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MarkForUpload: True
ProcCmdline: gnome-control-center credentials
SegvAnalysis:
 Segfault happened at: 0x7f54086591e5: mov 0x28(%rbx),%rdi
 PC (0x7f54086591e5) ok
 source "0x28(%rbx)" (0xaaaaaaaaaaaaaad2) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: gnome-control-center
StacktraceTop:
 ?? () from /usr/lib/libaccount-plugin-1.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libsignon-glib.so.1
 g_simple_async_result_complete () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: gnome-control-center crashed with SIGSEGV in g_simple_async_result_complete()
UpgradeStatus: Upgraded to raring on 2012-11-16 (87 days ago)
UserGroups: sambashare sudo
usr_lib_gnome-control-center:
 activity-log-manager-control-center 0.9.4-0ubuntu6.1
 deja-dup 25.5-0ubuntu1
 gnome-control-center-signon 0.1.2bzr12.12.05-0ubuntu1
 gnome-control-center-unity 1.2-0ubuntu1
 indicator-datetime 12.10.3daily13.02.06-0ubuntu1

Related branches

lp:~mardy/gnome-control-center-signon/lp1122520
Merged into lp:gnome-control-center-signon at revision 142
David King (community): Approve on 2013-03-22
PS Jenkins bot: Approve (continuous-integration) on 2013-03-22
Nicholas Skaggs (nskaggs) wrote :

StacktraceTop:
 finish_with_cleanup (self=0x7f543c1e4580) at libaccount-plugin/oauth-plugin.c:118
 process_async_cb_wrapper (object=<optimized out>, res=0x7f543c447250, user_data=user_data@entry=0x7f543c270c90) at signon-auth-session.c:243
 g_simple_async_result_complete (simple=0x7f543c447250) at /build/buildd/glib2.0-2.35.7/./gio/gsimpleasyncresult.c:777
 complete_in_idle_cb (data=0x7f543c447250) at /build/buildd/glib2.0-2.35.7/./gio/gsimpleasyncresult.c:789
 g_main_dispatch (context=0x7f543bf7c9f0) at /build/buildd/glib2.0-2.35.7/./glib/gmain.c:3054

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
summary: - gnome-control-center crashed with SIGSEGV in
- g_simple_async_result_complete()
+ gnome-control-center crashed with SIGSEGV in finish_with_cleanup()
tags: removed: need-amd64-retrace
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1122520

tags: added: package-qa-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
information type: Private → Public
David King (amigadave) on 2013-02-28
affects: gnome-control-center (Ubuntu) → gnome-control-center-signon (Ubuntu)
Jason Robinson (jaywink) wrote :

Can confirm this too. I reported #1134765 yesterday but didn't remember the right place I clicked to make it crash. It was indeed the "All settings" button. Immediately after clicking this with for example Facebook auth window open the whole settings UI crashes.

Attached report from "ubuntu-bug gnome-control-center-signon".

David King (amigadave) on 2013-03-07
Changed in gnome-control-center-signon:
status: New → In Progress
importance: Undecided → High
assignee: nobody → David King (amigadave)
milestone: none → 0.1.4
Changed in gnome-control-center-signon (Ubuntu):
assignee: nobody → Tommy Bengtsson (tommybe1)
Alberto Mardegan (mardy) wrote :

Tommy, do you intend to fix this bug yourself, or did you reassign it to you by mistake?
Please let us know, in order to avoid duplicate efforts. :-)

Tommy Bengtsson (tommybe1) wrote :

I fix it myself.

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:gnome-control-center-signon at revision 142, scheduled for release in gnome-control-center-signon, milestone 0.1.4

Changed in gnome-control-center-signon:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center-signon - 0.1.5-0ubuntu1

---------------
gnome-control-center-signon (0.1.5-0ubuntu1) raring; urgency=low

  * New upstream release.
    - OAuthPlugin: don't crash when cancelling the authentication or disposing
      the plugin (LP: #1122520)
 -- Alberto Mardegan <email address hidden> Mon, 25 Mar 2013 11:00:59 +0200

Changed in gnome-control-center-signon (Ubuntu):
status: Confirmed → Fix Released
Changed in gnome-control-center-signon:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center-signon (Ubuntu Raring):
status: New → Confirmed
razor7 (ghiamar) wrote :

Well, accessing online account manager, Gnome Control Center just crashes

My Online Account package version is gnome-control-center-signon:i386 0.1.6bzr13.04.05-0ubuntu1

To post a comment you must log in.