Use icons from the symbolic namespace

Bug #923576 reported by Daniel Fore on 2012-01-30
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GNOME Bluetooth
Fix Released
Medium
elementary OS
Fix Released
High
Unassigned
gnome-bluetooth (Ubuntu)
Wishlist
Unassigned

Bug Description

the bluetooth indicator should use panel icons from the symbolic namespace. This would provide greater upstream theme compatability as well as reduce the need for additional gtk-theme-based icon themes to handle light/dark theme changes. The icon names in question are as follows:

bluetooth-active-symbolic
bluetooth-disabled-symbolic

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-bluetooth (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, is upstream using those?

Changed in gnome-bluetooth (Ubuntu):
importance: Undecided → Wishlist
Daniel Fore (danrabbit) wrote :

Those are the icon names from the GNOME icon theme. I would assume that if GNOME Shell shows Bluetooth in the panel those are the icons they would use, but I'm not entirely sure.

Changed in elementaryos:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → elementary Drive-by Contributors (elementary-driveby)
Daniel Fore (danrabbit) wrote :

It looks like there is an upstream report marking this as fixed. Could just be a packaging issue?

Changed in elementaryos:
assignee: elementary Drive-by Contributors (elementary-driveby) → nobody
milestone: none → 0.2-luna
Changed in gnome-bluetooth:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in elementaryos:
status: Confirmed → Incomplete
Changed in gnome-bluetooth (Ubuntu):
status: Confirmed → Incomplete
Changed in elementaryos:
milestone: 0.2-luna → luna-beta1

./applet/notify.c:#define ACTIVE_ICON_NAME "bluetooth-active"
both upstream and in Ubuntu

Changed in gnome-bluetooth (Ubuntu):
status: Incomplete → Confirmed
Changed in elementaryos:
status: Incomplete → Confirmed

I can't just go and flip over those icon names because the package also ships fallback icons for hicolor icon theme which are not symbolic. Those fallback icons have to be changed too. And this patch is so deeply upstream that I'm afraid we'll end up patching it in elementary OS only, at least this cycle.

Wait. According to the code, it already uses symbolic icons, both in Ubuntu and upstream. Incomplete again, until proven to not work.

Changed in gnome-bluetooth (Ubuntu):
status: Confirmed → Incomplete
Changed in elementaryos:
status: Confirmed → Incomplete

Maybe we don't have symbolic icon in elementary OS because there's no bluetooth-disabled-symbolic icon in elementary theme?

Daniel Fore (danrabbit) wrote :

There are both of these icons present in elementary. Check the status/symbolic folder.

As far as I can tell, the indicator will use "bluetooth", "bluetooth-active", and "bluetooth-disabled" but it won't use the -symbolic variants.

Changed in elementaryos:
status: Incomplete → Confirmed
Mario Guerriero (mefrio-g) wrote :

In elementary are now used the symbolic icons even if I don't think it was an eOS bug

Changed in elementaryos:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-bluetooth - 3.6.1-0ubuntu1

---------------
gnome-bluetooth (3.6.1-0ubuntu1) raring; urgency=low

  * New upstream release

  [ Jeremy Bicha ]
  * debian/patches/01_use_app_indicator.patch:
    - Use symbolic icons so that the Unity bluetooth menu looks ok with
      alternative icon themes (LP: #923576)
 -- Robert Ancell <email address hidden> Fri, 16 Nov 2012 09:55:55 +1300

Changed in gnome-bluetooth (Ubuntu):
status: Incomplete → Fix Released
Changed in elementaryos:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.