Add/Remove crashed on opening gnome-app-install crashed with AttributeError in get_maintenance_status()

Bug #382336 reported by Didius Falco on 2009-06-01
This bug affects 35 people
Affects Status Importance Assigned to Milestone
gnome-app-install (Ubuntu)

Bug Description

Binary package hint: gnome-app-install

Description: Ubuntu karmic (development branch)
Release: 9.10

  Installed: 0.5.24-0ubuntu1.1
  Candidate: 0.5.24-0ubuntu1.1
  Version table:
 *** 0.5.24-0ubuntu1.1 0
        500 karmic/main Packages
        100 /var/lib/dpkg/status

Opened Add/Remove software for normal use.

Opened Add/Remove Software and immediately started getting crash reports in a continuous string. App did not lock up or disappear, just issued non-stop crash reports.

ProblemType: Crash
Architecture: i386
Date: Mon Jun 1 18:32:28 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/gnome-app-install
InterpreterPath: /usr/bin/python2.6
Package: gnome-app-install 0.5.24-0ubuntu1.1
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gnome-app-install
ProcVersionSignature: Ubuntu 2.6.30-6.7-generic
PythonArgs: ['/usr/bin/gnome-app-install']
SourcePackage: gnome-app-install
Title: gnome-app-install crashed with AttributeError in get_maintenance_status()
Uname: Linux 2.6.30-6-generic i686
UserGroups: adm admin audio cdrom crontab dialout dip fax fuse lp lpadmin netdev plugdev pulse pulse-access pulse-rt root sambashare ssh tape video

Didius Falco (pagun666) wrote :
visibility: private → public

I can reproduce this.

Changed in gnome-app-install (Ubuntu):
status: New → Confirmed
tags: removed: need-duplicate-check

I can confirm

Confirmed - could this be a Python version problem? Similar problems occurred a couple of years ago and the temporary fix was to link to the previous Python version.

Tried removing and re-installing gnome-app-install from Synaptic. Noted that dependencies removed were not re-instated on re-install and installation reported a bad '.desktop' file.

Re-installed application exhibits same behaviours as before.

The re-install errors are reported in Bug #385248 re: /usr/share/app-install/desktop/pauker.desktop

The pauker.desktop file is missing '[Desktop Entry]' as the first line. After adding it the error goes away and gnome-app-install can be re-installed without the error message... it still won't run though!

cazacugmihai (cazacugmihai) wrote :

I also can confirm this bug. It appears when I upgrated my system from 9.04 to 9.10.

Jack Ronan (cooljackthe1) wrote :

worked fine earlier then i didnt touch it then i wanted to install a game but it errored- 9.10

Kootoe (kootoe) wrote :

Happened to me also.

Charles Gray (cgraysportron) wrote :

Look, all I see is people with problems and no software to fix them. Then you ask me what kind of bug/whatever and how do I know?. Just give me a system check that does fix problems and a "click here to fix" button to solve my problems. Everyone is talking over my head. I'm ready to go back to windows/mac or pad and paper.
<email address hidden>

Phillip Susi (psusi) wrote :

This package has been removed from Ubuntu. Closing all related bugs.

Changed in gnome-app-install (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers