gnome-app-install has problems with searching

Bug #354563 reported by MikiTwic on 2009-04-03
132
This bug affects 10 people
Affects Status Importance Assigned to Milestone
gnome-app-install
Undecided
Michael Vogt
gnome-app-install (Ubuntu)
Medium
Michael Vogt
Jaunty
Undecided
Unassigned
Karmic
Medium
Michael Vogt

Bug Description

Jaunty; 2.6.28-11-generic #41-Ubuntu; x86_64
g-a-m ver: 0.5.24-0ubuntu1

TEST CASE:
1. open gnome-app-install
2. search for "abcde"
3. clear the search and verify that no results are displayed
4. restart g-a-i
5. search for chess
6. click on games, click on office, click on games, click on office
7. verify that the list is not empty now when office is selected

8. install the version from jaunty-proposed
9. repeat steps 1-7 and verify that the steps work correctly now

If you search for something that doesn't exist in gnome-app-install and then clear the search (or modify the search), the bad filter remains... and you are unable to find anything at all.

What's more, the search filter seems to conflict with the other filters as well, example:
g-a-m starts.
search for chess >shows chess
switch to office category > doesn't show chess
switch to games > shows chess
switch to office again > shows chess !!

In fact, any category will henceforth show the results of the chess search as if they did not filter at all.

Random behaviour is also seen with the "origin menu": If I search for chess (in [default] all available apps), then switch to third party apps chess is not shown (expected), but if I switch back to all available it is still not shown (unexpected). Henceforth No apps will be found until g-a-m is restarted

Also, after a search is done and cleared, switching between categories causes weird behaviour where "all" will show the filtering from games and other randomities.

[Original desc:]

If I'm searching for example cheese in gnome-app-install. If I make mistake in some letter the repair won't help to find anything.
1. Cheese --> result is OK
2. Cheeese repaired on Cheese doesn't find anything

P.S. sorry for my english, I hope you wil understand the problem

Related branches

MikiTwic (tvrznikmichal) wrote :
Changed in gnome-app-install:
status: New → Confirmed
Martin Erik Werner (arand) wrote :

Confirmed.

In fact, if you search for something that doesn't exist and then clear the search, the filter remains... and you are unable to find _anything at all!_

What's more, the search filter seems to completely screw the other filters as well, example:
g-a-m starts.
search for chess >shows chess
switch to office category > doesn't show chess
switch to games > shows chess
switch to office again > shows chess !!

In fact, any category will henceforth show the results of the chess search as if they did not filter at all.

Random behaviour is also seen with the "origin menu": If I search for chess (in [default] all available apps), then switch to third party apps chess is not shown (expected), but if I switch back to all available it is still not shown (unexpected).

Also, after a search is done and cleared, switching between categories causes weird behaviour where "all" will show the filtering from games and other randomities

Search is just completely broken!

wirechief (wirechief) wrote :

All Applications
I searched for Cheese ....it found it

switch to office category > doesn't show chess
switch to games > shows chess
switch to office again ..it crashes with a bug report screen

I am using a live usb with Linux ubuntu 2.6.28-11-generic #37-Ubuntu SMP Mon Mar 23 16:40:00 UTC 2009 x86_64 GNU/Linux
ii gnome-app-install 0.5.22-0ubuntu1

description: updated
Changed in gnome-app-install (Ubuntu):
status: New → Confirmed
Murat Gunes (mgunes) wrote :

Thanks for reporting. I can reproduce this in Jaunty with 0.5.24-0ubuntu1.

Changed in gnome-app-install (Ubuntu):
importance: Undecided → High
status: Confirmed → New
Changed in gnome-app-install:
status: Confirmed → New
description: updated
Murat Gunes (mgunes) on 2009-04-14
tags: added: regression-potential
Changed in gnome-app-install (Ubuntu):
importance: High → Medium
status: New → Triaged
Steve Beattie (sbeattie) on 2009-04-17
Changed in gnome-app-install (Ubuntu):
assignee: nobody → canonical-desktop-team
Martin Pitt (pitti) wrote :

Michael, since that's your baby, I toss it to you. Please feel free to ct-rev if appropriate. Thanks!

Changed in gnome-app-install (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Michael Vogt (mvo)
Ahmed Hamed (ahmedhamed88) wrote :

Any news on this issue? I faced this bug today and discovered it was reported. I was able to reproduce it on Jaunty x64 final.

Steve Beattie (sbeattie) on 2009-04-28
tags: added: jaunty regression-release
removed: regression-potential
Michael Vogt (mvo) wrote :

Thanks for the bugreport.

I can reproduce this problem. I attached a debdiff with a fix that I also uploaded to my PPA. Please test and let me know if it fixes the problems for you.

Changed in gnome-app-install (Ubuntu):
status: Triaged → In Progress
Michael Vogt (mvo) on 2009-04-29
description: updated
Martin Pitt (pitti) wrote :

Accepted gnome-app-install into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gnome-app-install (Ubuntu Jaunty):
status: New → Fix Committed
tags: added: verification-needed
Martin Erik Werner (arand) wrote :

I've compiled using gnome-app-install_0.5.24-0ubuntu1.1.dsc here on lp (seems deb hasn't hit repos yet) and ran through test case; as well as did some general messing about with searching.

As far as I saw, the issue is completely gone (what was it that caused this?).

Steve Beattie (sbeattie) wrote :

I have reproduced the issue with the version of gnome-app-install in jaunty, 0.5.24-0ubuntu1, and can confirm that the version in jaunty-proposed, 0.5.24-0ubuntu1.1, fixes the search issues. It also continues to add and remove software; there is no obivous sign of regressions. Marking verification-done.

(mvo: fyi, there is an actual package named "abcde", it's the "A Better CD Encoder" which is a shell script that's useful for converting audio CDs into mp3s/oggs. It's just not one of the packages that gets listed in gnome-app-install.)

tags: added: verification-done
removed: verification-needed
Akdo (menoft) wrote :

I have same problem here !

I have gnote that is setup, I make a research and there is no match found. This is normal, but after deleting all characters no package go back ! There is some problem when "All" and "Installed applications only" are selected

Look screencast.

Jaunty 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009 i686 GNU/Linux

dpkg -l | grep gnome-app-install
ii gnome-app-install 0.5.24-0ubuntu1 GNOME Application Installer

Akdo (menoft) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-app-install - 0.5.24-0ubuntu1.1

---------------
gnome-app-install (0.5.24-0ubuntu1.1) jaunty-proposed; urgency=low

  * AppInstall/Menu.py:
    - fix search filter bug (LP: #354563)

 -- Michael Vogt <email address hidden> Wed, 29 Apr 2009 10:25:39 +0200

Changed in gnome-app-install (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to karmic as well.

Changed in gnome-app-install (Ubuntu Karmic):
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :

Michael, please commit this upstream as well and close the upstream task. Thanks!

Changed in gnome-app-install:
assignee: nobody → Michael Vogt (mvo)
status: New → Fix Committed
sheena1 (hd-sheena) wrote :

Got the fix, followed instructions. Bug is now gone. Worked for me! Thanks.

Սահակ (petrosyan) wrote :

this bug has been fixed in Ubuntu 9.10

Changed in gnome-app-install:
status: Fix Committed → Fix Released
Andreas Moog (ampelbein) wrote :

Maybe fixed in Ubuntu, but the bug task "gnome-app-install" is about the upstream product, not the ubuntu package.

Changed in gnome-app-install:
status: Fix Released → Fix Committed
Steve Langasek (vorlon) wrote :

given that mvo is the upstream, it appears to be correct that this bug is also fixed upstream. :)

Changed in gnome-app-install:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers