GAJ-0.5.0 not running from source

Bug #624428 reported by José Ernesto Dávila Pantoja
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME Activity Journal
Undecided
Unassigned

Bug Description

Hi, I decided to give a try to the new version of Gnome Activity Journal (the version in lucid repositories is too old) and downloaded the sources from http://edge.launchpad.net/gnome-activity-journal/0.5.0/0.5.0/+download/gnome-activity-journal-0.5.0.tar.gz

After having zeitgeist-daemon (version 0.5.0) up-and-running I tried to launch GAJ but only got this error:

$ ./gnome-activity-journal
------------------------------------------------------------
./gnome-activity-journal:64: DeprecationWarning: BaseException.message has been deprecated as of Python 2.6
  print "ERROR: %s." % e.message
ERROR: No module named zeitgeist.
Did you remember to fetch the 'lp:zeitgeist' and 'lp:fungtk' repositories?

Please see the README file for more information, or contact us
in IRC channel #zeitgeist on Freenode (irc.freenode.net).
------------------------------------------------------------

Revision history for this message
José Ernesto Dávila Pantoja (josernestodavila) wrote :

After re-ordering the directory where I'm trying to run GAC from, I got to this point:

I have a 'zeitgeist' directory with 'zeitgeist-0.5.0' and 'gnome-activity-journal-0.5.0' in it. I perfectly run zeitgeist-daemon.py in background, but when I try to run gnome-activity-journal from its corresponding directory I got this message:

$ ./gnome-activity-journal
You need Zeitgeist 0.5.0 or later for the GNOME Activity Journal to work.
https://launchpad.net/zeitgeist

So I tried to figure out the version of zeitgeist-daemon by running: ./zeitgeist-daemon --version from zeitgeist-0.5.0 directory and I got this:

$ ./zeitgeist-daemon --version
bzr

Can somebody explain me why my zeitgeist version is 'bzr'?

Revision history for this message
Filip Chabik (hadret) wrote :

I have same problem as Jose Ernesto Davila, only when I test zeitgeist-daemon --version, I've got 0.5.0:

~$ zeitgeist-daemon --version
0.5.0

But when I try to launch GAJ 0.5.0, I get this message:

~$ gnome-activity-journal
You need Zeitgeist 0.5.0 or later for the GNOME Activity Journal to work.
https://launchpad.net/zeitgeist

Revision history for this message
Siegfried Gevatter (rainct) wrote : Re: [Gnome-zeitgeist] [Bug 624428] Re: GAJ-0.5.0 not running from source

Hi,

2010/8/27 Jose Ernesto Davila <email address hidden>:
> I have a 'zeitgeist' directory with 'zeitgeist-0.5.0' and 'gnome-
> activity-journal-0.5.0' in it.

Please try renaming "zeitgeist-0.5.0" to just "zeitgeist".

--
Siegfried-Angel Gevatter Pujals (RainCT)
Free Software Developer       363DEAE3

Changed in gnome-activity-journal:
status: New → Confirmed
Revision history for this message
José Ernesto Dávila Pantoja (josernestodavila) wrote :

Hi Siegfried,

I renamed "zeitgeist-0.5.0" to just "zeitgeist" and yet GAJ shows me the same error:

$ ./gnome-activity-journal
You need Zeitgeist 0.5.0 or later for the GNOME Activity Journal to work.
https://launchpad.net/zeitgeist

The only way I could run GAJ was installing it from Zeitgeist-Framework PPA.

Revision history for this message
Siegfried Gevatter (rainct) wrote :

I'm closing this since it's a local setup problem and not a bug.

If you're still experiencing those difficulties and they are impeding your work on GNOME Activity Journal, please raise the issue again using the Answers tracker, Mailing List or on IRC.

Changed in gnome-activity-journal:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers