Better name parsing for compute host's host_name and original_resource_id attributes at Gnocchi

Bug #1781137 reported by Gautam Prasad on 2018-07-11
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Gnocchi
New
Undecided
Unassigned

Bug Description

The resource_id of a host is parsed as resource_id: $.payload.host + "_" + $.payload.nodename. At Gnocchi, we get the following:

"host_name": "compute.8246L2C_10024DA",
"original_resource_id": "8246L2C_10024DA_8246L2C_10024DA",

Since the nodename and host themselves have "_" in their names, its string in itself is less readable and difficult to parse.

host_name uses "." as separator and original_resource_id uses "_". Can this be made consistent?

host_name also uses "compute.<host>". Can this just be name of the host? Since when we query Gnocchi , the "type" already mentions that its nova_compute.

Matthew Edmonds (edmondsw) wrote :

why isn't the resource_id just the host_name, since that is the key used to access the resource in the nova API?

affects: ceilometer → gnocchi
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers