Gnocchi uninstalls packages and stops working keystone Openstack Queens

Bug #1774040 reported by pablobrunetti on 2018-05-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gnocchi
New
Undecided
Unassigned

Bug Description

Hi,

I've installed all the modules (Keystone, Glance, New, Neutron, Horizon) for a Multi-Node setup in OpenStack Queens.

A serious error occurs when installing Gnocchi, causing the uninstallation of the basic services of some modules.

Below you can see the packages that are uninstalled:

The following packages were automatically installed and are no longer required:
gnocchi-metricd is already the newest version (4.2.4-0ubuntu1~cloud0).
python-gnocchiclient is already the newest version (7.0.1-0ubuntu1~cloud0).

The following packages will be REMOVED:
  keystone libapache2-mod-wsgi nova-placement-api openstack-dashboard

Gnocchi Installation Process:

stack@controllerdev:~$ sudo apt-get install gnocchi-api gnocchi-metricd python-gnocchiclient
Reading package lists... Done
Building dependency tree
Reading state information... Done
gnocchi-metricd is already the newest version (4.2.4-0ubuntu1~cloud0).
python-gnocchiclient is already the newest version (7.0.1-0ubuntu1~cloud0).
The following packages were automatically installed and are no longer required:
  libpython2.7 python-csscompressor python-django-appconf python-django-compressor python-django-horizon python-django-openstack-auth python-django-pyscss python-heatclient
  python-pathlib python-pint python-pyscss python-rcssmin python-rjsmin
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  libapache2-mod-wsgi-py3
The following packages will be REMOVED:
  keystone libapache2-mod-wsgi nova-placement-api openstack-dashboard
The following NEW packages will be installed:
  gnocchi-api libapache2-mod-wsgi-py3
0 upgraded, 2 newly installed, 4 to remove and 4 not upgraded.
Need to get 0 B/104 kB of archives.
After this operation, 23.5 MB disk space will be freed.
Do you want to continue? [Y/n] y
Preconfiguring packages ...
(Reading database ... 145748 files and directories currently installed.)
Removing keystone (2:13.0.0-0ubuntu1~cloud0) ...
Site keystone disabled.
apache2_invoke prerm: Disable site keystone.conf
Removing openstack-dashboard (3:13.0.0-0ubuntu1.1~cloud1) ...
Conf openstack-dashboard disabled.
apache2_invoke postrm: Disable configuration openstack-dashboard.conf
Removing nova-placement-api (2:17.0.3-0ubuntu1~cloud0) ...
Site nova-placement-api disabled.
apache2_invoke prerm: Disable site nova-placement-api.conf
Removing libapache2-mod-wsgi (4.3.0-1.1build1) ...
Module wsgi disabled.
apache2_invoke prerm: Disable module wsgi
Processing triggers for man-db (2.7.5-1) ...
Selecting previously unselected package libapache2-mod-wsgi-py3.
(Reading database ... 143471 files and directories currently installed.)
Preparing to unpack .../libapache2-mod-wsgi-py3_4.3.0-1.1build1_amd64.deb ...
Unpacking libapache2-mod-wsgi-py3 (4.3.0-1.1build1) ...
Selecting previously unselected package gnocchi-api.
Preparing to unpack .../gnocchi-api_4.2.4-0ubuntu1~cloud0_all.deb ...
Unpacking gnocchi-api (4.2.4-0ubuntu1~cloud0) ...
Setting up libapache2-mod-wsgi-py3 (4.3.0-1.1build1) ...
apache2_invoke: Enable module wsgi
Setting up gnocchi-api (4.2.4-0ubuntu1~cloud0) ...
Will not register gnocchi endpoint this time (no user request for it).
apache2_invoke: Enable site gnocchi-api.conf

Errors that occur after installing Gnocchi

stack@controllerdev:~$ openstack server list
Failed to discover available identity versions when contacting http://controllerdev:5000/v3. Attempting to parse version from URL.
Unable to establish connection to http://controllerdev:5000/v3/auth/tokens: HTTPConnectionPool(host='controllerdev', port=5000): Max retries exceeded with url: /v3/auth/tokens (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7fe93f877b90>: Failed to establish a new connection: [Errno 111] Connection refused',))

affects: devstack → gnocchi
summary: - Gnocchi uninstalls packages and stops working keystone
+ Gnocchi uninstalls packages and stops working keystone Openstack Queens
pablobrunetti (pablobrunetti) wrote :

Sorry, I installed on computers with Ubuntu 16.04 LTS server and verified that Openstack Queens needs to be installed on the Ubuntu 18.04 LTS server. For this reason conflicts were occurring with libapache2-mod-wsgi-py3 installed by gnocchi and libapache2-mod-wsgi installed by keystone. You may consider this bug to be invalid.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers