fails to find iso file when the ending extension is in capital

Bug #268018 reported by beefcurry on 2008-09-09
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gmount-ISO
Low
Unassigned

Bug Description

When an iso file is named with capital letters it fails to recognize when looking up image files. One work around is instead of searching for .iso files you choose "All files".

Steps to reproduce: Install Hardy version of gmount-iso.

rename a iso file to "CAPITAL.ISO"

launch gmount-iso, look for the file.

everything still mounts okay, just a bit inconvenient and may confuse some people.

Related branches

Changed in gmount-iso:
assignee: nobody → vincent-thomas
importance: Undecided → Low
status: New → Confirmed
Ken Pimontel (ken-specialorder) wrote :

I confirm this "bug". It would be so nice if g-mount finds both .iso and .ISO without the extra step involved.

Ken Pimontel (ken-specialorder) wrote :

Just looked at the course code and as far as my limited programming knowledge tells me, it look like this issue could be solved by adding filter.add_pattern("*.ISO") after line 149 of Gmount-iso.py

Best regards,

Ken

Vincent Thomas (vincent-thomas) wrote :

That's right !
I don't have enought time to correct all "bugs". I hope I'll can soon.
Sorry.

Ken Pimontel (ken-specialorder) wrote :

I understand. Let me know if there is anything I can help with.

shankao (shankao) wrote :

Fixed in version 0.4.1. Thanks!

Changed in gmount-iso:
assignee: Vincent Thomas (vincent-thomas) → nobody
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers