Give a hint to enable Google Talk

Bug #586812 reported by Simon Law on 2010-05-28
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GMail Notifier
Undecided
Unassigned

Bug Description

Give a hint that Google Talk has to be enabled if the server rejects the given credentials

well unfortunately there are many ways to access google mail and this notifier chose this way because it offers great possibilities like the instant mail notification. Another API would require a completely new backend and one also has to enable things like IMAP oder POP3 access... So due to this it is unfortunately limited to GTalk enabled accounts - but this should be possible for most people. Otherwise there are also many generic IMAP notifiers out there...

Changed in gm-notify:
status: New → Won't Fix
Simon Law (sfllaw) wrote :

At the very least, please convert this bug to give a decent warning message about needing (and how to enable) Google Talk for their domain. Not many people will be able to find the DEBUG switch and parse the Jabber output. :P

The problem is that it's not clear from the server response that this is
anything other than a bad username/password.

The only thing I can think of here would be to check if the SRV records are
set. If an SRV record exists for _xmpp-server._tcp.DOMAINNAME.TLD that
points at *.google.com, then the dns is at least telling the world "hey,
google's handling xmpp here".... however that's not required to have
intra-domain xmpp working, so it's still not perfect.

Maybe the dialog should say that it either hase to be gmail, or
googleapps+google-chat-enabled?

On Fri, May 28, 2010 at 08:30, Simon Law <email address hidden> wrote:

> At the very least, please convert this bug to give a decent warning
> message about needing (and how to enable) Google Talk for their domain.
> Not many people will be able to find the DEBUG switch and parse the
> Jabber output. :P
>
> --
> Support Google Apps without Google Talk
> https://bugs.launchpad.net/bugs/586812
> You received this bug notification because you are subscribed to GMail
> Notifier.
>

--
Jeremy Nickurak -= Email/XMPP: <email address hidden> =-

True, it's not clear.

However, if it is not an @gmail.com address, you can have the error message say "Authentication failed. Do you have Chat running? (learn more)"

good idea ;-)

summary: - Support Google Apps without Google Talk
+ Give a hint to enable Google Talk
description: updated
Changed in gm-notify:
status: Won't Fix → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers