Doesn't register to use the messaging menu (indicator-messages) on 14.04 LTS

Bug #1310490 reported by Bortnyák Roland on 2014-04-21
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
GMail Notifier
Undecided
Unassigned
libindicate
Confirmed
Undecided
Unassigned
gm-notify (Ubuntu)
Undecided
Unassigned
libindicate (Ubuntu)
Undecided
Unassigned

Bug Description

I've recently upgraded from Ubuntu 12.04.4 LTS to 14.04 LTS. I've noticed, that the mail icon (indicator-messages) is hidden (I don't use Thunderbird, so it is not installed.)

I know, that it is hidden, because I'm using GMail Notifier, which displays itself if new mail has arrived, and it works.

Package info:
gm-notify:
  Installed: 0.10.3-0ubuntu3
  Candidate: 0.10.3-0ubuntu3
  Version table:
 *** 0.10.3-0ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status

indicator-messages:
  Installed: 13.10.1+14.04.20140410-0ubuntu1
  Candidate: 13.10.1+14.04.20140410-0ubuntu1
  Version table:
 *** 13.10.1+14.04.20140410-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status

python-indicate:
  Installed: 12.10.1-0ubuntu3
  Candidate: 12.10.1-0ubuntu3
  Version table:
 *** 12.10.1-0ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status

$ gsettings get com.canonical.indicator.messages applications
@as []

Please fix this issue!

Lars Karlitski (larsu) wrote :

Hey, thanks for reporting this issue. The messaging menu hides itself when no applications are using it. The output of

  gsettings get com.canonical.indicator.messages applications

shows a list of applications that have registered to appear in the menu. Do Thunderbird and gmail-notifier appear in that list?

Also, is indicator-messages-service running?

Changed in indicator-messages (Ubuntu):
status: New → Incomplete
Bortnyák Roland (antivirtel) wrote :

$ gsettings get com.canonical.indicator.messages applications
@as []

It's empty. But the GMail Notifier notifies me on new e-mails. How can I add it? (This issue is reproduced more of my machines...)

Lars Karlitski (larsu) wrote :

The gmail-notifier doesn't register to use the messaging menu, then. Reassigning this bug to that project.

affects: indicator-messages (Ubuntu) → gm-notify (Ubuntu)
Changed in gm-notify (Ubuntu):
status: Incomplete → New
Bortnyák Roland (antivirtel) wrote :

Yeah, you're right, I've started Thunderbird, and it asked that indicator to show off.

$ gsettings get com.canonical.indicator.messages applications
   ['thunderbird.desktop']

summary: - indicator-messages is hidden on 14.04 LTS
+ Doesn't register to use the messaging menu (indicator-messages) on 14.04
+ LTS
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gm-notify (Ubuntu):
status: New → Confirmed
Aaruni Kaushik (aaruni-kaushik) wrote :

I have been able to get the gm-notify in the messaging menu, by manually creating a symlink to the gm-notify.desktop in /usr/share/indicators/messages/applications , but it doesn't do anything in terms of functionality. Screenshot, when gm-notify is running.

http://img.krow.me/image.php?di=JF6M

It doesn't report the number of unread emails, and doesn't even turn the messaging icon blue when new mail arrives.

Changed in gm-notify:
status: New → Confirmed
Bortnyák Roland (antivirtel) wrote :

Yeah, it can't even marked as Triaged :( Unfortunately.

description: updated
Noseong Park (behack) wrote :

I created the symbolic link, but it is not shown in the messaging menu. Does anybody know the manual document that I can refer to while modifying the python code (gm-notify is written in Python)? I really love this indicator so want to correct by myself.

Bortnyák Roland (antivirtel) wrote :

I'm not familiar with the Unity development, but I can suggest you to see the XChat or Thunderbird code. It may help, if you understand it.

Noseong Park (behack) wrote :

I found that the python binding for libindicate is the problem. This bug is already reported at https://bugs.launchpad.net/ubuntu/+source/libindicate/+bug/1315384. All example codes also don't work.

Changed in libindicate:
status: New → Confirmed
Changed in libindicate (Ubuntu):
status: New → Confirmed
description: updated
Noseong Park (behack) wrote :

I could make it working, but not perfect yet. It shows the gm-notify icon and unread e-mail numbers. I ported to libmessaging-menu. Please somebody continue to take a look a it. I may not be available for the next several days.

1. Download python wrapper for libmessagng-menu
swig -python -module messaging messaging.c

gcc -I/usr/include/python2.7 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/libdbusmenu-glib-0.4 -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/freetype2 -I/usr/include/pixman-1 -I/usr/include/libpng12 -I/usr/include/harfbuzz -I/usr/include/libindicate-0.7 -I/usr/include/libindicate-gtk-0.7/ -lindicate -ldbusmenu-glib -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfontconfig -lgobject-2.0 -lglib-2.0 -lfreetype -lindicate-gtk -I/usr/include/messaging-menu -lmessaging-menu -fPIC -c messaging.c messaging_wrap.c

ld -shared -o _messaging.so messaging.o messaging_wrap.o -lmessaging-menu

Now you can see _messaging.so is created. This is a python wrapper.

2. Download the modified gm-notify and run it.
At line 44, you should specify your wrapper library location.

Noseong Park (behack) wrote :

I forgot to say copy /usr/share/gm-notify/gm-notify.desktop to /usr/share/applications/

Noseong Park (behack) wrote :

One more thing. After "swig -python -module messaging messaging.c", messaging_wrap.c is created. Add #include <messaging-menu.h> to the file such that gcc doesn't complain.

Margarita Manterola (marga-9) wrote :

This bug is duped to a bug that was related to the lack of examples. I understand that an example was needed in order to fix this one, but it's definitely not a dupe of that one.

Margarita Manterola (marga-9) wrote :

So, I removed the dupe. Just so that the info stays visible. The duped bug was:

https://bugs.launchpad.net/ubuntu/+source/libindicate/+bug/1315384
(14.04 libmessaging-menu lacks an example of how to use the features that used to be provided by python-indicate in 12.04)

Margarita Manterola (marga-9) wrote :

indicator-messages now includes an example of how this should be done. Could you please fix gm-notify, please? Thanks.

Mihai Capotă (mihaic) wrote :

Jason Conti (jconti) ported gm-notify to libmessaging-menu and posted the work in bug #1040259:
https://bugs.launchpad.net/ubuntu/+source/gm-notify/+bug/1040259/comments/40

The patch works for me.

Mateusz Balbus (mate-ob) wrote :

Merged Jason Conti branch to trunk

Changed in gm-notify:
status: Confirmed → Fix Committed
Mateusz Balbus (mate-ob) on 2016-01-20
Changed in gm-notify:
status: Fix Committed → Fix Released
no longer affects: gm-notify/1.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers