Doesn't open with large PDF file and eats CPU

Bug #500265 reported by zp on 2009-12-25
4
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gloobus-preview
Critical
BadChoice

Bug Description

http://dl.dropbox.com/u/1149078/Equipment%20%26%20Machine%20power%20supply.pdf

^That file is from https://bugs.launchpad.net/gloobus-preview/+bug/475517

All I get in the terminal is:

$ gloobus-preview Equipment\ \&\ Machine\ power\ supply.pdf
Gtk-Message: Failed to load module "gnomenu-panel": libgnomenu-panel.so: cannot open shared object file: No such file or directory
[INFO] Mime Type: application/pdf
Creating iPdf...

And it maxes 2 of my cores. Ram usage doesn't increase (around 0.7% of 2GB).
Tell me if you need more info to debug.

Changed in gloobus-preview:
assignee: nobody → BadChoice (guitarboy000)
importance: Undecided → Medium
status: New → Incomplete
status: Incomplete → New
Colin Mills (cm006a5077) wrote :

The latest gloobus-preview update from the TualatriX repo fails to install and gives the following error message :-

Setting up gloobus-preview (0.4.1-1ubuntu2) ...
g_module_open() failed for /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-psd.so: /usr/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-psd.so: cannot open shared object file: No such file or directory

After install, gloobus-preview fails to launch, so I assume that the problem is associated with the latest update.

Colin could you try gloobus-preview from trunk?

I think your problem might be related to packaging and not some bug in gloobus-preview.

BadChoice (guitarboy000) wrote :

This is because the 02 optimization,
The src/makefile.am needs to override the CXXFLAGS so no -02 option is passed to the compiler!!

Changed in gloobus-preview:
milestone: none → 0.4.2
status: New → Confirmed
importance: Medium → Critical
status: Confirmed → Fix Committed
tibike (eusunttibi) wrote :

same here, also for office docs like ods and odt
[WARNING] Config file couldn't be readed
[INFO] Mime Type: application/vnd.oasis.opendocument.text
Creating iOO...
just hangs with max. CPU.

tibike (eusunttibi) wrote :

great! I did the update and problem fixed! thank you !!!!!

bzr pull
./autogen.sh
make
sudo make install

JB (darkwolfxp-junio) on 2010-03-22
Changed in gloobus-preview:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
macwindux (macwindux) wrote :

I have the same problem. Tried to install as described in http://www.webupd8.org/2010/06/gloobus-preview-gets-slideshow-support.html:

sudo apt-get install bzr build-essential automake libtool bzr libgtk2.0-dev libgvfscommon-dev libgstreamer-plugins-base0.10-dev libcairomm-1.0-dev libtag1-dev libpoppler-glib-dev libgnomeui-dev unoconv libgtksourceview2.0-dev libspectre-dev libdjvulibre-dev libswfdec-0.8-dev libbz2-dev libdbus-glib-1-dev
cd && bzr get lp:gloobus-preview
cd gloobus-preview/
./autogen.sh --prefix=/usr/
make && sudo make install

...but it don't solve the problem.
Sometimes I get also the error, described in Bug #625448.

Ubuntu: 10.04

Alexandr Grigorcea (cahr-gr) wrote :

@guidobln, your problem is different, it does not open files greater than 100Kb, this limit is placed there because big files take an eternity for convertion to pdf

macwindux (macwindux) wrote :

Thats not the point. the pdf files which are bigger then 100kb can viewed without problems... Only if I try to open "office-like-files", like ods, odt, doc, xls then I get the error message.

I converted these "office" files (odt) with the unoconv program "odt2pdf" and it works fine, after I opened this new created pdf with gloobus. So why can gloobus not open directly the odt file, I think it used also the unoconv package?!

PS:
100kb files are in my opinion not really big, isn't it? Meanwhile the most files, especially pdf files, I have are bigger then 100kb.

Alexandr Grigorcea (cahr-gr) wrote :

@guidobln, as I said your problem is different, you are in the wrong bug report
anyway, 100Kb is not big for you, but it may be huge for a netbook
I've made some tries on my Athlon x2 5400+ and most files greater than 100Kb take just too much time to convert them to pdf, it is much faster to open them with abiword or gnumeric
I am working on a solution to make this limit configurable

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers