Problem with bookmark menu in Firefox 4 : changes in bookmarks do not appear in menu before restarting FF

Bug #749450 reported by Xavier Guillot on 2011-04-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Global menubar extension
Low
Chris Coulson
firefox (Ubuntu)
Low
Chris Coulson
Natty
Low
Chris Coulson

Bug Description

Global Menu Integration in Unity works fine with Firefox, even if sometimes there is a small delay (1 second) before Bookmark menu opens and some changes in bookmarks do not appear immediately in global menu.

If I open the window "Show all bookmarks" and make some changes in the main menu, ie moving some favorites (just saved before with "Mark this page") on the folders (to open them later in sub-menus), if I re-click on Bookmark in the Global Menu bar, the favorites I just moved still appear as before.

I have to close and restart Firefox to get the modifications visible.

"some changes in bookmarks do not appear immediately in global menu" : when I modify bookmarks / folders (add or move some bookmarks in different folders) in the "Show all bookmarks" window, this does not appear in Bookmark global menu until I restart Firefox...

summary: Problem with bookmark menu in Firefox : no address link provided when
- hovering bookmark
+ hovering and changes not appear in menu before restarting FF
Chris Coulson (chrisccoulson) wrote :

I can't really work out what bug you're reporting here, you seem to be mixing multiple issues. Could you please report separate bugs for each problem you have?

Changed in globalmenu-extension:
status: New → Incomplete
summary: - Problem with bookmark menu in Firefox : no address link provided when
- hovering and changes not appear in menu before restarting FF
+ Problem with bookmark menu in Firefox 4 : changes in bookmarks do not
+ appear in menu before restarting FF
Xavier Guillot (valeryan-24) wrote :

You're right, sorry, there were 2 "bugs", both concerning Firefox Bookmark Menu in Global Menubar extension, so I put 2 descriptions in once, I changed the title, bug description and will open another for the second one.

description: updated
Chris Coulson (chrisccoulson) wrote :

Not confirming your problem here. If I run both menus side-by-side, they show exactly the same contents as each other. However, there are some bugs affecting bookmark sorting where the menu isn't updated properly, but those are Firefox bugs and have been there for ages (eg, bug 401615)

Xavier Guillot (valeryan-24) wrote :

Sorry for the late answer, here is the details on how to reproduce the bug :

- If you surf and click on Bookmarks menu on Globalbar extension, then "Bookmark this page", the new bookmark well appears directly in the bookmark menu. Then, if you open "Show all bookmarks" and move the just saved favorite to a folder, also when you open Globalbar Bookmark menu, changes are done.

- BUT if you open Firefox and already have a bookmark saved in the main menu : for example in the picture joined, I run Firefox, and I had previously saved the "OpenERP - Universe", it appears in the main bookmarks menu and on the bokmarks windows.

In this "Show all bookmarks" window, if now I move this link to one of the subfolders of "Programmes Informatique Linix", it disappears from "Show all bookmarks" main menu window, but if I go to Firefox and run Bookmarks menu from Globalbar extension, "OpenERP - Universe" is still here, I can click it and go to the page...

If I restart Firefox, now it shows well in the folder I moved it to, and no more on the main menu.

When using normal Firefox bookmark menu, changes are immediately saved and shown on the menu bar.

See pictures 2 & 3 to understand.

In this example, ie opening Firefox with already "OpenERP - Universe" on the main menu, if I save a new bookmark and move it without restarting Firefox, this modification will be immediately visible, but not for "OpenERP", for this one I have to restart the program.

I hope it is more clear.

Xavier Guillot (valeryan-24) wrote :

Picture 2 : I moved the existing "OpenERP" bookmark in a subfolder but it still appears in Globalbar Bookmarks menu.

Xavier Guillot (valeryan-24) wrote :

Picture 3 : I've restarted Firefox, now OK this bokmark does not show anymore on the main menu and is well in the subfolder I moved it.

Chris Coulson (chrisccoulson) wrote :

Thanks for the instructions, I can confirm this now

Changed in globalmenu-extension:
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → Low
status: Incomplete → Triaged
Chris Coulson (chrisccoulson) wrote :

I've worked around this in globalmenu-extension now, but this actually seems to be a Firefox bug. The issue seems to be that calling PlacesMenu._cleanPopup() doesn't clear the _DOMElement from each placesNode, so we end up with out-of-date information on each node

Changed in globalmenu-extension:
status: Triaged → Fix Committed
affects: Ubuntu Natty → firefox (Ubuntu Natty)
Changed in globalmenu-extension:
milestone: none → 1.0.1
Changed in firefox (Ubuntu Natty):
status: Triaged → Fix Committed
Changed in globalmenu-extension:
status: Fix Committed → Fix Released
Chris Coulson (chrisccoulson) wrote :

The original commit introduced another regression. I've reworked the whole lot now, and will upload to Natty later

Chris Coulson (chrisccoulson) wrote :

s/another/a/

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 4.0+nobinonly-0ubuntu2

---------------
firefox (4.0+nobinonly-0ubuntu2) natty; urgency=low

  * Update globalmenu-extension to 1.0.1
    - Fixes LP: #749450 - bookmarks editor doesn't work properly

  * Added Spanish and Japanese translations for static quicklist entry
    - update debian/firefox-*.desktop.in
  * Fix LP: #727372 - URI handling is broken. Use GIO for checking if
    a particular URI scheme has a handler, rather than probing GConf
    - add debian/patches/default-uri-handler-check-use-gio.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden> Sat, 16 Apr 2011 23:21:03 +0100

Changed in firefox (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers