Cannot get rid of Menu Bar in Nightly

Bug #1017247 reported by keldo on 2012-06-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Global menubar extension
Medium
Chris Coulson
firefox (Ubuntu)
Medium
Chris Coulson
Quantal
Medium
Chris Coulson

Bug Description

Since the past few updates, I am seeing the Menu Bar in the Nightly window. Trying to remove it through 'Customize...' doesn't work; I even tried 'Restore default set' while in that window. I now see two menubars, one in the Unity taskbar (global menu) and the other in the Nightly Window. I want to remove the latter.

A screenshot is attached. Thanks!

Troubleshooting information:

  Application Basics

        Name
        Firefox-Trunk

        Version
        16.0a1

        User Agent
        Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:16.0) Gecko/16.0 Firefox/16.0

        Profile Directory

          Open Directory

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

        Crash Reports

          about:crashes

        Memory Use

          about:memory

  Extensions

        Name

        Version

        Enabled

        ID

        Adblock Plus
        2.1rc.3496
        true
        {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

        Add to Search Bar
        2.0
        true
        <email address hidden>

        Barlesque
        1.15
        true
        <email address hidden>

        BetterPrivacy
        1.68
        true
        {d40f5e7b-d2cf-4856-b441-cc613eeffbe3}

        Cleanest Addon Manager
        2.0
        true
        <email address hidden>

        Element Hiding Helper for Adblock Plus
        1.2.2
        true
        <email address hidden>

        EPUBReader
        1.4.2.1
        true
        {5384767E-00D9-40E9-B72F-9CC39D655D6F}

        Ghostery
        2.7.2
        true
        <email address hidden>

        Global Menu Bar integration
        3.3pre
        true
        <email address hidden>

        HTTPS-Everywhere
        2.1
        true
        <email address hidden>

        Locationbar²
        1.0.6
        true
        <email address hidden>

        NoScript
        2.4.7rc2
        true
        {73a6fe31-595d-460b-a920-fcc0f8843232}

        OpenDownload²
        3.2.1
        true
        {210249CE-F888-11DD-B868-4CB456D89593}

        Organize Search Engines
        1.7
        true
        <email address hidden>

        Reddit Enhancement Suite
        4.1.2
        true
        jid1-xUfzOsOFlzSOXg@jetpack

        Scriptish
        0.1.7
        true
        <email address hidden>

        Secure Login
        0.9.9
        true
        <email address hidden>

        Stylish
        1.2.6
        true
        {46551EC9-40F0-4e47-8E18-8E5CF550CFB8}

        Ubuntu Firefox Modifications
        2.0.3
        true
        <email address hidden>

        UI Fixer
        1.4.4
        true
        <email address hidden>

  Important Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.casesensitive
        1

        accessibility.typeaheadfind.flashBar
        0

        browser.cache.disk.capacity
        1048576

        browser.cache.disk.smart_size.first_run
        false

        browser.cache.disk.smart_size_cached_value
        798720

        browser.places.smartBookmarksVersion
        4

        browser.search.useDBForOrder
        true

        browser.startup.homepage
        about:config

        browser.startup.homepage_override.buildID
        20120624095559

        browser.startup.homepage_override.mstone
        16.0a1

        browser.tabs.animate
        false

        browser.tabs.warnOnClose
        false

        dom.ipc.plugins.enabled.nppdf.so
        true

        extensions.lastAppVersion
        16.0a1

        font.default.x-western
        sans-serif

        font.minimum-size.x-western
        11

        font.name.monospace.x-western
        Ubuntu Mono

        font.name.sans-serif.x-western
        Ubuntu

        font.name.serif.x-western
        DejaVu Serif

        font.size.fixed.x-western
        14

        network.cookie.lifetimePolicy
        2

        network.cookie.prefsMigrated
        true

        network.http.pipelining
        true

        network.http.pipelining.aggressive
        true

        network.http.pipelining.max-optimistic-requests
        8

        network.http.pipelining.ssl
        true

        network.http.proxy.pipelining
        true

        places.database.lastMaintenance
        1340470689

        places.history.expiration.transient_current_max_pages
        100749

        plugins.click_to_play
        true

        print.tmp.printerfeatures.PostScript/default.can_change_colorspace
        false

        print.tmp.printerfeatures.PostScript/default.can_change_downloadfonts
        false

        print.tmp.printerfeatures.PostScript/default.can_change_jobtitle
        false

        print.tmp.printerfeatures.PostScript/default.can_change_num_copies
        true

        print.tmp.printerfeatures.PostScript/default.can_change_orientation
        true

        print.tmp.printerfeatures.PostScript/default.can_change_paper_size
        true

        print.tmp.printerfeatures.PostScript/default.can_change_plex
        false

        print.tmp.printerfeatures.PostScript/default.can_change_printincolor
        true

        print.tmp.printerfeatures.PostScript/default.can_change_resolution
        false

        print.tmp.printerfeatures.PostScript/default.can_change_spoolercommand
        true

        print.tmp.printerfeatures.PostScript/default.colorspace.0.name
        default

        print.tmp.printerfeatures.PostScript/default.colorspace.count
        1

        print.tmp.printerfeatures.PostScript/default.has_special_printerfeatures
        true

        print.tmp.printerfeatures.PostScript/default.orientation.0.name
        portrait

        print.tmp.printerfeatures.PostScript/default.orientation.1.name
        landscape

        print.tmp.printerfeatures.PostScript/default.orientation.count
        2

        print.tmp.printerfeatures.PostScript/default.paper.0.height_mm
        210

        print.tmp.printerfeatures.PostScript/default.paper.0.is_inch
        false

        print.tmp.printerfeatures.PostScript/default.paper.0.name
        A5

        print.tmp.printerfeatures.PostScript/default.paper.0.width_mm
        148

        print.tmp.printerfeatures.PostScript/default.paper.1.height_mm
        297

        print.tmp.printerfeatures.PostScript/default.paper.1.is_inch
        false

        print.tmp.printerfeatures.PostScript/default.paper.1.name
        A4

        print.tmp.printerfeatures.PostScript/default.paper.1.width_mm
        210

        print.tmp.printerfeatures.PostScript/default.paper.2.height_mm
        420

        print.tmp.printerfeatures.PostScript/default.paper.2.is_inch
        false

        print.tmp.printerfeatures.PostScript/default.paper.2.name
        A3

        print.tmp.printerfeatures.PostScript/default.paper.2.width_mm
        297

        print.tmp.printerfeatures.PostScript/default.paper.3.height_mm
        279

        print.tmp.printerfeatures.PostScript/default.paper.3.is_inch
        true

        print.tmp.printerfeatures.PostScript/default.paper.3.name
        Letter

        print.tmp.printerfeatures.PostScript/default.paper.3.width_mm
        215

        print.tmp.printerfeatures.PostScript/default.paper.4.height_mm
        355

        print.tmp.printerfeatures.PostScript/default.paper.4.is_inch
        true

        print.tmp.printerfeatures.PostScript/default.paper.4.name
        Legal

        print.tmp.printerfeatures.PostScript/default.paper.4.width_mm
        215

        print.tmp.printerfeatures.PostScript/default.paper.5.height_mm
        431

        print.tmp.printerfeatures.PostScript/default.paper.5.is_inch
        true

        print.tmp.printerfeatures.PostScript/default.paper.5.name
        Tabloid

        print.tmp.printerfeatures.PostScript/default.paper.5.width_mm
        279

        print.tmp.printerfeatures.PostScript/default.paper.6.height_mm
        254

        print.tmp.printerfeatures.PostScript/default.paper.6.is_inch
        true

        print.tmp.printerfeatures.PostScript/default.paper.6.name
        Executive

        print.tmp.printerfeatures.PostScript/default.paper.6.width_mm
        190

        print.tmp.printerfeatures.PostScript/default.paper.count
        7

        print.tmp.printerfeatures.PostScript/default.plex.0.name
        default

        print.tmp.printerfeatures.PostScript/default.plex.count
        1

        print.tmp.printerfeatures.PostScript/default.resolution.0.name
        default

        print.tmp.printerfeatures.PostScript/default.resolution.count
        1

        print.tmp.printerfeatures.PostScript/default.supports_colorspace_change
        false

        print.tmp.printerfeatures.PostScript/default.supports_downloadfonts_change
        false

        print.tmp.printerfeatures.PostScript/default.supports_jobtitle_change
        false

        print.tmp.printerfeatures.PostScript/default.supports_orientation_change
        true

        print.tmp.printerfeatures.PostScript/default.supports_paper_size_change
        true

        print.tmp.printerfeatures.PostScript/default.supports_plex_change
        false

        print.tmp.printerfeatures.PostScript/default.supports_printincolor_change
        true

        print.tmp.printerfeatures.PostScript/default.supports_resolution_change
        false

        print.tmp.printerfeatures.PostScript/default.supports_spoolercommand_change
        true

        privacy.donottrackheader.enabled
        true

        privacy.sanitize.migrateFx3Prefs
        true

        privacy.sanitize.sanitizeOnShutdown
        true

        security.warn_viewing_mixed
        false

  Graphics

        Adapter Description
        Tungsten Graphics, Inc -- Mesa DRI Mobile Intel® GM45 Express Chipset

        Vendor ID
        Tungsten Graphics, Inc

        Device ID
        Mesa DRI Mobile Intel® GM45 Express Chipset

        Driver Version
        2.1 Mesa 8.0.2

        WebGL Renderer
        Tungsten Graphics, Inc -- Mesa DRI Mobile Intel® GM45 Express Chipset -- 2.1 Mesa 8.0.2

        GPU Accelerated Windows
        0

        AzureBackend
        skia

  JavaScript

        Incremental GC
        1

  Library Versions

        Expected minimum version

        Version in use

        NSPR
        4.9.2 Beta
        4.9.2 Beta

        NSS
        3.13.5.0 Basic ECC
        3.13.5.0 Basic ECC

        NSS Util
        3.13.5.0
        3.13.5.0

        NSS SSL
        3.13.5.0 Basic ECC
        3.13.5.0 Basic ECC

        NSS S/MIME
        3.13.5.0 Basic ECC
        3.13.5.0 Basic ECC

keldo (keldo) wrote :
visibility: private → public
Chris Coulson (chrisccoulson) wrote :

This is a bug in one of your other addons (Cleanest Addon Manager), which somehow prevents the UA stylesheet from our addon from loading.

You could have determined that before reporting this though. In future, please read our bug reporting guidelines before reporting a bug (https://wiki.ubuntu.com/MozillaTeam/Bugs). And please don't use the Launchpad interface for reporting bugs

Changed in ubuntu-mozilla-ppa-bugs:
status: New → Invalid
Chris Coulson (chrisccoulson) wrote :

Just to be clear - what happens here is that the "Cleanest Addon Manager" addon accesses (and hence, causes the initialization of) the stylesheet service from it's startup() bootstrap method.

Our menubar registers a UA stylesheet in its chrome.manifest which is used to set the menubar to display: none and the toolbar to min-height: 0. The stylesheet service registers this UA stylesheet when it starts, but the "Cleanest Addon Manager" causes it to start before extension chrome is registered for non-restartless addons - such as ours.

This isn't the first time something like this has come up (see https://bugzilla.mozilla.org/show_bug.cgi?id=693687, which was also caused by a restartless addon accessing internal services before extension chrome is registered).

There shouldn't be any reason why this problematic addon couldn't access the stylesheet service from an idle event, thus avoiding the issue.

However, as this may not be the only addon doing something like this, I may add a workaround for it in our extension by not relying on chrome registration to register our stylesheet (and doing it manually instead - much in the same way as Cleanest Addon Manager does) :(

affects: ubuntu-mozilla-ppa-bugs → globalmenu-extension
Changed in globalmenu-extension:
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → Medium
status: Invalid → Triaged
Changed in firefox (Ubuntu Quantal):
importance: Undecided → Medium
assignee: nobody → Chris Coulson (chrisccoulson)
status: New → Triaged
Chris Coulson (chrisccoulson) wrote :
Changed in globalmenu-extension:
status: Triaged → Fix Released
Chris Coulson (chrisccoulson) wrote :

Pentadactyl does the same thing as well

keldo (keldo) wrote :

Just FYI: I uninstalled Cleanest Addon Manager 2.0 and it didn't help, then I remembered you said something about restartless addons, so I downgraded to Adblock Plus 2.0.3 as well from 2.1rc. I don't see the second menubar anymore. Thank you for your assistance.

I apologize for not trying with a clean profile first; I asked about my issue on IRC before reporting it here. Maybe you can add information about the bug-reporting procedure in the 'PPA description' section at https://launchpad.net/~ubuntu-mozilla-daily/+archive/ppa

Changed in firefox (Ubuntu Quantal):
status: Triaged → Fix Committed
Chris Coulson (chrisccoulson) wrote :

Thanks. So it seems that there are quite a few third party addons which break it :(

Hopefully this workaround will be enough to prevent them from doing it. The fix will be in the next nightly build btw

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox - 14.0~b9+build1-0ubuntu1

---------------
firefox (14.0~b9+build1-0ubuntu1) quantal; urgency=low

  * New upstream release from the beta channel (FIREFOX_14_0b9_BUILD1)

  [ Chris Coulson <email address hidden> ]
  * Update globalmenu-extension to 3.3 prerelease r386
    - Fix LP: #1016081 - Menubar is not hidden when using the Firefox
      button outside of Unity
    - Fix LP: #775305 - An empty menu appears when FFChrome is installed
    - Fix LP: #1017247 - Menubar appears in the window as well as the
      Unity panel. Manually register our UA stylesheet rather than relying
      on this happening via chrome registration, to work around a bug
      in various bootstrapped third party addons (eg, pentadactyl),
      which initialize and use the stylesheet service before extension
      chrome is registered for non-restartless addons such as ours
    - Add a small delay when opening the menu with the keyboard, so that
      the additional items are added before the menu appears. Fixes an
      issue where keyboard focus isn't on the first item when opening the
      history menu with the keyboard
  * Apport hook improvements:
    - Sort preferences alphabetically in the apport data
    - Treat preferences set in default addons as default prefs so that
      they don't show up in apport data, unless the preference files have
      been modified
    - Support random pref files dropped in to the Firefox install folder, and
      preferences from application bundles
    - Fix ordering issues when loading preferences
  * Fix LP: #1013171 - Fully support Python 3 in the apport hook
    - update debian/apport/source_firefox.py.in

  [ Martin Pitt <email address hidden> ]
  * Add partial support for Python 3 in the apport hook (LP: #1013171)
    - update debian/apport/source_firefox.py.in
 -- Chris Coulson <email address hidden> Thu, 21 Jun 2012 11:15:26 +0100

Changed in firefox (Ubuntu Quantal):
status: Fix Committed → Fix Released
Scott Moser (smoser) wrote :

Just for cross reference, this appears to have fixed pentadactyl issue 883 (http://code.google.com/p/dactyl/issues/detail?id=883)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.