X Error of failed request: GLXBadContext

Bug #1572448 reported by rik on 2016-04-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
glmark2
Undecided
Unassigned

Bug Description

$ uname -a
Linux 3.19.0-32-generic #37~14.04.1-Ubuntu SMP Thu Oct 22 09:41:40 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

Nvidia Driver: Linux_64-bit : Version 361.42
Nvidia Card: GT 710

$ glmark2
------------------------------------------------------
X Error of failed request: GLXBadContext
  Major opcode of failed request: 154 (GLX)
  Minor opcode of failed request: 4 (X_GLXDestroyContext)
  Serial number of failed request: 31
  Current serial number in output stream: 31
------------------------------------------------------

$ glmark2 --debug
---------------------------------------------------------
Debug: Found 20 matching FB configs.
Debug: GLX chosen config ID: 0x10f Native Visual ID: 0x28
Debug: Buffer: 32 bits
Debug: Red: 8 bits
Debug: Green: 8 bits
Debug: Blue: 8 bits
Debug: Alpha: 8 bits
Debug: Depth: 24 bits
Debug: Creating XWindow W: 800 H: 600 VisualID: 0x28
X Error of failed request: GLXBadContext
  Major opcode of failed request: 154 (GLX)
  Minor opcode of failed request: 4 (X_GLXDestroyContext)
  Serial number of failed request: 31
  Current serial number in output stream: 31
------------------------------------------------------------

The above output errors are the same if I also run "sudo glmark2".

$ glxinfo | grep -i render
-------------------------------------------
direct rendering: Yes
OpenGL renderer string: GeForce GT 710/PCIe/SSE2
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,
    GL_KTX_buffer_region, GL_NVX_conditional_render, GL_NVX_gpu_memory_info,
    GL_NV_compute_program5, GL_NV_conditional_render,
    GL_NV_path_rendering, GL_NV_pixel_data_range, GL_NV_point_sprite,
    GL_ARB_compute_variable_group_size, GL_ARB_conditional_render_inverted,
    GL_KTX_buffer_region, GL_NVX_conditional_render, GL_NVX_gpu_memory_info,
    GL_NV_compute_program5, GL_NV_conditional_render,
    GL_NV_path_rendering, GL_NV_pixel_data_range, GL_NV_point_sprite,
-------------------------

 glxgears, glxinfo, nvidia-settings, ..., everything else boots up and works fine, except glmark2.

Notes:
 I've been using the same version of Glmark2, (from LinuxMint 17.3 repo's, with no problems.
Glmark2 has worked great on all my other (older) Video cards, on this same system, with Nvidia Driver Version 352 before.

However, the only thing that has changed is the fact that I had recently upgraded my Video card to an Nvidia GT-710, and I've had to install Nvidia Driver 361.42, or higher for this card to work.

 Any ideas on this?
If you need anythiong else, let me know.
Thanks ahead.

rik (bsdsolarux) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers