[SRU] capture-output fails in glance-control

Bug #978907 reported by J. Daniel Schmidt on 2012-04-11
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Glance
Low
J. Daniel Schmidt
Essex
Undecided
Unassigned
glance (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Chuck Short

Bug Description

The parameter --capture-output lets glance-control fail on some distributions (eg openSUSE) that do not have a /usr/bin/logger (but rather /bin/logger).

Using just "logger" instead of "/usr/bin/logger" would solve this issue.

Related branches

Fix proposed to branch: master
Review: https://review.openstack.org/6456

Changed in glance:
assignee: nobody → J. Daniel Schmidt (jdsn)
status: New → In Progress

Reviewed: https://review.openstack.org/6456
Committed: http://github.com/openstack/glance/commit/b8ce9caab211004555da3642ab6fb0b40bb85f9e
Submitter: Jenkins
Branch: master

commit b8ce9caab211004555da3642ab6fb0b40bb85f9e
Author: J. Daniel Schmidt <email address hidden>
Date: Wed Apr 11 15:19:55 2012 +0200

    search for logger in PATH

    fixes bug 978907

    Change-Id: I16a20982cc90f3857e20ab23e2b3f5d1aa2722a0

Changed in glance:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/6652
Committed: http://github.com/openstack/glance/commit/98913da774a7b5a978e010d754b77a352bd51ec9
Submitter: Jenkins
Branch: stable/essex

commit 98913da774a7b5a978e010d754b77a352bd51ec9
Author: J. Daniel Schmidt <email address hidden>
Date: Wed Apr 11 15:19:55 2012 +0200

    search for logger in PATH

    fixes bug 978907

    Change-Id: I16a20982cc90f3857e20ab23e2b3f5d1aa2722a0

tags: added: in-stable-essex
Brian Waldon (bcwaldon) on 2012-04-23
Changed in glance:
importance: Undecided → Low
Thierry Carrez (ttx) on 2012-05-23
Changed in glance:
milestone: none → folsom-1
status: Fix Committed → Fix Released

** Impact **

The parameter --capture-output lets glance-control fail on some distributions (eg openSUSE) that do not have a /usr/bin/logger (but rather /bin/logger).

Using just "logger" instead of "/usr/bin/logger" would solve this issue.

** Development Fix **

This has been fixed in the development release https://review.openstack.org/6456 and fixed in quantal

** Stable Fix **

This has been fixed in the stable/essex tree: https://review.openstack.org/6652

** Test Case **

None

** Regression Potential **

None this bug does not affect us.

summary: - capture-output fails in glance-control
+ [SRU] capture-output fails in glance-control
Chuck Short (zulcss) on 2012-06-08
Changed in nova (Ubuntu Precise):
assignee: nobody → Chuck Short (zulcss)
milestone: none → ubuntu-12.04.1
Chuck Short (zulcss) on 2012-06-11
affects: nova (Ubuntu) → glance (Ubuntu)
Changed in glance (Ubuntu):
status: New → In Progress
Chuck Short (zulcss) wrote :

 No test case needed since this is not a bug in Ubuntu but in upstream. We inherited this commit since we are uploading a new snapshot.

Hello J., or anyone else affected,

Accepted glance into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in glance (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Steve Langasek (vorlon) wrote :

> The parameter --capture-output lets glance-control fail on some distributions
> (eg openSUSE) that do not have a /usr/bin/logger (but rather /bin/logger).

There is no point in opening a bug against the Ubuntu package for an issue that has no impact in Ubuntu. That is not the intent of the SRU process.

Changed in glance (Ubuntu):
status: In Progress → Invalid
Changed in glance (Ubuntu Precise):
status: Fix Committed → Invalid
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glance - 2012.1+stable~20120608-5462295-0ubuntu2.2

---------------
glance (2012.1+stable~20120608-5462295-0ubuntu2.2) precise-proposed; urgency=low

  * New usptream snapshot. (LP: #1010473)
  * Resynchronize with stable/essex:
   - 5462295 Fix i18n in glance.notifier.notify_kombu. (LP: #983829)
   - 7a9e3a7 Omit Content-Length on chunked transfer. (LP: #981332)
   - 5838b63 Fix content type for qpid notifier. (LP: #980872)
   - 98913da search for logger in PATH. Fixes (LP: #978907)
   - f136e7e Ensure swift auth URL includes trailing slash. Fixes (LP: #979745)
  * debian/rules: Add ability to build tarballs from a git snapshot.
  * debian/patches/fix-pep8-ubuntu.patch: Fix pep8 errors.
 -- Chuck Short <email address hidden> Tue, 05 Jun 2012 10:43:12 -0400

Changed in glance (Ubuntu Precise):
status: Invalid → Fix Released
Thierry Carrez (ttx) on 2012-09-27
Changed in glance:
milestone: folsom-1 → 2012.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers