OpenStack Image Registry and Delivery Service (Glance)

Extraneous print of URL route appearing in some tests

Reported by Jay Pipes on 2012-03-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Glance
Low
Jay Pipes

Bug Description

See https://jenkins.openstack.org/job/gate-glance-python26/140/console

Note the printing of this:

localhost.localdomain - - [16/Mar/2012 19:52:39] "HEAD /images/foobar HTTP/1.1" 200 -
localhost.localdomain - - [16/Mar/2012 19:52:39] "GET /images/foobar HTTP/1.1" 200 -

In various places...

Also, I stumbled upon a spurious print statement on line 1042 of glance/tests/functional/test_api.py

Jay Pipes (jaypipes) on 2012-03-16
Changed in glance:
assignee: Jay Pipes (jaypipes) → nobody
Jay Pipes (jaypipes) wrote :

Further inspection, looks like the extraneous stdout output is due to the use of BaseHTTPServer in store_utils.setup_http()

Changed in glance:
assignee: nobody → Jay Pipes (jaypipes)

Fix proposed to branch: master
Review: https://review.openstack.org/5516

Changed in glance:
status: Confirmed → In Progress
Brian Waldon (bcwaldon) on 2012-03-19
Changed in glance:
milestone: none → essex-rc1

Reviewed: https://review.openstack.org/5516
Committed: http://github.com/openstack/glance/commit/c5cb723abb120cf6ea2041dffb1d6ca457e93cdb
Submitter: Jenkins
Branch: master

commit c5cb723abb120cf6ea2041dffb1d6ca457e93cdb
Author: Jay Pipes <email address hidden>
Date: Mon Mar 19 11:42:57 2012 -0400

    Fixes LP #957401 - Remove stray output on stderr

    * Removes a stray print statement that was in the
      API functional test
    * Does a NOOP log_message method to the request
      handler used in glance.tests.functional.store_utils
      to prevent output in test runs frmo the HTTP server

    Change-Id: I663593d9d666d35d3c2c1655598ef68304726fd4

Changed in glance:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-03-21
Changed in glance:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in glance:
milestone: essex-rc1 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers