OpenStack Image Registry and Delivery Service (Glance)

test suite doesn't work with sqlalchemy v7

Reported by Monty Taylor on 2011-11-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Glance
Low
Andrew Hutchings

Bug Description

When we tried aligning the glance pip-requires with nova in terms of sqlalchemy versions, we got a bunch of funky errors from sqlalchemy (which was installing 7.0.3) These may just be how the test suite runs, as people seemed to think it should have worked.

In any case - I'd really like to get us aligned on versions there - so we should probably fix this.

Andrew Hutchings (linuxjedi) wrote :

Problem 1:
test_bad_sql_connection fails and breaks _ENGINE for the rest of the SQL Alchemy based tests

Problem 2:
test_walk_versions also breaks

Not figured out the cause of these two yet.

Changed in glance:
assignee: nobody → Andrew Hutchings (linuxjedi)
Andrew Hutchings (linuxjedi) wrote :

My own notes so far:

Problem 1 I have a patch for (going to attach here until I have set everything up to do workflow)

Problem 2 migration_api.downgrade(options, version) version 9->8 failing.

Andrew Hutchings (linuxjedi) wrote :
Jay Pipes (jaypipes) on 2011-11-21
Changed in glance:
status: New → Confirmed
importance: Undecided → Low
Changed in glance:
status: Confirmed → In Progress
Jay Pipes (jaypipes) on 2012-02-06
Changed in glance:
milestone: none → essex-4

Reviewed: https://review.openstack.org/3814
Committed: http://github.com/openstack/glance/commit/e4db87ce4c2757b734b5fc62a82e1076c3367af0
Submitter: Jenkins
Branch: master

commit e4db87ce4c2757b734b5fc62a82e1076c3367af0
Author: Andrew Hutchings <email address hidden>
Date: Mon Feb 6 18:35:49 2012 +0000

    Make Glance work with SQLAlchemy 0.7

    Fix execption caught during tests
    Fix test failure wiping out engine in use

    Fixes bug 892754

    Change-Id: I9de6f077af656730c95bc715c2b765b0c49c7d3c

Changed in glance:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-02-29
Changed in glance:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in glance:
milestone: essex-4 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers