OpenStack Image Registry and Delivery Service (Glance)

Image cache has virtually no unit test coverage

Reported by Jay Pipes on 2011-10-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Glance
Medium
Jay Pipes

Bug Description

The image cache does not have an unit tests, and there is quite a bit of the code that can be easily unit tested.

Jay Pipes (jaypipes) on 2011-10-13
Changed in glance:
status: Confirmed → In Progress
assignee: nobody → Jay Pipes (jaypipes)

Reviewed: https://review.openstack.org/923
Committed: http://github.com/openstack/glance/commit/ad9e9ca3f741af714b9faf46224bf12e4a2693bd
Submitter: Jenkins
Branch: master

 status fixcommitted
 done

commit ad9e9ca3f741af714b9faf46224bf12e4a2693bd
Author: Jay Pipes <email address hidden>
Date: Tue Oct 18 09:27:27 2011 -0400

    Overhauls the image cache to be truly optional

    Fixes LP Bug#874580 - keyerror 'location' when fetch errors
    Fixes LP Bug#817570 - Make new image cache a true extension
    Fixes LP Bug#872372 - Image cache has virtually no unit test coverage

    * Adds unit tests for the image cache (coverage goes from 26% to 100%)
    * Removes caching logic from the images controller and places it into
      a removeable transparent caching middleware
    * Adds a functional test case that verifies caching of an image
      and subsequent cache hits
    * Removes the image_cache_enabled configuration variable, since it's
      now enabled by simply including the cache in the application
      pipeline
    * Adds a singular glance-cache.conf to etc/ that replaces the
      multiple glance-pruner.conf, glance-reaper.conf and
      glance-prefetcher.conf files
    * Adds documentation on enabling and configuring the image cache

    TODO: Add documentation on the image cache utilities, like reaper,
          prefetcher, etc.

    Change-Id: I58845871deee26f81ffabe1750adc472ce5b3797

Changed in glance:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2011-11-17
Changed in glance:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in glance:
milestone: essex-1 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers