OpenStack Image Registry and Delivery Service (Glance)

Glance client packaging uses non-required dependencies

Reported by Jay Pipes on 2011-09-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Glance
Medium
Jay Pipes
glance (Ubuntu)
Undecided
Jay Pipes

Bug Description

The python-glance package (supposed to contain only the Glance client) has a bunch of dependencies like eventlet and sqlalchemy that it shouldn't.

Related branches

Jay Pipes (jaypipes) on 2011-11-02
Changed in glance:
milestone: essex-1 → essex-2
Jay Pipes (jaypipes) on 2011-11-15
Changed in glance:
assignee: nobody → Jay Pipes (jaypipes)
status: Confirmed → In Progress
Jay Pipes (jaypipes) wrote :
Changed in glance (Ubuntu):
status: New → In Progress
assignee: nobody → Jay Pipes (jaypipes)

Reviewed: https://review.openstack.org/1619
Committed: http://github.com/openstack/glance/commit/1ab63ff5c97cfcbcebd993b57e209c0dd17c2ee8
Submitter: Jenkins
Branch: master

 status fixcommitted
 done

commit 1ab63ff5c97cfcbcebd993b57e209c0dd17c2ee8
Author: Jay Pipes <email address hidden>
Date: Tue Nov 15 11:49:10 2011 -0500

    Fixes LP Bug#861650 - Glance client deps

    This patch addresses the dependency proliferation in
    the glance client stuff. It removes references to modules
    that contain non-client-necessary libraries (like
    eventlet, xattr, sqlalchemy-migrate and sqlalchemy)
    by restructuring the modules slightly.

    Note that the additional httplib2 dependency is because
    that is used in the authentication strategy stuff in
    glance.common.auth. This could be rewritten to use httplib
    instead, further reducing the dependencies of the client lib.

    IMPORTANT NOTE: This patch changes the default entrypoint
    for the Images API router application, and therefore this
    should be merged along with the packaging changes in this
    branch:

    https://code.launchpad.net/~jaypipes/glance/ubuntu/+merge/82318

    Change-Id: I5dbc8584fb77e3e011fb6ff3532f792f5103e242

Jay Pipes (jaypipes) on 2011-12-15
Changed in glance (Ubuntu):
status: In Progress → Fix Committed
Changed in glance:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2011-12-15
Changed in glance:
status: Fix Committed → Fix Released
Chuck Short (zulcss) on 2012-03-07
Changed in glance (Ubuntu):
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in glance:
milestone: essex-2 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers