OpenStack Image Registry and Delivery Service (Glance)

bin/glance should handle cache being disabled

Reported by Brian Waldon on 2011-08-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Glance
Low
Jay Pipes

Bug Description

If the image cacheing middleware isn't deployed, the bin/glance commands will still try to make requests to /cached_images and result in a 404. We should handle that 404 and be more useful to the end-user.

Jay Pipes (jaypipes) on 2011-08-31
Changed in glance:
status: New → Confirmed
importance: Undecided → Low
milestone: none → diablo-rbp
Thierry Carrez (ttx) on 2011-09-12
Changed in glance:
milestone: diablo-rbp → 2011.3
Jay Pipes (jaypipes) on 2011-09-13
Changed in glance:
milestone: 2011.3 → none
Jay Pipes (jaypipes) on 2011-09-15
Changed in glance:
milestone: none → essex-1
Jay Pipes (jaypipes) on 2011-10-20
Changed in glance:
assignee: nobody → Jay Pipes (jaypipes)
Jay Pipes (jaypipes) on 2011-10-20
Changed in glance:
status: Confirmed → In Progress
Jay Pipes (jaypipes) on 2011-11-08
Changed in glance:
milestone: essex-1 → essex-2

Reviewed: https://review.openstack.org/1612
Committed: http://github.com/openstack/glance/commit/88780460895ccf77747c2db4450919e9daa17020
Submitter: Jenkins
Branch: master

 status fixcommitted
 done

commit 88780460895ccf77747c2db4450919e9daa17020
Author: Jay Pipes <email address hidden>
Date: Mon Nov 14 18:40:17 2011 -0500

    Fixes LP Bug#837817 - bin/glance cache disabled

    This patch removes the cache management commands
    from the main bin/glance client and puts them in
    a bin/glance-cache-manage program. It also adds
    a number of cache management calls to manage the
    cache queue via the HTTP API.

    The reason I moved the cache management commands
    into a separate utility is that I'm thinking towards
    the future, where we have a separate admin API, and
    having a separate management utility seemed like the
    best way to go.

    Change-Id: Ic916a72f39516a06be27ea6c8ef69eb9e1a70936

Changed in glance:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2011-12-14
Changed in glance:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in glance:
milestone: essex-2 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers