Stable maint check of stable/ocata failing

Bug #1747305 reported by Brian Rosmaita on 2018-02-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Glance
Critical
Brian Rosmaita

Bug Description

See http://lists.openstack.org/pipermail/openstack-stable-maint/2018-February/007241.html

Possibly caused by the eventlet issue recently fixed in master.

Will be complicated by the fact that glare still exists in this branch.

Changed in glance:
importance: Undecided → Critical

Reviewed: https://review.openstack.org/541385
Committed: https://git.openstack.org/cgit/openstack/glance/commit/?id=539c2fab9ec97a0bf63ceade47cab78d680a9ca8
Submitter: Zuul
Branch: stable/ocata

commit 539c2fab9ec97a0bf63ceade47cab78d680a9ca8
Author: Hemanth Makkapati <email address hidden>
Date: Wed Mar 22 10:42:01 2017 -0500

    Fix tests in stable/ocata

    Backport fixes due to distro changes affecting py27 causing stable
    maintenance check jobs to fail. This patch includes the following
    changes:

    - Invoke Monkey Patching for All Tests
      (cherry picked from commit 630402204e83b9e36c6822fc251fa06cf28963ac)

    - eventlet issue <0.22.0 (impacts functional tests)
    - fixtures must be imported absolutely or they aren't monkey patched
      (these two were cherry picked from commit
       3a638140ca7162902cea0405a7174dfad5868280)

    - extending eventlet issue <0.22.0 fix to glare
      (new in this patch, not required in pike or master)

    Closes-bug: #1747305
    Change-Id: Ib9f8a52136e25d1cb609d465ca5d859523d9acc6

tags: added: in-stable-ocata
Changed in glance:
status: In Progress → Fix Committed

This issue was fixed in the openstack/glance 14.0.1 release.

Changed in glance:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers