functional tests broken under py27

Bug #1744824 reported by Brian Rosmaita on 2018-01-22
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Glance
Critical
Unassigned

Bug Description

Over the weekend, the py27 tests began failing. To reproduce, you need to use an upgraded Ubuntu. It appears to be a distro package issue (though it's not clear ATM what package).

The failing tests are functional tests, the unit tests pass OK.

The py35 tests all pass (both unit and functional).

In the meantime, the requirements team has dropped the glance py27 tests from the requirements gate: https://review.openstack.org/#/c/536082/

We should fix soon to get our tests back into the gate to prevent other bad stuff from happening to glance.

Brian Rosmaita (brian-rosmaita) wrote :

Adding this note from Abhishek about troubleshooting, in case anyone has time to take a look:

I have tried to debug this in my environment but so far not able to find the reason.
While starting the api service from functional tests it fails to load middleware 'rootapp' from api-paste.ini

What I have done is added below lines in tox.ini to enable debugging of functional tests

[testenv:debug-functional]
basepython = python2.7
setenv =
  TEST_PATH = ./glance/tests/functional
commands = oslo_debug_helper {posargs}

and added pdb at
'https://github.com/openstack/glance/blob/master/glance/tests/functional/__init__.py#L770'

While executing each functional test, it creates the temp directory at location /tmp/tmp* where it stores config, paste.ini and other required files.

Steve McLellan (sjmc7) wrote :

Looks like this is affecting searchlight too (which is the same codebase from a couple of years back)

Brian Rosmaita (brian-rosmaita) wrote :

Good summary of probable cause and solution here: http://lists.openstack.org/pipermail/openstack-dev/2018-January/126580.html

Erno has a patch up applying the fix to glance: https://review.openstack.org/#/c/537951/

Reviewed: https://review.openstack.org/537951
Committed: https://git.openstack.org/cgit/openstack/glance/commit/?id=6f63d28d9b8727409fd982d5920846a942b6d43e
Submitter: Zuul
Branch: master

commit 6f63d28d9b8727409fd982d5920846a942b6d43e
Author: Erno Kuvaja <email address hidden>
Date: Thu Jan 25 16:16:22 2018 +0000

    Fix py27 eventlet issue <0.22.0

    Closes-Bug: #1744824

    Change-Id: Ib9f8a52136e25d1cb609d465ca5d859523d9acc6

Changed in glance:
status: Triaged → Fix Released
Changed in glance:
milestone: queens-3 → queens-rc1

This issue was fixed in the openstack/glance 16.0.0.0rc1 release candidate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers