packstack installation failure on centos7

Bug #1695226 reported by balakrishnan on 2017-06-02

This bug report was converted into a question: question #642022: packstack installation failure on centos7.

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Glance
Undecided
Unassigned

Bug Description

i creating packstack control node(ocata) in centos 7 getting below error during installation.

Copying Puppet modules and manifests [ DONE ]
Applying 10.106.138.248_controller.pp
10.106.138.248_controller.pp: [ ERROR ]
Applying Puppet manifests [ ERROR ]

ERROR : Error appeared during Puppet run: 10.106.138.248_controller.pp
Error: Failed to apply catalog: Command: 'openstack ["flavor", "list", "--quiet", "--format", "csv", ["--long", "--all"]]' has been running for more than 40 seconds (tried 8, for a total of 170 seconds)
You will find full trace in log /var/tmp/packstack/20170601-160446-NM4KSV/manifests/10.106.138.248_controller.pp.log
Please check log file /var/tmp/packstack/20170601-160446-NM4KSV/openstack-setup.log for more information
Additional information:
 * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components.
 * File /root/keystonerc_admin has been created on OpenStack client host 10.106.138.248. To use the command line tools you need to source the file.
 * To access the OpenStack Dashboard browse to http://10.106.138.248/dashboard .
Please, find your login credentials stored in the keystonerc_admin in your home directory.

balakrishnan (balakrishnank) wrote :
balakrishnan (balakrishnank) wrote :
description: updated
balakrishnan (balakrishnank) wrote :

can any one look into the bug ?

Changed in glance:
status: New → Invalid
status: Invalid → New
Brian Rosmaita (brian-rosmaita) wrote :

Sorry to take so long to get to this. I looked through the logs you posted, and this doesn't seem to be a glance-specific problem. It looks like the error is occurring during you packstack installation itself, not with specific components. Could you provide more information about the particular problem you are seeing with glance?

Changed in glance:
status: New → Incomplete
Amer Hwitat (amer.hwitat) wrote :

it's the RAM and CPU of the VM .. I have this problem installing ceilometer and ironic on my VM ...

openstack ["flavor", "list", "--quiet", "--format", "csv", ["--long", "--all"]]' has been running for more than 40 seconds (tried 4, for a total of 170 seconds)

or maybe it's nova ... but all the errors I had in --allinone is after I added Ironic installation to the answer file

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions