Metadata defintions in etc/metadefs are not included in Python packages

Bug #1469869 reported by Ian Cordasco
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Glance
Fix Released
Undecided
Unassigned

Bug Description

The files in etc/metadefs in the Glance repository are not included in either the tarball or wheel when one runs

    python setup.py sdist bdist_wheel

These should be included by default and installed so they can be used. Since wheels should not be allowed to write to paths outside of the directory the package is installed in,

    glance-manage db_load_metadefs

Should also look in the installed directory path for etc/metadefs when loading them.

This is a problem in every version of Glance that was meant to include those metadata definitions. Since this does not prevent functionality from working (since a user could download the files to /etc/metadefs and run the command), I do not think this has backport potential.

Tags: metadef
Ian Cordasco (icordasc)
description: updated
Revision history for this message
Ian Cordasco (icordasc) wrote :

lifeless was kind enough to provide http://docs.openstack.org/developer/pbr/#files as a reference for the best way to do this with pbr. It needs some testing first to make sure we get the right solution.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to glance (master)

Reviewed: https://review.openstack.org/206790
Committed: https://git.openstack.org/cgit/openstack/glance/commit/?id=f9c4312ab155a8ae44628e913f62de451080dea3
Submitter: Jenkins
Branch: master

commit f9c4312ab155a8ae44628e913f62de451080dea3
Author: Ian Cordasco <email address hidden>
Date: Tue Jul 28 21:01:07 2015 -0500

    Include metadefs files in all packages

    Previously, metadefs were only shipped in archives of the entire
    repository. There's been a recent push in the operator community to
    deploy from source, including building wheels and installing using them.
    In order for the deployers to take advantage of metadefs as intended.

    Change-Id: I1d7eacc19feed34f3e9029d11865e788bb4d4a8c
    Closes-bug: 1469869

Changed in glance:
status: New → Fix Committed
Thierry Carrez (ttx)
Changed in glance:
milestone: none → liberty-3
Thierry Carrez (ttx)
Changed in glance:
status: Fix Committed → Fix Released
Thierry Carrez (ttx)
Changed in glance:
milestone: liberty-3 → 11.0.0
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers