No results returned when listing images passing in the 'created_at' property as a filter

Bug #1439827 reported by Luke Wollney on 2015-04-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Glance
Undecided
Unassigned

Bug Description

Overview:
When making the list images request, passing in a datetime for the created_at property, there are no results returned.

Steps to reproduce:
1) Create an image, note the image's created_at property
2) Perform a list images request passing in the created_at property via GET /images?created_at=<datetime>
3) Notice no results are returned

Expected:
Return a list of images with the specified created_at datetime

Actual:
No results are returned

Kamil Rykowski (kamil-rykowski) wrote :

Not able to reproduce it. I've image which created_at field is set to "2015-04-08T07:57:08Z" and I can easily get it using

http://localhost:9292/v2/images?created_at=2015-04-08T07:57:08Z

or

http://localhost:9292/v2/images?created_at=2015-04-08T07:57:08

and even

http://localhost:9292/v2/images?created_at=2015-04-08-07:57:08

Changed in glance:
status: New → Invalid
Luke Wollney (luke-wollney) wrote :

After further investigation, and to Kamil's point, using the created_at filter works when using the following formats:

2015-04-08T07:57:08Z
2015-04-08T07:57:08
2015-04-08-07:57:08

However, it does not work when using the following format:

2015-04-08-07:57:08+00:00

When using the updated_at image property as a filter, the above format does work. To be consistent, the same formats should work for both filters.

Changed in glance:
status: Invalid → New
Kamil Rykowski (kamil-rykowski) wrote :

What database engine are you using? I still can't reproduce the mentioned issue. Both queries work fine for me:

http://localhost:9292/v2/images?created_at=2015-04-10-13:40:06+00:00
http://localhost:9292/v2/images?created_at=2015-04-10-13:40:06+NO123+JUST_TEST

Changed in glance:
status: New → Incomplete
Luke Wollney (luke-wollney) wrote :

Let me assign this to one of the devs and see if they can reproduce. Thank you very much.

Luke Wollney (luke-wollney) wrote :

Ah, nevermind. I see that I can't assign it directly. Let me email them and ask them to attempt to reproduce this. Thank you again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers