Openstack installation: Devstack- Failed to upload image (500 Internal Server Error) - stable/juno

Bug #1387399 reported by Muralikrishnan Ragupathiraju on 2014-10-29
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Glance
Undecided
Feilong Wang

Bug Description

Issue:
-------
Dev stack installation Failed: Failed to upload image - 500 Internal Server Error

Steps:
---------
Brand new install using
1.) git clone https://git.openstack.org/openstack-dev/devstack -b stable/juno
2.) $devstack/ ./stack.sh
3.) Failed with below error.

Note: Couple of weeks back i was able to install successfully. but recent code changes braking the installation

localrc:
---------
https://gist.github.com/anonymous/135e79d34e6b371f3c7f

Glance api log:
----------------
https://gist.github.com/anonymous/82639133f9061c7e7190

stackrc.log
---------------
2014-10-29 13:25:18.719 | + openstack --os-token a176744d9a474494aece85e99745c4e8 --os-url http://10.201.125.11:9292 image create ubuntu_mysql --public --container-format=bare --disk-format qcow2
2014-10-29 13:26:12.674 | WARNING: urllib3.connectionpool HttpConnectionPool is full, discarding connection: 10.201.125.11
2014-10-29 13:26:12.674 | ERROR: openstack <html>
2014-10-29 13:26:12.674 | <head>
2014-10-29 13:26:12.674 | <title>500 Internal Server Error</title>
2014-10-29 13:26:12.674 | </head>
2014-10-29 13:26:12.674 | <body>
2014-10-29 13:26:12.675 | <h1>500 Internal Server Error</h1>
2014-10-29 13:26:12.675 | Failed to upload image ea100521-3cd9-41c2-9c11-529fdec0154b<br /><br />
2014-10-29 13:26:12.675 |
2014-10-29 13:26:12.675 | </body>
2014-10-29 13:26:12.675 | </html> (HTTP 500)
2014-10-29 13:26:12.704 | + exit_trap
2014-10-29 13:26:12.705 | + local r=1
2014-10-29 13:26:12.705 | ++ jobs -p
2014-10-29 13:26:12.713 | + jobs=
2014-10-29 13:26:12.713 | + [[ -n '' ]]
2014-10-29 13:26:12.713 | + kill_spinner
2014-10-29 13:26:12.733 | + '[' '!' -z '' ']'
2014-10-29 13:26:12.733 | + [[ 1 -ne 0 ]]
2014-10-29 13:26:12.733 | + echo 'Error on exit'
2014-10-29 13:26:12.733 | Error on exit
2014-10-29 13:26:12.733 | + [[ -z /opt/stack/logs ]]
2014-10-29 13:26:12.733 | + /home/mragupat/devstack/tools/worlddump.py -d /opt/stack/logs
2014-10-29 13:26:12.972 | + exit 1

Feilong Wang (flwang) on 2014-10-29
Changed in glance:
assignee: nobody → Fei Long Wang (flwang)
Feilong Wang (flwang) wrote :

Just tried this on my local env, I can't reproduce this issue with latest devstack version.

Changed in glance:
status: New → Invalid
Changed in glance:
status: Invalid → Confirmed

I just updated my devstack (git pull), changed nothing in the configuration, and the issue just disappeared.

It seams like this issue happens from time to time since the bug was reported on 2014-10-29, not reproducible on 2014-10-30, reappeared on 2015-01-28 and disappeared again on 2015-02-03...

Changed in glance:
status: Confirmed → Incomplete
lakshmipathi (lakshmipathi-g) wrote :

It appears again with kilo - I'm unable to figure it out.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers