functional tests fail due to leftover pyc files

Bug #1015181 reported by Alex Meade on 2012-06-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Glance
Wishlist
Alex Meade

Bug Description

Unlike in nova, glance does not clean up *.pyc files that are left over. This causes previous errors such as syntax errors to remain in the pyc files and cause errors with the functional tests.

Alex Meade (alex-meade) on 2012-06-19
Changed in glance:
status: New → In Progress
assignee: nobody → Alex Meade (alex-meade)
Brian Waldon (bcwaldon) on 2012-06-19
Changed in glance:
importance: Undecided → Wishlist

Reviewed: https://review.openstack.org/8700
Committed: http://github.com/openstack/glance/commit/0c0fd6acaaa39fd113f96f7e65cd1eb61f49bf26
Submitter: Jenkins
Branch: master

commit 0c0fd6acaaa39fd113f96f7e65cd1eb61f49bf26
Author: Alex Meade <email address hidden>
Date: Tue Jun 19 12:07:12 2012 -0400

    Clean up .pyc files before running tests.

    Fixes bug 1015181

    Change-Id: I5628de56464f882f804522c66d9ffbe35a3b21e1

Changed in glance:
status: In Progress → Fix Committed
Alex Meade (alex-meade) wrote :

NOTE: This bug does not apply when using tox

Also, it appears to be caused by having corrupt .pyc files, which could result from having syntax errors and then switch branches where there are no long syntax errors but the pyc has not been cleaned.

Thierry Carrez (ttx) on 2012-07-04
Changed in glance:
milestone: none → folsom-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-09-27
Changed in glance:
milestone: folsom-2 → 2012.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers