cinder store still uses the deprecated v2 api by default

Bug #1915602 reported by Takashi Kajinami
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
glance_store
Fix Released
Undecided
Unassigned

Bug Description

Currently default of the cinder_catalog_info is still "volumev2::publicURL".
This means that cinder store still depends on the deprecated v2 api instead of the current v3 api unless users/operators explicitly set that parameter or some other credentials parameters like cinder_store_user_name.

summary: - cinder store still uses the deprecated volumev2 api by default
+ cinder store still uses the deprecated v2 api by default
description: updated
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/glance_store 2.5.0

This issue was fixed in the openstack/glance_store 2.5.0 release.

Revision history for this message
Takashi Kajinami (kajinamit) wrote :

This was fixed by https://review.opendev.org/c/openstack/glance_store/+/775497 , which was already released as part of glance_store 2.5.0 .

Changed in glance-store:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers