interface function for multihash not wrapped correctly

Bug #1784420 reported by Brian Rosmaita on 2018-07-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
glance_store
Status tracked in Stein
Rocky
Critical
Brian Rosmaita
Stein
Critical
Brian Rosmaita

Bug Description

The most recent glance_store release contains support for computing secure hash values of stored data, but the function called by Glance to store data was not wrapped correctly. As a result, the computed secure hash value is not available to Glance.

Need to wrap store_add_to_backend_with_multihash() so that Glance can use it.

Changed in glance-store:
status: Triaged → In Progress
Brian Rosmaita (brian-rosmaita) wrote :
summary: - missing multihash version of interface function
+ interface function for multihash not wrapped correctly

Reviewed: https://review.openstack.org/587098
Committed: https://git.openstack.org/cgit/openstack/glance_store/commit/?id=4d4cf1559cf393a2a10a458f83209cbeb2756e49
Submitter: Zuul
Branch: master

commit 4d4cf1559cf393a2a10a458f83209cbeb2756e49
Author: Brian Rosmaita <email address hidden>
Date: Mon Jul 30 11:54:27 2018 -0400

    Wrap interface function for multihash correctly

    The store_add_to_backend_with_multihash() function was not wrapped
    correctly so that Glance could consume the secure hash value. This
    patch adds the correct wrapping.

    Closes-bug: #1784420

    Change-Id: I7a94dfffb61fc212abb58c1e1aec5884474b6aa8

Changed in glance-store:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/587516
Committed: https://git.openstack.org/cgit/openstack/glance_store/commit/?id=cfd0567b4f22760aa5526bdc0f955213084b5222
Submitter: Zuul
Branch: stable/rocky

commit cfd0567b4f22760aa5526bdc0f955213084b5222
Author: Brian Rosmaita <email address hidden>
Date: Mon Jul 30 11:54:27 2018 -0400

    Wrap interface function for multihash correctly

    The store_add_to_backend_with_multihash() function was not wrapped
    correctly so that Glance could consume the secure hash value. This
    patch adds the correct wrapping.

    Closes-bug: #1784420

    (cherry picked from commit 4d4cf1559cf393a2a10a458f83209cbeb2756e49)

    Change-Id: I7a94dfffb61fc212abb58c1e1aec5884474b6aa8

tags: added: in-stable-rocky

This issue was fixed in the openstack/glance_store 0.26.1 release.

This issue was fixed in the openstack/glance_store 0.27.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers