Only the last result gets returned

Reported by Luke on 2011-05-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gkeyring
Fix Released
Undecided
Kamil Páral

Bug Description

gkeyring v0.2.3 from pypi

Running gkeyring where there are multiple results expected, i.e. gkeyring -p user=$USER and $USER has passwords for multiple servers, only returns the last result.

The problem is line 223 - "results.append(result)" needs to be indented again so it is within the "for match in matches:" loop on line 214.

Changed in gkeyring:
milestone: none → 0.2.4
assignee: nobody → Kamil Páral (kamil.paral)
status: New → In Progress
Kamil Páral (kamil.paral) wrote :

This should be fixed in revision 25. Can you please checkout the latest code and try?

Changed in gkeyring:
status: In Progress → Fix Committed
Changed in gkeyring:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers