git

typo in git-gui, located lib/sshkey.tcl:11

Bug #879427 reported by Joel Pickett
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
git
Fix Committed
Undecided
Benjamin Kerensa

Bug Description

found this while translating into en_AU

in template - "git-gui" under
lib/sshkey.tcl:11

"Generation succeded, but no keys found."

should be "succeeded"

Related branches

Changed in git (Ubuntu):
status: New → Fix Committed
assignee: nobody → Dejan Ribič (dejan-ribic)
Revision history for this message
Dejan Ribič (dejan-ribic) wrote :

hi i fixed typo in precise branch, merge from git/dejan branch. here i am attaching a diff file, i am still new at bug fixing so i appologize in advance if i've done something wrong

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "sshkeys.tcl.diff" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Revision history for this message
Anders Kaseorg (andersk) wrote :

Hi Dejan, can you please submit your patch upstream by following the directions in Documentation/SubmittingPatches? Then the fix will make its way into Ubuntu after upstream releases a new version.

(It would be inconvenient for Ubuntu to take the patch directly because we would stop getting automatic updates from Debian, and manual work would be required to merge each new version—that’s not worth it for a simple spelling fix.)

Changed in git (Ubuntu):
status: Fix Committed → Confirmed
Revision history for this message
Dejan Ribič (dejan-ribic) wrote :

I sent the .diff file to git mailing list with [PATCH] prefix in subject, so I guess that will make it in Upstream version.

Revision history for this message
Dejan Ribič (dejan-ribic) wrote :

Just a quick update: the fix is now in git-gui, which apparently is hosted seperatly, so when they merge with git-core the fix will be here.

Revision history for this message
Anders Kaseorg (andersk) wrote :

Thanks! This was merged upstream in Git 1.7.9-rc0 (at v1.7.9-rc0~75^2~10), which is now in Debian experimental. After 1.7.9 final is released, Ubuntu will pick up the fix from Debian, probably in precise or precise+1.

(If you’d like to test the release candidate on Ubuntu, I’m building 1.7.9-rc0 packages in this PPA; they should be ready later today: https://launchpad.net/~git-core/+archive/candidate .)

Changed in git (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Anders Kaseorg (andersk) wrote :

git (1:1.7.9-1) unstable; urgency=low

  * merge branch debian-experimental.
  * new upstream release (closes: #657262).
  * debian/diff/0016-unix-socket-handle-long-socket-...diff: remove;
    applied upstream.
  * debian/changelog: add missing parenthesis to 1:1.7.9~rc1-1 entry.

 -- Jonathan Nieder <email address hidden> Fri, 27 Jan 2012 21:23:27 -0600

Changed in git (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Benjamin Kerensa (bkerensa) wrote :

I do not feel this bug was fixed since the typos still exist in both Ubuntu and Debian and further in the git-gui source.

http://article.gmane.org/gmane.comp.version-control.git/192299

I have submitted a patch to debian and git to resolve this.

Revision history for this message
Daniel Holbach (dholbach) wrote :

The issue is still there.

Changed in git (Ubuntu):
status: Fix Released → In Progress
Revision history for this message
Benjamin Kerensa (bkerensa) wrote :

@Daniel Holbach:

I did submit a patch fixing this and I'm unsure how long it will take upstream to accept it but it does indeed fix the issue and notably Debian did not even want to take it so I had to pass it all the way to Git upstream.

Changed in git (Ubuntu):
assignee: Dejan Ribič (dejan-ribic) → nobody
assignee: nobody → Benjamin Kerensa (bkerensa)
affects: git (Ubuntu) → git
Revision history for this message
Anders Kaseorg (andersk) wrote :

It was accepted here:
http://repo.or.cz/w/git-gui.git/commit/ef42057deae1aca6c3716019a3672809785f0a96
which will be pulled into Git upstream on the next merge of git-gui.

Revision history for this message
Benjamin Kerensa (bkerensa) wrote :

The patch has been applied in Git and now awaiting for Debian to get it and then us :)

Changed in git:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers